Simplify new-note marker placement - always in the centre
[rails.git] / INSTALL.md
index 7959543444ba6ebd6c52e84f2ff0e8cd852e4e73..09e3b12f7827a92971c129dd4ef49dd6aa4449a5 100644 (file)
@@ -3,11 +3,12 @@
 These instructions are designed for setting up The Rails Port for development and testing.
 If you want to deploy the software for your own project, then see the notes at the end.
 
+You can install the software directly on your machine, which is the traditional and probably best-supported approach. However, there is an alternative which may be easier: Vagrant. This installs the software into a virtual machine, which makes it easier to get a consistent development environment and may avoid installation difficulties. For Vagrant instructions, see [VAGRANT.md](VAGRANT.md).
+
 These instructions are based on Ubuntu 12.04 LTS, which is the platform used by the OSMF servers.
 The instructions also work, with only minor amendments, for all other current Ubuntu releases, Fedora and MacOSX
 
-We don't recommend attempting to develop or deploy this software on Windows. If you need to use Windows, then
-try developing this sofware using Ubuntu in a virtual machine.
+We don't recommend attempting to develop or deploy this software on Windows. If you need to use Windows, then try developing this sofware using Ubuntu in a virtual machine, or use [Vagrant](VAGRANT.md).
 
 ## Dependencies
 
@@ -17,22 +18,26 @@ of packages required before you can get the various gems installed.
 
 ## Minimum requirements
 
-* Ruby 1.8.7 or 1.9.3
+* Ruby 1.9.3
 * RubyGems 1.3.1+
 * Postgres 8.3+
 * ImageMagick
 * Bundler
+* Javascript Runtime
 
 These can be installed on Ubuntu 10.10 or later with:
 
 ```
-sudo apt-get install ruby libruby ruby-dev rdoc ri ruby-bundler rubygems \
-                     libmagickwand-dev libxml2-dev libxslt1-dev \
+sudo apt-get install ruby1.9.1 libruby1.9.1 ruby1.9.1-dev ri1.9.1 \
+                     libmagickwand-dev libxml2-dev libxslt1-dev nodejs \
                      apache2 apache2-threaded-dev build-essential git-core \
                      postgresql postgresql-contrib libpq-dev postgresql-server-dev-all \
                      libsasl2-dev
+sudo gem1.9.1 install bundler
 ```
 
+Note that the "1.9.1" Ubuntu packages do in fact contain ruby 1.9.3.
+
 ### Alternative platforms
 
 #### Fedora
@@ -41,7 +46,7 @@ For Fedora, you can install the minimum requirements with:
 
 ```
 sudo yum install ruby ruby-devel rubygem-rdoc rubygem-bundler rubygems \
-                 libxml2-devel \
+                 libxml2-devel js \
                  gcc gcc-c++ git \
                  postgresql postgresql-server postgresql-contrib postgresql-devel \
                  perl-podlators