Fix new rubocop warnings
[rails.git] / lib / redactable.rb
index c46b327..d827cfd 100644 (file)
@@ -1,4 +1,4 @@
-require 'osm'
+require "osm"
 
 module Redactable
   def self.included(base)
@@ -13,10 +13,10 @@ module Redactable
 
   def redact!(redaction)
     # check that this version isn't the current version
-    fail OSM::APICannotRedactError.new if self.is_latest_version?
+    raise OSM::APICannotRedactError if is_latest_version?
 
     # make the change
     self.redaction = redaction
-    self.save!
+    save!
   end
 end