Don't allow libxml 2.0.0 and later to be used
authorTom Hughes <tom@compton.nu>
Wed, 11 May 2011 22:06:19 +0000 (23:06 +0100)
committerTom Hughes <tom@compton.nu>
Wed, 11 May 2011 22:06:19 +0000 (23:06 +0100)
config/environment.rb

index ce5a893..15ec245 100644 (file)
@@ -18,7 +18,7 @@ Rails::Initializer.run do |config|
   unless  STATUS == :database_offline
     config.gem 'composite_primary_keys', :version => '2.2.2'
   end
-  config.gem 'libxml-ruby', :version => '>= 1.1.1', :lib => 'libxml'
+  config.gem 'libxml-ruby', :version => ['>= 1.1.1', ' < 2.0.0'], :lib => 'libxml'
   config.gem 'rmagick', :lib => 'RMagick'
   config.gem 'oauth', :version => '>= 0.4.3'
   config.gem 'oauth-plugin', :version => '0.3.14'