Remove ancient documentation.
authorAndy Allan <andy@gravitystorm.co.uk>
Thu, 19 Jun 2014 13:59:13 +0000 (14:59 +0100)
committerAndy Allan <andy@gravitystorm.co.uk>
Thu, 19 Jun 2014 13:59:13 +0000 (14:59 +0100)
doc/README_FOR_APP [deleted file]

diff --git a/doc/README_FOR_APP b/doc/README_FOR_APP
deleted file mode 100644 (file)
index 863e19d..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-This is the OpenStreetMap rails server codebase. Documentation is currently
-extremely incomplete. Please help by writing docs and moving any SQL you
-see to use models etc.
-
-=INSTALL
-
-Full information is available at 
-http://wiki.openstreetmap.org/wiki/Rails
-
-* Get rails working (http://www.rubyonrails.org/)
-* Make your db (see db/README)
-* Install ruby libxml bindings:
-    sudo apt-get install libxml-ruby1.8 libxml-parser-ruby1.8
-* Install ImageMagick libraries & ruby gem:
-    sudo apt-get install libmagickcore-dev
-    sudo gem install rmagick
-* Install primary keys plugin for active record (minimum version 0.9.1)
-    sudo gem install composite_primary_keys
-* Make sure you have a MTA listening on localhost:25 if you want mail
-    sudo apt-get install exim4
-* Start the server
-    script/server
-* Thats it
-
-=API CHANGES FOR EDITOR AUTHORS
-
-See
-
-The information about the next version of the protocol API 0.6 is available at 
-http://wiki.openstreetmap.org/wiki/OSM_Protocol_Version_0.6
-http://wiki.openstreetmap.org/wiki/REST
-
-=HACKING
-
-* Log in to your site (proably localhost:3000)
-* Create a user and confirm it (by setting the active flag to true in the users table of the database
-* You want to play with the API (probably at http://localhost:3000/api/0.6/node/create etc)
-* Lots of tests are needed to test the API. To run the tests use 
-    rake test
-* Lots of little things to make the site work like the old one.
-
-=Bugs
-
-See the 'rails_port' component for bugs:
-http://trac.openstreetmap.org/query?status=new&status=assigned&status=reopened&component=website&order=priority