Stop wiki update script trying to be "helpful"
authorTom Hughes <tom@compton.nu>
Wed, 26 Sep 2018 21:43:30 +0000 (22:43 +0100)
committerTom Hughes <tom@compton.nu>
Wed, 26 Sep 2018 21:43:30 +0000 (22:43 +0100)
Instead of trying to advise how to import some (but not all) of
the modules, just require them in the normal way.

Closes #1763

script/misc/update-wiki-pages

index 84e1e8a..3f15c0d 100755 (executable)
@@ -3,20 +3,11 @@ use 5.010;
 use strict;
 use warnings;
 
 use strict;
 use warnings;
 
-use Pod::Usage ();
-use Getopt::Long ();
-
-BEGIN {
-    eval "require MediaWiki::API; require YAML::XS;" or do {
-        print "You have to install some modules via CPAN to run this:\n";
-        print "   sudo cpanp MediaWiki::API YAML::XS\n";
-        exit 1;
-    };
-}
-
+use Getopt::Long;
+use Pod::Usage;
 use MediaWiki::API;
 use MediaWiki::API;
+use Test::More qw(no_plan);
 use YAML::XS qw(Dump);
 use YAML::XS qw(Dump);
-use Test::More 'no_plan';
 
 =head1 NAME
 
 
 =head1 NAME