Install rubocop in the test environment
authorTom Hughes <tom@compton.nu>
Sun, 22 Feb 2015 15:44:34 +0000 (15:44 +0000)
committerTom Hughes <tom@compton.nu>
Sun, 22 Feb 2015 15:47:23 +0000 (15:47 +0000)
Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index b8657ba..017f8f3 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -86,6 +86,7 @@ end
 
 # Gems needed for running tests
 group :test do
+  gem "rubocop"
   gem "timecop"
   gem "minitest", "~> 5.1", :platforms => [:ruby_19, :ruby_20]
 end
index fee7277..c066614 100644 (file)
@@ -40,8 +40,12 @@ GEM
       thread_safe (~> 0.3, >= 0.3.4)
       tzinfo (~> 1.1)
     arel (6.0.0)
-    autoprefixer-rails (4.0.2.2)
+    ast (2.0.0)
+    astrolabe (1.3.0)
+      parser (>= 2.2.0.pre.3, < 3.0)
+    autoprefixer-rails (5.1.7)
       execjs
+      json
     bigdecimal (1.1.0)
     builder (3.2.2)
     capybara (2.4.4)
@@ -61,7 +65,7 @@ GEM
     coffee-script (2.3.0)
       coffee-script-source
       execjs
-    coffee-script-source (1.8.0)
+    coffee-script-source (1.9.1)
     colorize (0.7.5)
     composite_primary_keys (8.0.0)
       activerecord (~> 4.2.0)
@@ -70,14 +74,14 @@ GEM
     deadlock_retry (1.2.0)
     dynamic_form (1.1.4)
     erubis (2.7.0)
-    execjs (2.2.2)
+    execjs (2.3.0)
     faraday (0.9.1)
       multipart-post (>= 1.2, < 3)
-    globalid (0.3.0)
+    globalid (0.3.3)
       activesupport (>= 4.1.0)
     hike (1.2.3)
     htmlentities (4.3.3)
-    http_accept_language (2.0.2)
+    http_accept_language (2.0.5)
     httpclient (2.6.0.1)
     i18n (0.7.0)
     iconv (0.1)
@@ -91,8 +95,8 @@ GEM
     jsonify-rails (0.3.2)
       actionpack
       jsonify (< 0.4.0)
-    jwt (1.2.0)
-    kgio (2.9.2)
+    jwt (1.2.1)
+    kgio (2.9.3)
     konacha (3.3.0)
       actionpack (>= 3.1, < 5)
       capybara
@@ -110,7 +114,7 @@ GEM
     multi_json (1.10.1)
     multi_xml (0.5.5)
     multipart-post (2.0.0)
-    nokogiri (1.6.5)
+    nokogiri (1.6.6.2)
       mini_portile (~> 0.6.0)
     nokogumbo (1.2.0)
       nokogiri
@@ -135,13 +139,16 @@ GEM
       activesupport (>= 3.0.0)
       cocaine (~> 0.5.3)
       mime-types
+    parser (2.2.0.3)
+      ast (>= 1.1, < 3.0)
     pg (0.18.1)
-    poltergeist (1.5.1)
+    poltergeist (1.6.0)
       capybara (~> 2.1)
       cliver (~> 0.3.1)
       multi_json (~> 1.0)
       websocket-driver (>= 0.2.0)
-    psych (2.0.9)
+    powerpack (0.1.0)
+    psych (2.0.13)
     r2 (0.2.5)
     rack (1.6.0)
     rack-cors (0.3.1)
@@ -177,15 +184,23 @@ GEM
       activesupport (= 4.2.0)
       rake (>= 0.8.7)
       thor (>= 0.18.1, < 2.0)
+    rainbow (2.0.0)
     rake (10.4.2)
     redcarpet (3.2.2)
     rinku (1.7.3)
+    rubocop (0.29.1)
+      astrolabe (~> 1.3)
+      parser (>= 2.2.0.1, < 3.0)
+      powerpack (~> 0.1)
+      rainbow (>= 1.99.1, < 3.0)
+      ruby-progressbar (~> 1.4)
     ruby-openid (2.6.0)
-    sanitize (3.1.0)
+    ruby-progressbar (1.7.1)
+    sanitize (3.1.1)
       crass (~> 1.0.1)
       nokogiri (>= 1.4.4)
       nokogumbo (= 1.2.0)
-    sass (3.4.9)
+    sass (3.4.12)
     sass-rails (5.0.1)
       railties (>= 4.0.0, < 5.0)
       sass (~> 3.1)
@@ -198,25 +213,25 @@ GEM
       multi_json (~> 1.0)
       rack (~> 1.0)
       tilt (~> 1.1, != 1.3.0)
-    sprockets-rails (2.2.2)
+    sprockets-rails (2.2.4)
       actionpack (>= 3.0)
       activesupport (>= 3.0)
       sprockets (>= 2.8, < 4.0)
     thor (0.19.1)
     thread_safe (0.3.4)
     tilt (1.4.1)
-    timecop (0.7.1)
+    timecop (0.7.3)
     tzinfo (1.2.2)
       thread_safe (~> 0.1)
     uglifier (2.7.0)
       execjs (>= 0.3.0)
       json (>= 1.8.0)
-    validates_email_format_of (1.6.1)
+    validates_email_format_of (1.6.2)
       i18n
     vendorer (0.1.16)
-    websocket-driver (0.5.1)
+    websocket-driver (0.5.2)
       websocket-extensions (>= 0.1.0)
-    websocket-extensions (0.1.1)
+    websocket-extensions (0.1.2)
     xpath (2.0.0)
       nokogiri (~> 1.3)
 
@@ -257,6 +272,7 @@ DEPENDENCIES
   rails-i18n (~> 4.0.0)
   redcarpet
   rinku (>= 1.2.2)
+  rubocop
   ruby-openid (>= 2.2.0)
   sanitize
   sass-rails (~> 5.0)