Use image_optim_rails instead of image_optim
authorTom Hughes <tom@compton.nu>
Thu, 10 Nov 2016 12:14:19 +0000 (12:14 +0000)
committerTom Hughes <tom@compton.nu>
Thu, 10 Nov 2016 12:14:19 +0000 (12:14 +0000)
The rails hooks have been extracted into a separate gem so
this hasn't actually been working since the last image_optim
update happened.

Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 7d87708..8294038 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -38,7 +38,7 @@ gem "r2"
 gem "autoprefixer-rails"
 
 # Use image_optim to optimise images
-gem "image_optim", ">= 0.22.0"
+gem "image_optim_rails"
 
 # Load rails plugins
 gem "rails-i18n", "~> 4.0.0"
index 7edc94f..ccf1438 100644 (file)
@@ -39,10 +39,11 @@ GEM
       minitest (~> 5.1)
       thread_safe (~> 0.3, >= 0.3.4)
       tzinfo (~> 1.1)
-    addressable (2.4.0)
+    addressable (2.5.0)
+      public_suffix (~> 2.0, >= 2.0.2)
     arel (6.0.3)
     ast (2.3.0)
-    autoprefixer-rails (6.5.1.1)
+    autoprefixer-rails (6.5.2)
       execjs
     bigdecimal (1.1.0)
     builder (3.2.2)
@@ -109,13 +110,17 @@ GEM
       image_size (~> 1.3)
       in_threads (~> 1.3)
       progress (~> 3.0, >= 3.0.1)
+    image_optim_rails (0.2.0)
+      image_optim (~> 0.24.0)
+      rails
+      sprockets
     image_size (1.4.2)
     in_threads (1.3.1)
     jquery-rails (4.2.1)
       rails-dom-testing (>= 1, < 3)
       railties (>= 4.2.0)
       thor (>= 0.14, < 2.0)
-    jshint (1.4.0)
+    jshint (1.5.0)
       execjs (>= 1.4.0)
       multi_json (~> 1.0)
       therubyracer (~> 0.12.1)
@@ -158,7 +163,7 @@ GEM
     multipart-post (2.0.0)
     nokogiri (1.6.8.1)
       mini_portile2 (~> 2.1.0)
-    nokogumbo (1.4.9)
+    nokogumbo (1.4.10)
       nokogiri
     oauth (0.4.7)
     oauth-plugin (0.5.1)
@@ -210,6 +215,7 @@ GEM
     powerpack (0.1.1)
     progress (3.2.2)
     psych (2.1.1)
+    public_suffix (2.0.4)
     r2 (0.2.6)
     rack (1.6.4)
     rack-cors (0.4.0)
@@ -302,7 +308,7 @@ GEM
     validates_email_format_of (1.6.3)
       i18n
     vendorer (0.1.16)
-    webmock (1.24.2)
+    webmock (2.1.0)
       addressable (>= 2.3.6)
       crack (>= 0.3.2)
       hashdiff
@@ -332,7 +338,7 @@ DEPENDENCIES
   htmlentities
   http_accept_language (~> 2.0.0)
   i18n-js (>= 3.0.0.rc10)
-  image_optim (>= 0.22.0)
+  image_optim_rails
   jquery-rails
   jshint
   json
@@ -370,4 +376,4 @@ DEPENDENCIES
   webmock
 
 BUNDLED WITH
-   1.11.2
+   1.12.5