Remove sprockets-rails version restriction now konacha is fixed
authorTom Hughes <tom@compton.nu>
Thu, 11 Feb 2016 07:10:42 +0000 (07:10 +0000)
committerTom Hughes <tom@compton.nu>
Thu, 11 Feb 2016 07:10:42 +0000 (07:10 +0000)
Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 1653c98..6ae69eb 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -91,9 +91,6 @@ gem "kgio"
 # Used to generate logstash friendly log files
 gem "logstasher"
 
-# Stay with sprockets-rails 2.x pending fix for konacha
-gem "sprockets-rails", "< 3"
-
 # Gems useful for development
 group :development do
   gem "vendorer"
index 89c8388..296131d 100644 (file)
@@ -42,7 +42,7 @@ GEM
     addressable (2.4.0)
     arel (6.0.3)
     ast (2.2.0)
-    autoprefixer-rails (6.3.1)
+    autoprefixer-rails (6.3.2)
       execjs
       json
     bigdecimal (1.1.0)
@@ -125,12 +125,13 @@ GEM
       jsonify (< 0.4.0)
     jwt (1.5.1)
     kgio (2.10.0)
-    konacha (3.7.0)
-      actionpack (>= 3.1, < 5)
+    konacha (4.0.0)
+      actionpack (>= 4.1, < 5)
       capybara
       colorize
-      railties (>= 3.1, < 5)
+      railties (>= 4.1, < 5)
       sprockets (>= 2, < 4)
+      sprockets-rails (>= 2, < 4)
       tilt
     libv8 (3.16.14.13)
     libxml-ruby (2.8.0)
@@ -187,13 +188,13 @@ GEM
     omniauth-windowslive (0.0.9.1)
       multi_json (>= 1.0.3)
       omniauth-oauth2 (~> 1.0)
-    paperclip (4.3.4)
+    paperclip (4.3.5)
       activemodel (>= 3.2.0)
       activesupport (>= 3.2.0)
       cocaine (~> 0.5.5)
       mime-types
       mimemagic (= 0.3.0)
-    parser (2.3.0.2)
+    parser (2.3.0.4)
       ast (~> 2.2)
     pg (0.18.4)
     poltergeist (1.9.0)
@@ -250,8 +251,8 @@ GEM
       mime-types (>= 1.16, < 3.0)
       netrc (~> 0.7)
     rinku (1.7.3)
-    rubocop (0.37.0)
-      parser (>= 2.3.0.2, < 3.0)
+    rubocop (0.37.1)
+      parser (>= 2.3.0.4, < 3.0)
       powerpack (~> 0.1)
       rainbow (>= 1.99.1, < 3.0)
       ruby-progressbar (~> 1.7)
@@ -278,10 +279,10 @@ GEM
     sprockets (3.5.2)
       concurrent-ruby (~> 1.0)
       rack (> 1, < 3)
-    sprockets-rails (2.3.3)
-      actionpack (>= 3.0)
-      activesupport (>= 3.0)
-      sprockets (>= 2.8, < 4.0)
+    sprockets-rails (3.0.1)
+      actionpack (>= 4.0)
+      activesupport (>= 4.0)
+      sprockets (>= 3.0.0)
     term-ansicolor (1.3.2)
       tins (~> 1.0)
     therubyracer (0.12.2)
@@ -360,7 +361,6 @@ DEPENDENCIES
   sanitize
   sass-rails (~> 5.0)
   soap4r-ruby1.9
-  sprockets-rails (< 3)
   timecop
   uglifier (>= 1.3.0)
   validates_email_format_of (>= 1.5.1)