Merge remote-tracking branch 'openstreetmap/pull/1122'
authorTom Hughes <tom@compton.nu>
Wed, 9 Mar 2016 19:05:16 +0000 (19:05 +0000)
committerTom Hughes <tom@compton.nu>
Wed, 9 Mar 2016 19:05:16 +0000 (19:05 +0000)
script/vagrant/setup/provision.sh

index 912a62958af73f9c86b3071800d0c469a785b89c..5699b537b14ef5e42529f363c0bb51996396dba9 100644 (file)
@@ -1,8 +1,8 @@
 #!/usr/bin/env bash
 
 # set locale to UTF-8 compatible. apologies to non-english speakers...
+locale-gen en_GB.utf8
 update-locale LANG=en_GB.utf8 LC_ALL=en_GB.utf8
-locale-gen
 export LANG=en_GB.utf8
 export LC_ALL=en_GB.utf8
 
@@ -13,12 +13,12 @@ apt-get update
 apt-get upgrade -y
 
 # install packages as explained in INSTALL.md
-apt-get install -y ruby1.9.1 libruby1.9.1 ruby1.9.1-dev ri1.9.1 \
-    libmagickwand-dev libxml2-dev libxslt1-dev nodejs \
-    apache2 apache2-threaded-dev build-essential git-core \
-    postgresql postgresql-contrib libpq-dev postgresql-server-dev-all \
-    libsasl2-dev
-gem1.9.1 install bundle
+apt-get install -y ruby2.0 libruby2.0 ruby2.0-dev \
+                     libmagickwand-dev libxml2-dev libxslt1-dev nodejs \
+                     apache2 apache2-threaded-dev build-essential git-core \
+                     postgresql postgresql-contrib libpq-dev postgresql-server-dev-all \
+                     libsasl2-dev imagemagick
+gem2.0 install bundler
 
 ## install the bundle necessary for openstreetmap-website
 pushd /srv/openstreetmap-website