Updating to use Rails 2.1.2. Moving the gem dependancies to the config/environment...