Fix rubocop warnings
[chef.git] / cookbooks / mediawiki / recipes / default.rb
index d6d90caa1f762f67758587852f85570cbec25f81..9b97eacaca428a7dd402d47de71becf0500e00bf 100644 (file)
@@ -22,7 +22,7 @@ include_recipe "apache::ssl"
 include_recipe "mysql"
 include_recipe "git"
 
-#Mediawiki Base Requirements
+# Mediawiki Base Requirements
 package "php5"
 package "php5-cli"
 package "php5-curl"
@@ -34,16 +34,38 @@ package "libapache2-mod-php5"
 
 package "php-wikidiff2"
 
-#Mediawiki Image + SVG support
+# Mediawiki Image + SVG support
 package "imagemagick"
 package "librsvg2-bin"
 
-#Mediawiki PDF support via Extension:PdfHandler
+# Mediawiki PDF support via Extension:PdfHandler
 package "ghostscript"
 package "poppler-utils"
 
-#Mediawiki backup
+# Mediawiki backup
 package "xz-utils"
+package "liblz4-tool"
+
+# Mediawiki packages for VisualEditor support
+package "curl"
+package "parsoid"
+
+template "/etc/mediawiki/parsoid/settings.js" do
+  source "parsoid-settings.js.erb"
+  owner "root"
+  group "root"
+  mode 0o644
+end
+
+service "parsoid" do
+  action [:enable]
+  supports :status => false, :restart => true, :reload => false
+  subscribes :restart, "template[/etc/mediawiki/parsoid/settings.js]"
+end
+
+link "/etc/php5/apache2/conf.d/20-wikidiff2.ini" do
+  to "../../mods-available/wikidiff2.ini"
+end
 
 apache_module "php5"
 apache_module "rewrite"