Make sure tile servers install the right postgis version
authorTom Hughes <tom@compton.nu>
Fri, 9 Dec 2016 09:30:06 +0000 (09:30 +0000)
committerTom Hughes <tom@compton.nu>
Fri, 9 Dec 2016 09:30:06 +0000 (09:30 +0000)
cookbooks/tile/recipes/default.rb

index dd4a7a603590385e42e0c35edbeff68321d29482..5083790c37d7680cefa8d46a666358b00b9e7305 100644 (file)
@@ -325,7 +325,10 @@ node[:tile][:styles].each do |name, details|
   end
 end
 
+postgresql_version = node[:tile][:database][:cluster].split("/").first
+
 package "postgis"
+package "postgresql-#{postgresql_version}-postgis-2.3"
 
 postgresql_user "jburgess" do
   cluster node[:tile][:database][:cluster]