Remove some no longer needed code for old Ubuntu versions
authorTom Hughes <tom@compton.nu>
Sun, 26 Feb 2017 10:19:09 +0000 (10:19 +0000)
committerTom Hughes <tom@compton.nu>
Sun, 26 Feb 2017 10:21:09 +0000 (10:21 +0000)
cookbooks/donate/recipes/default.rb
cookbooks/nodejs/recipes/default.rb
cookbooks/nominatim/recipes/default.rb
cookbooks/planet/recipes/default.rb

index d1b431bd782d20b310d5c303e3acefaa8e0a15dc..89eb26d57462d16fcd03b74deed59d22b8df5621 100644 (file)
@@ -21,23 +21,13 @@ include_recipe "apache"
 include_recipe "mysql"
 include_recipe "git"
 
-if node[:lsb][:release].to_f >= 16.04
-  package "php"
-  package "php-cli"
-  package "php-curl"
-  package "php-mysql"
-  package "php-gd"
-
-  apache_module "php7.0"
-else
-  package "php5"
-  package "php5-cli"
-  package "php5-curl"
-  package "php5-mysql"
-  package "php5-gd"
-
-  apache_module "php5"
-end
+package "php"
+package "php-cli"
+package "php-curl"
+package "php-mysql"
+package "php-gd"
+
+apache_module "php7.0"
 
 apache_module "headers"
 
index f6f054fe08b8cc9f8289334f62f3d7d5c8203601..7e2b844e6f67637a91cd78b6a3855ee73cadc132 100644 (file)
@@ -18,8 +18,7 @@
 #
 
 package "nodejs"
+package "nodejs-legacy"
 package "npm"
 package "g++"
 package "make"
-
-package "nodejs-legacy" if node[:lsb][:release].to_f >= 14.04
index ac1b27f3314f1e356221f803fb7fd129b69587aa..5dedfd4e7574b38fa67d94706a4f456ea65b3e25 100644 (file)
@@ -307,27 +307,19 @@ apache_module "proxy_fcgi"
 apache_module "proxy_http"
 apache_module "headers"
 
-service "php5-fpm" do
-  if node[:lsb][:release].to_f >= 15.10
-    provider Chef::Provider::Service::Systemd
-    service_name "php7.0-fpm"
-  elsif node[:lsb][:release].to_f >= 14.04
-    provider Chef::Provider::Service::Upstart
-  end
+service "php7.0-fpm" do
   action [:enable, :start]
   supports :status => true, :restart => true, :reload => true
 end
 
-php_confdir = node[:lsb][:release].to_f >= 15.10 ? "/etc/php/7.0" : "/etc/php5"
-
 node[:nominatim][:fpm_pools].each do |name, data|
-  template "#{php_confdir}/fpm/pool.d/#{name}.conf" do
+  template "/etc/php/7.0/fpm/pool.d/#{name}.conf" do
     source "fpm.conf.erb"
     owner "root"
     group "root"
     mode 0o644
     variables data.merge(:name => name)
-    notifies :reload, "service[php5-fpm]"
+    notifies :reload, "service[php7.0-fpm]"
   end
 end
 
index 33c01751b2d09e5348250aea8c4429b4c1ea85ef..5d4e063cd4b3000a8071e8a4b3167aac00f6dc93 100644 (file)
@@ -23,11 +23,7 @@ package "perl"
 package "pbzip2"
 package "osmosis"
 
-if node[:lsb][:release].to_f >= 16.04
-  package "php-cli"
-else
-  package "php5-cli"
-end
+package "php-cli"
 
 file "/etc/cron.d/planet" do
   action :delete