Make passenger default to ruby 2.5 on 18.04
authorTom Hughes <tom@compton.nu>
Sat, 23 Jun 2018 16:27:57 +0000 (17:27 +0100)
committerTom Hughes <tom@compton.nu>
Sat, 23 Jun 2018 16:27:57 +0000 (17:27 +0100)
cookbooks/passenger/attributes/default.rb
roles/stormfly-01.rb

index e21f96269ddfa419a50df8918c2c481ca837b58c..adb0edc081e3155bb5293566cc6554d21b4f42ca 100644 (file)
@@ -1,4 +1,4 @@
-default[:passenger][:ruby_version] = "2.3"
+default[:passenger][:ruby_version] = node[:lsb][:release].to_f >= 18.04 ? "2.5" : "2.3"
 default[:passenger][:max_pool_size] = 6
 default[:passenger][:pool_idle_time] = 300
 
index 841564bc3f6b911d50513e375130a20115badfb1..fc50adc394b94430c89e345111754c24a420550d 100644 (file)
@@ -17,9 +17,6 @@ default_attributes(
         :address => "2605:bc80:3010:700::8cde:a768"
       }
     }
-  },
-  :passenger => {
-    :ruby_version => "2.5"
   }
 )