Remove hacks added to support passenger 4 upgrade
authorTom Hughes <tom@compton.nu>
Tue, 8 Jul 2014 09:16:25 +0000 (10:16 +0100)
committerTom Hughes <tom@compton.nu>
Tue, 8 Jul 2014 09:16:25 +0000 (10:16 +0100)
cookbooks/apache/providers/module.rb
cookbooks/apache/resources/module.rb
cookbooks/passenger/attributes/default.rb
cookbooks/passenger/recipes/default.rb
cookbooks/passenger/templates/default/passenger.conf.erb
roles/dev.rb
roles/taginfo.rb
roles/web.rb

index 31910ed..1700837 100644 (file)
@@ -23,9 +23,7 @@ end
 
 action :install do
   if not installed?
-    package package_name do
-      version new_resource.version
-    end
+    package package_name
 
     updated = true
   else
index 2d07750..f2d9555 100644 (file)
@@ -22,6 +22,5 @@ default_action [:install, :enable]
 
 attribute :name, :kind_of => String, :name_attribute => true
 attribute :package, :kind_of => String
-attribute :version, :kind_of => String
 attribute :conf, :kind_of => String
 attribute :variables, :kind_of => Hash, :default => {}
index eff26a2..a67ac6a 100644 (file)
@@ -1,6 +1,5 @@
 default[:apt][:sources] = node[:apt][:sources] |  [ "brightbox-ruby-ng", "passenger" ]
 
-default[:passenger][:version] = "3.0.21"
 default[:passenger][:ruby_version] = "1.9.1"
 default[:passenger][:max_pool_size] = 6
 default[:passenger][:pool_idle_time] = 300
index 8b74aa0..267942f 100644 (file)
@@ -33,14 +33,9 @@ template "/usr/local/bin/passenger-ruby" do
 end
 
 apache_module "passenger" do
-  version node[:passenger][:version]
   conf "passenger.conf.erb"
 end
 
-if node[:passenger][:version] < "4"
-  package "passenger-common#{node[:passenger][:ruby_version]}"
-end
-
 munin_plugin "passenger_memory"
 munin_plugin "passenger_processes"
 munin_plugin "passenger_queues"
index 002394f..958c729 100644 (file)
@@ -1,16 +1,9 @@
 # DO NOT EDIT - This file is being maintained by Chef
 
 <IfModule mod_passenger.c>
-<% if node[:passenger][:version] >= "4" -%>
   PassengerRoot /usr/lib/ruby/vendor_ruby/phusion_passenger/locations.ini
   PassengerDefaultRuby /usr/bin/ruby
-<% else -%>
-  PassengerRoot /usr
-<% end -%>
   PassengerRuby /usr/local/bin/passenger-ruby
-<% if node[:passenger][:version] < "4" -%>
-  PassengerUseGlobalQueue on
-<% end -%>
   PassengerMaxPoolSize <%= node[:passenger][:max_pool_size] %>
   PassengerPoolIdleTime <%= node[:passenger][:pool_idle_time] %>
 </IfModule>
index 947c6f5..fcb243f 100644 (file)
@@ -149,9 +149,6 @@ default_attributes(
       }
     }
   },
-  :passenger => {
-    :version => "4.0.45"
-  },
   :postgresql => {
     :versions => [ "9.1" ],
     :settings => {
index a49f00d..ffafde6 100644 (file)
@@ -24,9 +24,6 @@ default_attributes(
       :max_requests_per_child => 10000
     }
   },
-  :passenger => {
-    :version => "4.0.45"
-  },
   :taginfo => {
     :sites => [
       {
index a13329d..30069f1 100644 (file)
@@ -14,7 +14,6 @@ default_attributes(
     "/store/rails" => { :host => "ironbelly", :path => "/store/rails" }
   },
   :passenger => {
-    :version => "4.0.45",
     :pool_idle_time => 0
   },
   :web => {