Add top-level Apache 2.0 license file.