Update bundle
[rails.git] / Gemfile
1 source 'http://rubygems.org'
2
3 # Require rails
4 gem 'rails', '4.0.0'
5
6 # Require things which have moved to gems in ruby 1.9
7 gem 'bigdecimal', "~> 1.1.0", :platforms => :ruby_19
8
9 # Require things which have moved to gems in ruby 2.0
10 gem 'psych', :platforms => :ruby_20
11
12 # Require json for multi_json
13 gem 'json'
14
15 # Use postgres as the database
16 gem 'pg'
17
18 # Use SCSS for stylesheets
19 gem 'sass-rails', '~> 4.0.0'
20
21 # Use Uglifier as compressor for JavaScript assets
22 gem 'uglifier', '>= 1.3.0'
23
24 # Use CoffeeScript for .js.coffee assets and views
25 gem 'coffee-rails', '~> 4.0.0'
26
27 # See https://github.com/sstephenson/execjs#readme for more supported runtimes
28 # gem 'therubyracer', platforms: :ruby
29
30 # Use jquery as the JavaScript library
31 gem 'jquery-rails'
32
33 # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
34 # gem 'jbuilder', '~> 1.2'
35 gem 'jsonify-rails'
36
37 # Use R2 for RTL conversion
38 gem 'r2'
39
40 # Use ejs for javascript templates
41 gem 'ejs'
42
43 # Load rails plugins
44 gem 'rails-i18n', ">= 0.6.3"
45 gem 'dynamic_form'
46 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
47 gem 'openstreetmap-oauth-plugin', '>= 0.4.1.1', :require => 'oauth-plugin'
48 gem 'open_id_authentication', '>= 1.1.0'
49 gem 'validates_email_format_of', '>= 1.5.1'
50 gem 'composite_primary_keys', '>= 6.0.0'
51 gem 'http_accept_language', '~> 1.0.2'
52 gem 'paperclip', '~> 2.0'
53 gem 'deadlock_retry', '>= 1.2.0'
54 gem 'openstreetmap-i18n-js', '>= 3.0.0.rc5.2', :require => 'i18n-js'
55 gem 'rack-cors'
56 gem 'actionpack-page_caching'
57
58 # We need ruby-openid 2.2.0 or later for ruby 1.9 support
59 gem 'ruby-openid', '>= 2.2.0'
60
61 # Markdown formatting support
62 gem 'redcarpet'
63
64 # Character conversion support for ruby 1.8
65 gem 'iconv', '= 0.1', :platforms => :ruby_18
66
67 # Load libxml support for XML parsing and generation
68 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
69
70 # Use for HTML sanitisation
71 gem 'sanitize'
72 gem 'htmlentities'
73
74 # Load SystemTimer for implementing request timeouts
75 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer', :platforms => :ruby_18
76
77 # Load httpclient for SOAP support for Quova GeoIP queries
78 gem 'httpclient'
79
80 # Load memcache in case we are using it
81 gem 'memcached', '>= 1.4.1'
82
83 # Gems useful for development
84 group :development do
85   gem 'vendorer'
86 end
87
88 # Gems needed for running tests
89 group :test do
90   gem 'timecop'
91   gem 'minitest', '~> 4.7.0', :platforms => [:ruby_19, :ruby_20]
92 end