Monkey patch CPK to fix problems with polymorphic has_many
[rails.git] / Gemfile
1 # Gem source to use
2 source 'http://rubygems.org'
3
4 # Require rails
5 gem 'rails', '3.1.2'
6
7 # Require the postgres database driver
8 gem 'pg'
9
10 # Load prototype support
11 gem 'prototype-rails'
12
13 # Load rails plugins
14 gem 'rails-i18n-updater'
15 gem 'dynamic_form'
16 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
17 gem 'oauth-plugin', '>= 0.4.0.pre7'
18 gem 'open_id_authentication', '>= 1.1.0'
19 gem 'validates_email_format_of', '>= 1.5.1'
20 gem 'composite_primary_keys', '>= 4.1.1'
21
22 # Load libxml support for XML parsing and generation
23 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
24
25 # Load ImageMagick support for user picture resizing
26 gem 'rmagick', :require => 'RMagick'
27
28 # Load HTML sanitizer
29 gem 'sanitize'
30
31 # Load SystemTimer for implementing request timeouts
32 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer'
33
34 # Load httpclient for SOAP support for Quova GeoIP queries
35 gem 'httpclient'
36
37 # Load memcache in case we are using it
38 gem 'memcache-client'
39 gem 'memcached'
40
41 # Gems needed for running tests
42 group :test do
43   gem 'timecop'
44 end
45
46 # Gems needed for compiling assets
47 group :assets do
48   gem 'sass-rails', "  ~> 3.1.0"
49   gem 'coffee-rails', "~> 3.1.0"
50   gem 'uglifier'
51   gem 'therubyracer'
52 end