Localisation updates from https://translatewiki.net.
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.5)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.3)
8       actionpack (= 5.2.3)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.3)
12       actionpack (= 5.2.3)
13       actionview (= 5.2.3)
14       activejob (= 5.2.3)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.3)
18       actionview (= 5.2.3)
19       activesupport (= 5.2.3)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.3)
27       activesupport (= 5.2.3)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.3)
35       activesupport (= 5.2.3)
36       globalid (>= 0.3.6)
37     activemodel (5.2.3)
38       activesupport (= 5.2.3)
39     activerecord (5.2.3)
40       activemodel (= 5.2.3)
41       activesupport (= 5.2.3)
42       arel (>= 9.0)
43     activerecord-import (1.0.2)
44       activerecord (>= 3.2)
45     activestorage (5.2.3)
46       actionpack (= 5.2.3)
47       activerecord (= 5.2.3)
48       marcel (~> 0.3.1)
49     activesupport (5.2.3)
50       concurrent-ruby (~> 1.0, >= 1.0.2)
51       i18n (>= 0.7, < 2)
52       minitest (~> 5.1)
53       tzinfo (~> 1.1)
54     addressable (2.6.0)
55       public_suffix (>= 2.0.2, < 4.0)
56     annotate (2.7.5)
57       activerecord (>= 3.2, < 7.0)
58       rake (>= 10.4, < 13.0)
59     arel (9.0.0)
60     ast (2.4.0)
61     autoprefixer-rails (8.6.5)
62       execjs
63     aws-eventstream (1.0.3)
64     aws-partitions (1.189.0)
65     aws-sdk-core (3.59.0)
66       aws-eventstream (~> 1.0, >= 1.0.2)
67       aws-partitions (~> 1.0)
68       aws-sigv4 (~> 1.1)
69       jmespath (~> 1.0)
70     aws-sdk-kms (1.23.0)
71       aws-sdk-core (~> 3, >= 3.58.0)
72       aws-sigv4 (~> 1.1)
73     aws-sdk-s3 (1.45.0)
74       aws-sdk-core (~> 3, >= 3.58.0)
75       aws-sdk-kms (~> 1)
76       aws-sigv4 (~> 1.1)
77     aws-sigv4 (1.1.0)
78       aws-eventstream (~> 1.0, >= 1.0.2)
79     better_errors (2.5.1)
80       coderay (>= 1.0.0)
81       erubi (>= 1.0.0)
82       rack (>= 0.9.0)
83     better_html (1.0.14)
84       actionview (>= 4.0)
85       activesupport (>= 4.0)
86       ast (~> 2.0)
87       erubi (~> 1.4)
88       html_tokenizer (~> 0.0.6)
89       parser (>= 2.4)
90       smart_properties
91     bigdecimal (1.1.0)
92     binding_of_caller (0.8.0)
93       debug_inspector (>= 0.0.1)
94     bootsnap (1.4.4)
95       msgpack (~> 1.0)
96     browser (2.6.1)
97     builder (3.2.3)
98     bzip2-ffi (1.0.0)
99       ffi (~> 1.0)
100     cancancan (3.0.1)
101     canonical-rails (0.2.6)
102       rails (>= 4.1, < 6.1)
103     capybara (2.18.0)
104       addressable
105       mini_mime (>= 0.1.3)
106       nokogiri (>= 1.3.3)
107       rack (>= 1.0.0)
108       rack-test (>= 0.5.4)
109       xpath (>= 2.0, < 4.0)
110     cliver (0.3.2)
111     coderay (1.1.2)
112     coffee-rails (4.2.2)
113       coffee-script (>= 2.2.0)
114       railties (>= 4.0.0)
115     coffee-script (2.4.1)
116       coffee-script-source
117       execjs
118     coffee-script-source (1.12.2)
119     composite_primary_keys (11.1.0)
120       activerecord (~> 5.2.1)
121     concurrent-ruby (1.1.5)
122     config (2.0.0)
123       activesupport (>= 4.2)
124       deep_merge (~> 1.2, >= 1.2.1)
125       dry-schema (~> 1.0)
126     coveralls (0.8.23)
127       json (>= 1.8, < 3)
128       simplecov (~> 0.16.1)
129       term-ansicolor (~> 1.3)
130       thor (>= 0.19.4, < 2.0)
131       tins (~> 1.6)
132     crack (0.4.3)
133       safe_yaml (~> 1.0.0)
134     crass (1.0.4)
135     dalli (2.7.10)
136     debug_inspector (0.0.3)
137     deep_merge (1.2.1)
138     delayed_job (4.1.7)
139       activesupport (>= 3.0, < 5.3)
140     delayed_job_active_record (4.1.3)
141       activerecord (>= 3.0, < 5.3)
142       delayed_job (>= 3.0, < 5)
143     docile (1.3.2)
144     dry-configurable (0.8.3)
145       concurrent-ruby (~> 1.0)
146       dry-core (~> 0.4, >= 0.4.7)
147     dry-container (0.7.2)
148       concurrent-ruby (~> 1.0)
149       dry-configurable (~> 0.1, >= 0.1.3)
150     dry-core (0.4.8)
151       concurrent-ruby (~> 1.0)
152     dry-equalizer (0.2.2)
153     dry-inflector (0.1.2)
154     dry-initializer (3.0.1)
155     dry-logic (1.0.2)
156       concurrent-ruby (~> 1.0)
157       dry-core (~> 0.2)
158       dry-equalizer (~> 0.2)
159     dry-schema (1.3.1)
160       concurrent-ruby (~> 1.0)
161       dry-configurable (~> 0.8, >= 0.8.3)
162       dry-core (~> 0.4)
163       dry-equalizer (~> 0.2)
164       dry-initializer (~> 3.0)
165       dry-logic (~> 1.0)
166       dry-types (~> 1.0)
167     dry-types (1.1.0)
168       concurrent-ruby (~> 1.0)
169       dry-container (~> 0.3)
170       dry-core (~> 0.4, >= 0.4.4)
171       dry-equalizer (~> 0.2, >= 0.2.2)
172       dry-inflector (~> 0.1, >= 0.1.2)
173       dry-logic (~> 1.0, >= 1.0.2)
174     dynamic_form (1.1.4)
175     erb_lint (0.0.29)
176       activesupport
177       better_html (~> 1.0.7)
178       html_tokenizer
179       rainbow
180       rubocop (~> 0.51)
181       smart_properties
182     erubi (1.8.0)
183     execjs (2.7.0)
184     exifr (1.3.6)
185     factory_bot (5.0.2)
186       activesupport (>= 4.2.0)
187     factory_bot_rails (5.0.2)
188       factory_bot (~> 5.0.2)
189       railties (>= 4.2.0)
190     fakefs (0.20.1)
191     faraday (0.15.4)
192       multipart-post (>= 1.2, < 3)
193     ffi (1.11.1)
194     ffi-libarchive (0.4.10)
195       ffi (~> 1.0)
196     fspath (3.1.2)
197     gd2-ffij (0.4.0)
198       ffi (>= 1.0.0)
199     geoip (1.6.4)
200     globalid (0.4.2)
201       activesupport (>= 4.2.0)
202     hashdiff (1.0.0)
203     hashie (3.6.0)
204     html_tokenizer (0.0.7)
205     htmlentities (4.3.4)
206     http_accept_language (2.0.5)
207     i18n (0.9.5)
208       concurrent-ruby (~> 1.0)
209     i18n-js (3.3.0)
210       i18n (>= 0.6.6)
211     image_optim (0.26.5)
212       exifr (~> 1.2, >= 1.2.2)
213       fspath (~> 3.0)
214       image_size (>= 1.5, < 3)
215       in_threads (~> 1.3)
216       progress (~> 3.0, >= 3.0.1)
217     image_optim_rails (0.4.3)
218       image_optim (~> 0.24)
219       rails
220       sprockets
221     image_size (2.0.2)
222     in_threads (1.5.3)
223     jaro_winkler (1.5.3)
224     jmespath (1.4.0)
225     jquery-rails (4.3.5)
226       rails-dom-testing (>= 1, < 3)
227       railties (>= 4.2.0)
228       thor (>= 0.14, < 2.0)
229     json (2.2.0)
230     jsonify (0.3.1)
231       multi_json (~> 1.0)
232     jsonify-rails (0.3.2)
233       actionpack
234       jsonify (< 0.4.0)
235     jwt (2.2.1)
236     kgio (2.11.2)
237     kramdown (2.1.0)
238     libxml-ruby (3.1.0)
239     listen (3.1.5)
240       rb-fsevent (~> 0.9, >= 0.9.4)
241       rb-inotify (~> 0.9, >= 0.9.7)
242       ruby_dep (~> 1.2)
243     logstash-event (1.2.02)
244     logstasher (1.3.0)
245       activesupport (>= 4.0)
246       logstash-event (~> 1.2.0)
247       request_store
248     loofah (2.2.3)
249       crass (~> 1.0.2)
250       nokogiri (>= 1.5.9)
251     mail (2.7.1)
252       mini_mime (>= 0.1.1)
253     marcel (0.3.3)
254       mimemagic (~> 0.3.2)
255     method_source (0.9.2)
256     mimemagic (0.3.3)
257     mini_magick (4.9.5)
258     mini_mime (1.0.2)
259     mini_portile2 (2.4.0)
260     minitest (5.11.3)
261     msgpack (1.3.0)
262     multi_json (1.13.1)
263     multi_xml (0.6.0)
264     multipart-post (2.1.1)
265     nio4r (2.4.0)
266     nokogiri (1.10.3)
267       mini_portile2 (~> 2.4.0)
268     nokogumbo (2.0.1)
269       nokogiri (~> 1.8, >= 1.8.4)
270     oauth (0.4.7)
271     oauth-plugin (0.5.1)
272       multi_json
273       oauth (~> 0.4.4)
274       oauth2 (>= 0.5.0)
275       rack
276     oauth2 (1.4.1)
277       faraday (>= 0.8, < 0.16.0)
278       jwt (>= 1.0, < 3.0)
279       multi_json (~> 1.3)
280       multi_xml (~> 0.5)
281       rack (>= 1.2, < 3)
282     omniauth (1.9.0)
283       hashie (>= 3.4.6, < 3.7.0)
284       rack (>= 1.6.2, < 3)
285     omniauth-facebook (5.0.0)
286       omniauth-oauth2 (~> 1.2)
287     omniauth-github (1.3.0)
288       omniauth (~> 1.5)
289       omniauth-oauth2 (>= 1.4.0, < 2.0)
290     omniauth-google-oauth2 (0.7.0)
291       jwt (>= 2.0)
292       omniauth (>= 1.1.1)
293       omniauth-oauth2 (>= 1.5)
294     omniauth-mediawiki (0.0.4)
295       jwt (~> 2.0)
296       omniauth-oauth (~> 1.0)
297     omniauth-oauth (1.1.0)
298       oauth
299       omniauth (~> 1.0)
300     omniauth-oauth2 (1.6.0)
301       oauth2 (~> 1.1)
302       omniauth (~> 1.9)
303     omniauth-openid (1.0.1)
304       omniauth (~> 1.0)
305       rack-openid (~> 1.3.1)
306     omniauth-windowslive (0.0.12)
307       multi_json (~> 1.12)
308       omniauth-oauth2 (~> 1.4)
309     openstreetmap-deadlock_retry (1.3.0)
310     parallel (1.17.0)
311     parser (2.6.3.0)
312       ast (~> 2.4.0)
313     pg (1.1.4)
314     poltergeist (1.18.1)
315       capybara (>= 2.1, < 4)
316       cliver (~> 0.3.1)
317       websocket-driver (>= 0.2.0)
318     progress (3.5.2)
319     psych (3.1.0)
320     public_suffix (3.1.1)
321     puma (3.12.1)
322     quad_tile (1.0.1)
323     r2 (0.2.7)
324     rack (2.0.7)
325     rack-cors (1.0.3)
326     rack-openid (1.3.1)
327       rack (>= 1.1.0)
328       ruby-openid (>= 2.1.8)
329     rack-test (1.1.0)
330       rack (>= 1.0, < 3)
331     rack-uri_sanitizer (0.0.2)
332     rails (5.2.3)
333       actioncable (= 5.2.3)
334       actionmailer (= 5.2.3)
335       actionpack (= 5.2.3)
336       actionview (= 5.2.3)
337       activejob (= 5.2.3)
338       activemodel (= 5.2.3)
339       activerecord (= 5.2.3)
340       activestorage (= 5.2.3)
341       activesupport (= 5.2.3)
342       bundler (>= 1.3.0)
343       railties (= 5.2.3)
344       sprockets-rails (>= 2.0.0)
345     rails-controller-testing (1.0.4)
346       actionpack (>= 5.0.1.x)
347       actionview (>= 5.0.1.x)
348       activesupport (>= 5.0.1.x)
349     rails-dom-testing (2.0.3)
350       activesupport (>= 4.2.0)
351       nokogiri (>= 1.6)
352     rails-html-sanitizer (1.0.4)
353       loofah (~> 2.2, >= 2.2.2)
354     rails-i18n (4.0.2)
355       i18n (~> 0.6)
356       rails (>= 4.0)
357     railties (5.2.3)
358       actionpack (= 5.2.3)
359       activesupport (= 5.2.3)
360       method_source
361       rake (>= 0.8.7)
362       thor (>= 0.19.0, < 2.0)
363     rainbow (3.0.0)
364     rake (12.3.2)
365     rb-fsevent (0.10.3)
366     rb-inotify (0.10.0)
367       ffi (~> 1.0)
368     record_tag_helper (1.0.0)
369       actionview (~> 5.x)
370     request_store (1.4.1)
371       rack (>= 1.4)
372     rinku (2.0.6)
373     rotp (5.1.0)
374       addressable (~> 2.5)
375     rubocop (0.73.0)
376       jaro_winkler (~> 1.5.1)
377       parallel (~> 1.10)
378       parser (>= 2.6)
379       rainbow (>= 2.2.2, < 4.0)
380       ruby-progressbar (~> 1.7)
381       unicode-display_width (>= 1.4.0, < 1.7)
382     rubocop-performance (1.4.0)
383       rubocop (>= 0.71.0)
384     rubocop-rails (2.2.1)
385       rack (>= 1.1)
386       rubocop (>= 0.72.0)
387     ruby-openid (2.7.0)
388     ruby-progressbar (1.10.1)
389     ruby_dep (1.5.0)
390     safe_yaml (1.0.5)
391     sanitize (5.0.0)
392       crass (~> 1.0.2)
393       nokogiri (>= 1.8.0)
394       nokogumbo (~> 2.0)
395     sassc (2.0.1)
396       ffi (~> 1.9)
397       rake
398     sassc-rails (2.1.2)
399       railties (>= 4.0.0)
400       sassc (>= 2.0)
401       sprockets (> 3.0)
402       sprockets-rails
403       tilt
404     secure_headers (6.1.1)
405     simplecov (0.16.1)
406       docile (~> 1.1)
407       json (>= 1.8, < 3)
408       simplecov-html (~> 0.10.0)
409     simplecov-html (0.10.2)
410     smart_properties (1.15.0)
411     sprockets (3.7.2)
412       concurrent-ruby (~> 1.0)
413       rack (> 1, < 3)
414     sprockets-rails (3.2.1)
415       actionpack (>= 4.0)
416       activesupport (>= 4.0)
417       sprockets (>= 3.0.0)
418     strong_migrations (0.4.1)
419       activerecord (>= 5)
420     term-ansicolor (1.7.1)
421       tins (~> 1.0)
422     thor (0.20.3)
423     thread_safe (0.3.6)
424     tilt (2.0.9)
425     tins (1.21.1)
426     tzinfo (1.2.5)
427       thread_safe (~> 0.1)
428     uglifier (4.1.20)
429       execjs (>= 0.3.0, < 3)
430     unicode-display_width (1.6.0)
431     validates_email_format_of (1.6.3)
432       i18n
433     vendorer (0.2.0)
434     webmock (3.6.0)
435       addressable (>= 2.3.6)
436       crack (>= 0.3.2)
437       hashdiff (>= 0.4.0, < 2.0.0)
438     websocket-driver (0.7.1)
439       websocket-extensions (>= 0.1.0)
440     websocket-extensions (0.1.4)
441     xpath (3.2.0)
442       nokogiri (~> 1.8)
443
444 PLATFORMS
445   ruby
446
447 DEPENDENCIES
448   SystemTimer (>= 1.1.3)
449   aasm
450   actionpack-page_caching
451   active_record_union
452   activerecord-import
453   annotate
454   autoprefixer-rails (~> 8.6.3)
455   aws-sdk-s3
456   better_errors
457   bigdecimal (~> 1.1.0)
458   binding_of_caller
459   bootsnap (>= 1.1.0)
460   browser
461   bzip2-ffi
462   cancancan
463   canonical-rails
464   capybara (~> 2.13)
465   coffee-rails (~> 4.2)
466   composite_primary_keys (~> 11.1.0)
467   config
468   coveralls
469   dalli
470   delayed_job_active_record
471   dynamic_form
472   erb_lint
473   factory_bot_rails
474   fakefs
475   faraday
476   ffi-libarchive
477   gd2-ffij (>= 0.4.0)
478   geoip
479   htmlentities
480   http_accept_language (~> 2.0.0)
481   i18n-js (>= 3.0.0)
482   image_optim_rails
483   jquery-rails
484   json
485   jsonify-rails
486   kgio
487   kramdown
488   libxml-ruby (>= 2.0.5)
489   listen
490   logstasher
491   mimemagic
492   mini_magick
493   minitest (~> 5.1)
494   oauth-plugin (>= 0.5.1)
495   omniauth
496   omniauth-facebook
497   omniauth-github
498   omniauth-google-oauth2 (>= 0.6.0)
499   omniauth-mediawiki (>= 0.0.4)
500   omniauth-openid
501   omniauth-windowslive
502   openstreetmap-deadlock_retry (>= 1.3.0)
503   pg
504   poltergeist
505   psych
506   puma (~> 3.7)
507   quad_tile (~> 1.0.1)
508   r2 (~> 0.2.7)
509   rack-cors
510   rack-uri_sanitizer
511   rails (= 5.2.3)
512   rails-controller-testing
513   rails-i18n (~> 4.0.0)
514   record_tag_helper
515   rinku (>= 2.0.6)
516   rotp
517   rubocop
518   rubocop-performance
519   rubocop-rails
520   sanitize
521   sassc-rails
522   secure_headers
523   strong_migrations
524   uglifier (>= 1.3.0)
525   validates_email_format_of (>= 1.5.1)
526   vendorer
527   webmock
528
529 BUNDLED WITH
530    1.17.2