Update to rails 5.2.1
[rails.git] / Gemfile
1 source "https://rubygems.org"
2
3 # Require rails
4 gem "rails", "5.2.1"
5
6 # Require things which have moved to gems in ruby 1.9
7 gem "bigdecimal", "~> 1.1.0", :platforms => :ruby_19
8
9 # Require things which have moved to gems in ruby 2.0
10 gem "psych", :platforms => :ruby_20
11
12 # Require json for multi_json
13 gem "json"
14
15 # Use postgres as the database
16 gem "pg", "~> 0.18"
17
18 # Use SCSS for stylesheets
19 gem "sassc-rails"
20
21 # Use Uglifier as compressor for JavaScript assets
22 gem "uglifier", ">= 1.3.0"
23
24 # Use CoffeeScript for .js.coffee assets and views
25 gem "coffee-rails", "~> 4.2"
26
27 # Use jquery as the JavaScript library
28 gem "jquery-rails"
29
30 # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
31 # gem 'jbuilder', '~> 2.0'
32 gem "jsonify-rails"
33
34 # Reduces boot times through caching; required in config/boot.rb
35 gem "bootsnap", ">= 1.1.0", :require => false
36
37 # Use R2 for RTL conversion
38 gem "r2", "~> 0.2.7"
39
40 # Use autoprefixer to generate CSS prefixes
41 gem "autoprefixer-rails", "~> 8.6.3"
42
43 # Use image_optim to optimise images
44 gem "image_optim_rails"
45
46 # Load rails plugins
47 gem "actionpack-page_caching"
48 gem "active_record_union"
49 gem "cancancan"
50 gem "composite_primary_keys", "~> 11.1.0"
51 gem "delayed_job_active_record"
52 gem "dynamic_form"
53 gem "http_accept_language", "~> 2.0.0"
54 gem "i18n-js", ">= 3.0.0"
55 gem "oauth-plugin", ">= 0.5.1"
56 gem "openstreetmap-deadlock_retry", ">= 1.3.0", :require => "deadlock_retry"
57 gem "paperclip", "~> 5.2"
58 gem "rack-cors"
59 gem "rails-i18n", "~> 4.0.0"
60 gem "record_tag_helper"
61 gem "rinku", ">= 1.2.2", :require => "rails_rinku"
62 gem "validates_email_format_of", ">= 1.5.1"
63
64 # Native OSM extensions
65 gem "quad_tile", "~> 1.0.1"
66
67 # Sanitise URIs
68 gem "rack-uri_sanitizer"
69
70 # Omniauth for authentication
71 gem "omniauth"
72 gem "omniauth-facebook"
73 gem "omniauth-github"
74 gem "omniauth-google-oauth2", ">= 0.2.7"
75 gem "omniauth-mediawiki", ">= 0.0.3"
76 gem "omniauth-openid"
77 gem "omniauth-windowslive"
78
79 # Markdown formatting support
80 gem "redcarpet"
81
82 # For status transitions of Issues
83 gem "aasm"
84
85 # Load libxml support for XML parsing and generation
86 gem "libxml-ruby", ">= 2.0.5", :require => "libxml"
87
88 # Use for HTML sanitisation
89 gem "htmlentities"
90 gem "sanitize"
91
92 # Load SystemTimer for implementing request timeouts
93 gem "SystemTimer", ">= 1.1.3", :require => "system_timer", :platforms => :ruby_18
94
95 # Load faraday for mockable HTTP client
96 gem "faraday"
97
98 # Load geoip for querying Maxmind GeoIP database
99 gem "geoip"
100
101 # Load rotp to generate TOTP tokens
102 gem "rotp"
103
104 # Load memcache client in case we are using it
105 gem "dalli"
106 gem "kgio"
107
108 # Load secure_headers for Content-Security-Policy support
109 gem "secure_headers"
110
111 # Load canonical-rails to generate canonical URLs
112 gem "canonical-rails"
113
114 # Used to generate logstash friendly log files
115 gem "logstasher"
116
117 # Gems useful for development
118 group :development do
119   gem "annotate"
120   gem "better_errors"
121   gem "binding_of_caller"
122   gem "listen"
123   gem "vendorer"
124 end
125
126 # Gems needed for running tests
127 group :test do
128   gem "minitest", "~> 5.1", :platforms => [:ruby_19, :ruby_20]
129   gem "rails-controller-testing"
130   gem "rubocop"
131   gem "webmock"
132 end
133
134 # Needed in development as well so rake can see konacha tasks
135 group :development, :test do
136   gem "capybara", "~> 2.13"
137   gem "coveralls", :require => false
138   gem "factory_bot_rails"
139   gem "jshint"
140   gem "poltergeist"
141   gem "puma", "~> 3.7"
142 end