Merge remote-tracking branch 'upstream/pull/1652'
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     actioncable (5.1.4)
6       actionpack (= 5.1.4)
7       nio4r (~> 2.0)
8       websocket-driver (~> 0.6.1)
9     actionmailer (5.1.4)
10       actionpack (= 5.1.4)
11       actionview (= 5.1.4)
12       activejob (= 5.1.4)
13       mail (~> 2.5, >= 2.5.4)
14       rails-dom-testing (~> 2.0)
15     actionpack (5.1.4)
16       actionview (= 5.1.4)
17       activesupport (= 5.1.4)
18       rack (~> 2.0)
19       rack-test (>= 0.6.3)
20       rails-dom-testing (~> 2.0)
21       rails-html-sanitizer (~> 1.0, >= 1.0.2)
22     actionpack-page_caching (1.1.0)
23       actionpack (>= 4.0.0, < 6)
24     actionview (5.1.4)
25       activesupport (= 5.1.4)
26       builder (~> 3.1)
27       erubi (~> 1.4)
28       rails-dom-testing (~> 2.0)
29       rails-html-sanitizer (~> 1.0, >= 1.0.3)
30     activejob (5.1.4)
31       activesupport (= 5.1.4)
32       globalid (>= 0.3.6)
33     activemodel (5.1.4)
34       activesupport (= 5.1.4)
35     activerecord (5.1.4)
36       activemodel (= 5.1.4)
37       activesupport (= 5.1.4)
38       arel (~> 8.0)
39     activesupport (5.1.4)
40       concurrent-ruby (~> 1.0, >= 1.0.2)
41       i18n (~> 0.7)
42       minitest (~> 5.1)
43       tzinfo (~> 1.1)
44     addressable (2.5.2)
45       public_suffix (>= 2.0.2, < 4.0)
46     annotate (2.7.2)
47       activerecord (>= 3.2, < 6.0)
48       rake (>= 10.4, < 13.0)
49     arel (8.0.0)
50     ast (2.3.0)
51     autoprefixer-rails (7.1.5)
52       execjs
53     bigdecimal (1.1.0)
54     builder (3.2.3)
55     canonical-rails (0.2.1)
56       rails (>= 4.1, < 5.2)
57     capybara (2.15.4)
58       addressable
59       mini_mime (>= 0.1.3)
60       nokogiri (>= 1.3.3)
61       rack (>= 1.0.0)
62       rack-test (>= 0.5.4)
63       xpath (~> 2.0)
64     climate_control (0.2.0)
65     cliver (0.3.2)
66     cocaine (0.5.8)
67       climate_control (>= 0.0.3, < 1.0)
68     coffee-rails (4.2.2)
69       coffee-script (>= 2.2.0)
70       railties (>= 4.0.0)
71     coffee-script (2.4.1)
72       coffee-script-source
73       execjs
74     coffee-script-source (1.12.2)
75     composite_primary_keys (10.0.0)
76       activerecord (~> 5.1.0)
77     concurrent-ruby (1.0.5)
78     coveralls (0.8.21)
79       json (>= 1.8, < 3)
80       simplecov (~> 0.14.1)
81       term-ansicolor (~> 1.3)
82       thor (~> 0.19.4)
83       tins (~> 1.6)
84     crack (0.4.3)
85       safe_yaml (~> 1.0.0)
86     crass (1.0.2)
87     dalli (2.7.6)
88     docile (1.1.5)
89     dynamic_form (1.1.4)
90     erubi (1.6.1)
91     execjs (2.7.0)
92     exifr (1.3.2)
93     factory_girl (4.8.1)
94       activesupport (>= 3.0.0)
95     factory_girl_rails (4.8.0)
96       factory_girl (~> 4.8.0)
97       railties (>= 3.0.0)
98     faraday (0.12.2)
99       multipart-post (>= 1.2, < 3)
100     ffi (1.9.18)
101     fspath (3.1.0)
102     geoip (1.6.3)
103     globalid (0.4.0)
104       activesupport (>= 4.2.0)
105     hashdiff (0.3.7)
106     hashie (3.5.6)
107     htmlentities (4.3.4)
108     http_accept_language (2.0.5)
109     i18n (0.8.6)
110     i18n-js (3.0.1)
111       i18n (~> 0.6, >= 0.6.6)
112     image_optim (0.25.0)
113       exifr (~> 1.2, >= 1.2.2)
114       fspath (~> 3.0)
115       image_size (~> 1.5)
116       in_threads (~> 1.3)
117       progress (~> 3.0, >= 3.0.1)
118     image_optim_rails (0.4.1)
119       image_optim (~> 0.24)
120       rails
121       sprockets
122     image_size (1.5.0)
123     in_threads (1.4.0)
124     jquery-rails (4.3.1)
125       rails-dom-testing (>= 1, < 3)
126       railties (>= 4.2.0)
127       thor (>= 0.14, < 2.0)
128     jshint (1.5.0)
129       execjs (>= 1.4.0)
130       multi_json (~> 1.0)
131       therubyracer (~> 0.12.1)
132     json (2.1.0)
133     jsonify (0.3.1)
134       multi_json (~> 1.0)
135     jsonify-rails (0.3.2)
136       actionpack
137       jsonify (< 0.4.0)
138     jwt (1.5.6)
139     kgio (2.11.0)
140     libv8 (3.16.14.19)
141     libxml-ruby (3.0.0)
142     listen (3.1.5)
143       rb-fsevent (~> 0.9, >= 0.9.4)
144       rb-inotify (~> 0.9, >= 0.9.7)
145       ruby_dep (~> 1.2)
146     logstash-event (1.2.02)
147     logstasher (1.2.1)
148       activesupport (>= 4.0)
149       logstash-event (~> 1.2.0)
150       request_store
151     loofah (2.1.1)
152       crass (~> 1.0.2)
153       nokogiri (>= 1.5.9)
154     mail (2.6.6)
155       mime-types (>= 1.16, < 4)
156     method_source (0.9.0)
157     mime-types (3.1)
158       mime-types-data (~> 3.2015)
159     mime-types-data (3.2016.0521)
160     mimemagic (0.3.0)
161     mini_mime (0.1.4)
162     mini_portile2 (2.3.0)
163     minitest (5.10.3)
164     multi_json (1.12.2)
165     multi_xml (0.6.0)
166     multipart-post (2.0.0)
167     nio4r (2.1.0)
168     nokogiri (1.8.1)
169       mini_portile2 (~> 2.3.0)
170     nokogumbo (1.4.13)
171       nokogiri
172     oauth (0.4.7)
173     oauth-plugin (0.5.1)
174       multi_json
175       oauth (~> 0.4.4)
176       oauth2 (>= 0.5.0)
177       rack
178     oauth2 (1.4.0)
179       faraday (>= 0.8, < 0.13)
180       jwt (~> 1.0)
181       multi_json (~> 1.3)
182       multi_xml (~> 0.5)
183       rack (>= 1.2, < 3)
184     omniauth (1.7.1)
185       hashie (>= 3.4.6, < 3.6.0)
186       rack (>= 1.6.2, < 3)
187     omniauth-facebook (4.0.0)
188       omniauth-oauth2 (~> 1.2)
189     omniauth-github (1.3.0)
190       omniauth (~> 1.5)
191       omniauth-oauth2 (>= 1.4.0, < 2.0)
192     omniauth-google-oauth2 (0.5.2)
193       jwt (~> 1.5)
194       multi_json (~> 1.3)
195       omniauth (>= 1.1.1)
196       omniauth-oauth2 (>= 1.3.1)
197     omniauth-mediawiki (0.0.3)
198       jwt (~> 1.0)
199       omniauth-oauth (~> 1.0)
200     omniauth-oauth (1.1.0)
201       oauth
202       omniauth (~> 1.0)
203     omniauth-oauth2 (1.4.0)
204       oauth2 (~> 1.0)
205       omniauth (~> 1.2)
206     omniauth-openid (1.0.1)
207       omniauth (~> 1.0)
208       rack-openid (~> 1.3.1)
209     omniauth-windowslive (0.0.12)
210       multi_json (~> 1.12)
211       omniauth-oauth2 (~> 1.4)
212     openstreetmap-deadlock_retry (1.3.0)
213     paperclip (4.3.7)
214       activemodel (>= 3.2.0)
215       activesupport (>= 3.2.0)
216       cocaine (~> 0.5.5)
217       mime-types
218       mimemagic (= 0.3.0)
219     parallel (1.12.0)
220     parser (2.4.0.0)
221       ast (~> 2.2)
222     pg (0.21.0)
223     poltergeist (1.16.0)
224       capybara (~> 2.1)
225       cliver (~> 0.3.1)
226       websocket-driver (>= 0.2.0)
227     powerpack (0.1.1)
228     progress (3.3.2)
229     psych (2.2.4)
230     public_suffix (3.0.0)
231     r2 (0.2.7)
232     rack (2.0.3)
233     rack-cors (1.0.1)
234     rack-openid (1.3.1)
235       rack (>= 1.1.0)
236       ruby-openid (>= 2.1.8)
237     rack-test (0.7.0)
238       rack (>= 1.0, < 3)
239     rack-uri_sanitizer (0.0.2)
240     rails (5.1.4)
241       actioncable (= 5.1.4)
242       actionmailer (= 5.1.4)
243       actionpack (= 5.1.4)
244       actionview (= 5.1.4)
245       activejob (= 5.1.4)
246       activemodel (= 5.1.4)
247       activerecord (= 5.1.4)
248       activesupport (= 5.1.4)
249       bundler (>= 1.3.0)
250       railties (= 5.1.4)
251       sprockets-rails (>= 2.0.0)
252     rails-controller-testing (1.0.2)
253       actionpack (~> 5.x, >= 5.0.1)
254       actionview (~> 5.x, >= 5.0.1)
255       activesupport (~> 5.x)
256     rails-dom-testing (2.0.3)
257       activesupport (>= 4.2.0)
258       nokogiri (>= 1.6)
259     rails-html-sanitizer (1.0.3)
260       loofah (~> 2.0)
261     rails-i18n (4.0.2)
262       i18n (~> 0.6)
263       rails (>= 4.0)
264     railties (5.1.4)
265       actionpack (= 5.1.4)
266       activesupport (= 5.1.4)
267       method_source
268       rake (>= 0.8.7)
269       thor (>= 0.18.1, < 2.0)
270     rainbow (2.2.2)
271       rake
272     rake (12.1.0)
273     rb-fsevent (0.10.2)
274     rb-inotify (0.9.10)
275       ffi (>= 0.5.0, < 2)
276     record_tag_helper (1.0.0)
277       actionview (~> 5.x)
278     redcarpet (3.4.0)
279     ref (2.0.0)
280     request_store (1.3.2)
281     rinku (2.0.3)
282     rotp (3.3.0)
283     rubocop (0.50.0)
284       parallel (~> 1.10)
285       parser (>= 2.3.3.1, < 3.0)
286       powerpack (~> 0.1)
287       rainbow (>= 2.2.2, < 3.0)
288       ruby-progressbar (~> 1.7)
289       unicode-display_width (~> 1.0, >= 1.0.1)
290     ruby-openid (2.7.0)
291     ruby-progressbar (1.9.0)
292     ruby_dep (1.5.0)
293     safe_yaml (1.0.4)
294     sanitize (4.5.0)
295       crass (~> 1.0.2)
296       nokogiri (>= 1.4.4)
297       nokogumbo (~> 1.4.1)
298     sass (3.5.2)
299       sass-listen (~> 4.0.0)
300     sass-listen (4.0.0)
301       rb-fsevent (~> 0.9, >= 0.9.4)
302       rb-inotify (~> 0.9, >= 0.9.7)
303     sass-rails (5.0.6)
304       railties (>= 4.0.0, < 6)
305       sass (~> 3.1)
306       sprockets (>= 2.8, < 4.0)
307       sprockets-rails (>= 2.0, < 4.0)
308       tilt (>= 1.1, < 3)
309     secure_headers (4.0.1)
310       useragent (>= 0.15.0)
311     simplecov (0.14.1)
312       docile (~> 1.1.0)
313       json (>= 1.8, < 3)
314       simplecov-html (~> 0.10.0)
315     simplecov-html (0.10.2)
316     sprockets (3.7.1)
317       concurrent-ruby (~> 1.0)
318       rack (> 1, < 3)
319     sprockets-rails (3.2.1)
320       actionpack (>= 4.0)
321       activesupport (>= 4.0)
322       sprockets (>= 3.0.0)
323     term-ansicolor (1.6.0)
324       tins (~> 1.0)
325     therubyracer (0.12.3)
326       libv8 (~> 3.16.14.15)
327       ref
328     thor (0.19.4)
329     thread_safe (0.3.6)
330     tilt (2.0.8)
331     tins (1.15.0)
332     tzinfo (1.2.3)
333       thread_safe (~> 0.1)
334     uglifier (3.2.0)
335       execjs (>= 0.3.0, < 3)
336     unicode-display_width (1.3.0)
337     useragent (0.16.8)
338     validates_email_format_of (1.6.3)
339       i18n
340     vendorer (0.1.16)
341     webmock (3.1.0)
342       addressable (>= 2.3.6)
343       crack (>= 0.3.2)
344       hashdiff
345     websocket-driver (0.6.5)
346       websocket-extensions (>= 0.1.0)
347     websocket-extensions (0.1.2)
348     xpath (2.1.0)
349       nokogiri (~> 1.3)
350
351 PLATFORMS
352   ruby
353
354 DEPENDENCIES
355   SystemTimer (>= 1.1.3)
356   actionpack-page_caching
357   annotate
358   autoprefixer-rails
359   bigdecimal (~> 1.1.0)
360   canonical-rails
361   coffee-rails (~> 4.2)
362   composite_primary_keys (~> 10.0.0)
363   coveralls
364   dalli
365   dynamic_form
366   factory_girl_rails
367   faraday
368   geoip
369   htmlentities
370   http_accept_language (~> 2.0.0)
371   i18n-js (>= 3.0.0)
372   image_optim_rails
373   jquery-rails
374   jshint
375   json
376   jsonify-rails
377   kgio
378   libxml-ruby (>= 2.0.5)
379   listen
380   logstasher
381   minitest (~> 5.1)
382   oauth-plugin (>= 0.5.1)
383   omniauth
384   omniauth-facebook
385   omniauth-github
386   omniauth-google-oauth2 (>= 0.2.7)
387   omniauth-mediawiki (>= 0.0.3)
388   omniauth-openid
389   omniauth-windowslive
390   openstreetmap-deadlock_retry (>= 1.3.0)
391   paperclip (~> 4.0)
392   pg
393   poltergeist
394   psych
395   r2 (~> 0.2.7)
396   rack-cors
397   rack-uri_sanitizer
398   rails (= 5.1.4)
399   rails-controller-testing
400   rails-i18n (~> 4.0.0)
401   record_tag_helper
402   redcarpet
403   rinku (>= 1.2.2)
404   rotp
405   rubocop
406   sanitize
407   sass-rails (~> 5.0)
408   secure_headers
409   uglifier (>= 1.3.0)
410   validates_email_format_of (>= 1.5.1)
411   vendorer
412   webmock
413
414 BUNDLED WITH
415    1.15.4