more geocoder stuff
[rails.git] / README
1 INSTALL
2 =======
3
4 * get rails working (http://www.rubyonrails.org/)
5
6 * make your db (see db/README)
7
8 * install ruby libxml bindings:
9
10    # sudo aptitude install libxml-ruby1.8 libxml-parser-ruby1.8
11
12 * make sure you have a MTA listening on localhost:25 if you want mail
13
14 * script/server
15
16 * thats it
17
18 API CHANGES FOR EDITOR AUTHORS
19 ==============================
20
21 See
22
23 http://wiki.openstreetmap.org/index.php/REST#Changes_in_the_upcoming_0.4_API
24
25 HACKING
26 =======
27
28 log in to your site (proably localhost:3000)
29
30 create a user and confirm it
31
32 you want to play with the API (probably at localhost:3000/api/0.4/node/create etc)
33
34 Lots of tests are needed to test the API.
35
36 Lots of little things to make the site work like the old one.
37
38 Also see the 'rails_port' component for bugs:
39 http://trac.openstreetmap.org/query?status=new&status=assigned&status=reopened&component=rails_port&order=priority