Add minitest-rails-capybara
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.1.0)
6     actioncable (5.0.5)
7       actionpack (= 5.0.5)
8       nio4r (>= 1.2, < 3.0)
9       websocket-driver (~> 0.6.1)
10     actionmailer (5.0.5)
11       actionpack (= 5.0.5)
12       actionview (= 5.0.5)
13       activejob (= 5.0.5)
14       mail (~> 2.5, >= 2.5.4)
15       rails-dom-testing (~> 2.0)
16     actionpack (5.0.5)
17       actionview (= 5.0.5)
18       activesupport (= 5.0.5)
19       rack (~> 2.0)
20       rack-test (~> 0.6.3)
21       rails-dom-testing (~> 2.0)
22       rails-html-sanitizer (~> 1.0, >= 1.0.2)
23     actionpack-page_caching (1.1.0)
24       actionpack (>= 4.0.0, < 6)
25     actionview (5.0.5)
26       activesupport (= 5.0.5)
27       builder (~> 3.1)
28       erubis (~> 2.7.0)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.0.3)
31     activejob (5.0.5)
32       activesupport (= 5.0.5)
33       globalid (>= 0.3.6)
34     activemodel (5.0.5)
35       activesupport (= 5.0.5)
36     activerecord (5.0.5)
37       activemodel (= 5.0.5)
38       activesupport (= 5.0.5)
39       arel (~> 7.0)
40     activesupport (5.0.5)
41       concurrent-ruby (~> 1.0, >= 1.0.2)
42       i18n (~> 0.7)
43       minitest (~> 5.1)
44       tzinfo (~> 1.1)
45     addressable (2.5.1)
46       public_suffix (~> 2.0, >= 2.0.2)
47     arel (7.1.4)
48     ast (2.3.0)
49     autoprefixer-rails (7.1.2.3)
50       execjs
51     bigdecimal (1.1.0)
52     builder (3.2.3)
53     canonical-rails (0.2.1)
54       rails (>= 4.1, < 5.2)
55     capybara (2.14.4)
56       addressable
57       mime-types (>= 1.16)
58       nokogiri (>= 1.3.3)
59       rack (>= 1.0.0)
60       rack-test (>= 0.5.4)
61       xpath (~> 2.0)
62     climate_control (0.2.0)
63     cliver (0.3.2)
64     cocaine (0.5.8)
65       climate_control (>= 0.0.3, < 1.0)
66     coffee-rails (4.2.2)
67       coffee-script (>= 2.2.0)
68       railties (>= 4.0.0)
69     coffee-script (2.4.1)
70       coffee-script-source
71       execjs
72     coffee-script-source (1.12.2)
73     composite_primary_keys (9.0.7)
74       activerecord (~> 5.0.0)
75     concurrent-ruby (1.0.5)
76     coveralls (0.8.21)
77       json (>= 1.8, < 3)
78       simplecov (~> 0.14.1)
79       term-ansicolor (~> 1.3)
80       thor (~> 0.19.4)
81       tins (~> 1.6)
82     crack (0.4.3)
83       safe_yaml (~> 1.0.0)
84     crass (1.0.2)
85     dalli (2.7.6)
86     deadlock_retry (1.2.0)
87     docile (1.1.5)
88     dynamic_form (1.1.4)
89     erubis (2.7.0)
90     execjs (2.7.0)
91     exifr (1.3.1)
92     factory_girl (4.8.0)
93       activesupport (>= 3.0.0)
94     factory_girl_rails (4.8.0)
95       factory_girl (~> 4.8.0)
96       railties (>= 3.0.0)
97     faraday (0.12.2)
98       multipart-post (>= 1.2, < 3)
99     ffi (1.9.18)
100     fspath (3.1.0)
101     geoip (1.6.3)
102     globalid (0.4.0)
103       activesupport (>= 4.2.0)
104     hashdiff (0.3.4)
105     hashie (3.5.6)
106     htmlentities (4.3.4)
107     http_accept_language (2.0.5)
108     i18n (0.8.6)
109     i18n-js (3.0.0)
110       i18n (~> 0.6, >= 0.6.6)
111     image_optim (0.25.0)
112       exifr (~> 1.2, >= 1.2.2)
113       fspath (~> 3.0)
114       image_size (~> 1.5)
115       in_threads (~> 1.3)
116       progress (~> 3.0, >= 3.0.1)
117     image_optim_rails (0.4.1)
118       image_optim (~> 0.24)
119       rails
120       sprockets
121     image_size (1.5.0)
122     in_threads (1.4.0)
123     jquery-rails (4.3.1)
124       rails-dom-testing (>= 1, < 3)
125       railties (>= 4.2.0)
126       thor (>= 0.14, < 2.0)
127     jshint (1.5.0)
128       execjs (>= 1.4.0)
129       multi_json (~> 1.0)
130       therubyracer (~> 0.12.1)
131     json (2.1.0)
132     jsonify (0.3.1)
133       multi_json (~> 1.0)
134     jsonify-rails (0.3.2)
135       actionpack
136       jsonify (< 0.4.0)
137     jwt (1.5.6)
138     kgio (2.11.0)
139     libv8 (3.16.14.19)
140     libxml-ruby (3.0.0)
141     listen (3.1.5)
142       rb-fsevent (~> 0.9, >= 0.9.4)
143       rb-inotify (~> 0.9, >= 0.9.7)
144       ruby_dep (~> 1.2)
145     logstash-event (1.2.02)
146     logstasher (1.2.1)
147       activesupport (>= 4.0)
148       logstash-event (~> 1.2.0)
149       request_store
150     loofah (2.0.3)
151       nokogiri (>= 1.5.9)
152     mail (2.6.6)
153       mime-types (>= 1.16, < 4)
154     method_source (0.8.2)
155     mime-types (3.1)
156       mime-types-data (~> 3.2015)
157     mime-types-data (3.2016.0521)
158     mimemagic (0.3.0)
159     mini_portile2 (2.2.0)
160     minitest (5.10.3)
161     minitest-capybara (0.8.2)
162       capybara (~> 2.2)
163       minitest (~> 5.0)
164       rake
165     minitest-metadata (0.6.0)
166       minitest (>= 4.7, < 6.0)
167     minitest-rails (3.0.0)
168       minitest (~> 5.8)
169       railties (~> 5.0)
170     minitest-rails-capybara (3.0.1)
171       capybara (~> 2.7)
172       minitest-capybara (~> 0.8)
173       minitest-metadata (~> 0.6)
174       minitest-rails (~> 3.0)
175     multi_json (1.12.1)
176     multi_xml (0.6.0)
177     multipart-post (2.0.0)
178     nio4r (2.1.0)
179     nokogiri (1.8.0)
180       mini_portile2 (~> 2.2.0)
181     nokogumbo (1.4.13)
182       nokogiri
183     oauth (0.4.7)
184     oauth-plugin (0.5.1)
185       multi_json
186       oauth (~> 0.4.4)
187       oauth2 (>= 0.5.0)
188       rack
189     oauth2 (1.4.0)
190       faraday (>= 0.8, < 0.13)
191       jwt (~> 1.0)
192       multi_json (~> 1.3)
193       multi_xml (~> 0.5)
194       rack (>= 1.2, < 3)
195     omniauth (1.6.1)
196       hashie (>= 3.4.6, < 3.6.0)
197       rack (>= 1.6.2, < 3)
198     omniauth-facebook (4.0.0)
199       omniauth-oauth2 (~> 1.2)
200     omniauth-github (1.3.0)
201       omniauth (~> 1.5)
202       omniauth-oauth2 (>= 1.4.0, < 2.0)
203     omniauth-google-oauth2 (0.5.2)
204       jwt (~> 1.5)
205       multi_json (~> 1.3)
206       omniauth (>= 1.1.1)
207       omniauth-oauth2 (>= 1.3.1)
208     omniauth-mediawiki (0.0.3)
209       jwt (~> 1.0)
210       omniauth-oauth (~> 1.0)
211     omniauth-oauth (1.1.0)
212       oauth
213       omniauth (~> 1.0)
214     omniauth-oauth2 (1.4.0)
215       oauth2 (~> 1.0)
216       omniauth (~> 1.2)
217     omniauth-openid (1.0.1)
218       omniauth (~> 1.0)
219       rack-openid (~> 1.3.1)
220     omniauth-windowslive (0.0.12)
221       multi_json (~> 1.12)
222       omniauth-oauth2 (~> 1.4)
223     paperclip (4.3.7)
224       activemodel (>= 3.2.0)
225       activesupport (>= 3.2.0)
226       cocaine (~> 0.5.5)
227       mime-types
228       mimemagic (= 0.3.0)
229     parallel (1.12.0)
230     parser (2.4.0.0)
231       ast (~> 2.2)
232     pg (0.21.0)
233     poltergeist (1.15.0)
234       capybara (~> 2.1)
235       cliver (~> 0.3.1)
236       websocket-driver (>= 0.2.0)
237     powerpack (0.1.1)
238     progress (3.3.1)
239     psych (2.2.4)
240     public_suffix (2.0.5)
241     r2 (0.2.7)
242     rack (2.0.3)
243     rack-cors (1.0.1)
244     rack-openid (1.3.1)
245       rack (>= 1.1.0)
246       ruby-openid (>= 2.1.8)
247     rack-test (0.6.3)
248       rack (>= 1.0)
249     rack-uri_sanitizer (0.0.2)
250     rails (5.0.5)
251       actioncable (= 5.0.5)
252       actionmailer (= 5.0.5)
253       actionpack (= 5.0.5)
254       actionview (= 5.0.5)
255       activejob (= 5.0.5)
256       activemodel (= 5.0.5)
257       activerecord (= 5.0.5)
258       activesupport (= 5.0.5)
259       bundler (>= 1.3.0)
260       railties (= 5.0.5)
261       sprockets-rails (>= 2.0.0)
262     rails-controller-testing (1.0.2)
263       actionpack (~> 5.x, >= 5.0.1)
264       actionview (~> 5.x, >= 5.0.1)
265       activesupport (~> 5.x)
266     rails-dom-testing (2.0.3)
267       activesupport (>= 4.2.0)
268       nokogiri (>= 1.6)
269     rails-html-sanitizer (1.0.3)
270       loofah (~> 2.0)
271     rails-i18n (4.0.2)
272       i18n (~> 0.6)
273       rails (>= 4.0)
274     railties (5.0.5)
275       actionpack (= 5.0.5)
276       activesupport (= 5.0.5)
277       method_source
278       rake (>= 0.8.7)
279       thor (>= 0.18.1, < 2.0)
280     rainbow (2.2.2)
281       rake
282     rake (12.0.0)
283     rb-fsevent (0.10.2)
284     rb-inotify (0.9.10)
285       ffi (>= 0.5.0, < 2)
286     record_tag_helper (1.0.0)
287       actionview (~> 5.x)
288     redcarpet (3.4.0)
289     ref (2.0.0)
290     request_store (1.3.2)
291     rinku (2.0.2)
292     rotp (3.3.0)
293     rubocop (0.49.1)
294       parallel (~> 1.10)
295       parser (>= 2.3.3.1, < 3.0)
296       powerpack (~> 0.1)
297       rainbow (>= 1.99.1, < 3.0)
298       ruby-progressbar (~> 1.7)
299       unicode-display_width (~> 1.0, >= 1.0.1)
300     ruby-openid (2.7.0)
301     ruby-progressbar (1.8.1)
302     ruby_dep (1.5.0)
303     safe_yaml (1.0.4)
304     sanitize (4.5.0)
305       crass (~> 1.0.2)
306       nokogiri (>= 1.4.4)
307       nokogumbo (~> 1.4.1)
308     sass (3.5.1)
309       sass-listen (~> 4.0.0)
310     sass-listen (4.0.0)
311       rb-fsevent (~> 0.9, >= 0.9.4)
312       rb-inotify (~> 0.9, >= 0.9.7)
313     sass-rails (5.0.6)
314       railties (>= 4.0.0, < 6)
315       sass (~> 3.1)
316       sprockets (>= 2.8, < 4.0)
317       sprockets-rails (>= 2.0, < 4.0)
318       tilt (>= 1.1, < 3)
319     secure_headers (3.6.7)
320       useragent
321     simplecov (0.14.1)
322       docile (~> 1.1.0)
323       json (>= 1.8, < 3)
324       simplecov-html (~> 0.10.0)
325     simplecov-html (0.10.1)
326     sprockets (3.7.1)
327       concurrent-ruby (~> 1.0)
328       rack (> 1, < 3)
329     sprockets-rails (3.2.0)
330       actionpack (>= 4.0)
331       activesupport (>= 4.0)
332       sprockets (>= 3.0.0)
333     term-ansicolor (1.6.0)
334       tins (~> 1.0)
335     therubyracer (0.12.3)
336       libv8 (~> 3.16.14.15)
337       ref
338     thor (0.19.4)
339     thread_safe (0.3.6)
340     tilt (2.0.8)
341     tins (1.15.0)
342     tzinfo (1.2.3)
343       thread_safe (~> 0.1)
344     uglifier (3.2.0)
345       execjs (>= 0.3.0, < 3)
346     unicode-display_width (1.3.0)
347     useragent (0.16.8)
348     validates_email_format_of (1.6.3)
349       i18n
350     vendorer (0.1.16)
351     webmock (3.0.1)
352       addressable (>= 2.3.6)
353       crack (>= 0.3.2)
354       hashdiff
355     websocket-driver (0.6.5)
356       websocket-extensions (>= 0.1.0)
357     websocket-extensions (0.1.2)
358     xpath (2.1.0)
359       nokogiri (~> 1.3)
360
361 PLATFORMS
362   ruby
363
364 DEPENDENCIES
365   SystemTimer (>= 1.1.3)
366   aasm
367   actionpack-page_caching
368   autoprefixer-rails
369   bigdecimal (~> 1.1.0)
370   canonical-rails
371   coffee-rails (~> 4.2)
372   composite_primary_keys (~> 9.0.7)
373   coveralls
374   dalli
375   deadlock_retry (>= 1.2.0)
376   dynamic_form
377   factory_girl_rails
378   faraday
379   geoip
380   htmlentities
381   http_accept_language (~> 2.0.0)
382   i18n-js (>= 3.0.0)
383   image_optim_rails
384   jquery-rails
385   jshint
386   json
387   jsonify-rails
388   kgio
389   libxml-ruby (>= 2.0.5)
390   listen
391   logstasher
392   minitest (~> 5.1)
393   minitest-rails-capybara
394   oauth-plugin (>= 0.5.1)
395   omniauth
396   omniauth-facebook
397   omniauth-github
398   omniauth-google-oauth2 (>= 0.2.7)
399   omniauth-mediawiki (>= 0.0.3)
400   omniauth-openid
401   omniauth-windowslive
402   paperclip (~> 4.0)
403   pg
404   poltergeist
405   psych
406   r2
407   rack-cors
408   rack-uri_sanitizer
409   rails (= 5.0.5)
410   rails-controller-testing
411   rails-i18n (~> 4.0.0)
412   record_tag_helper
413   redcarpet
414   rinku (>= 1.2.2)
415   rotp
416   rubocop
417   sanitize
418   sass-rails (~> 5.0)
419   secure_headers
420   uglifier (>= 1.3.0)
421   validates_email_format_of (>= 1.5.1)
422   vendorer
423   webmock
424
425 BUNDLED WITH
426    1.13.7