Move coveralls submission to actions workflow
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.1.1)
6       concurrent-ruby (~> 1.0)
7     actioncable (6.0.3.4)
8       actionpack (= 6.0.3.4)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailbox (6.0.3.4)
12       actionpack (= 6.0.3.4)
13       activejob (= 6.0.3.4)
14       activerecord (= 6.0.3.4)
15       activestorage (= 6.0.3.4)
16       activesupport (= 6.0.3.4)
17       mail (>= 2.7.1)
18     actionmailer (6.0.3.4)
19       actionpack (= 6.0.3.4)
20       actionview (= 6.0.3.4)
21       activejob (= 6.0.3.4)
22       mail (~> 2.5, >= 2.5.4)
23       rails-dom-testing (~> 2.0)
24     actionpack (6.0.3.4)
25       actionview (= 6.0.3.4)
26       activesupport (= 6.0.3.4)
27       rack (~> 2.0, >= 2.0.8)
28       rack-test (>= 0.6.3)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.2.0)
31     actionpack-page_caching (1.2.3)
32       actionpack (>= 5.0.0)
33     actiontext (6.0.3.4)
34       actionpack (= 6.0.3.4)
35       activerecord (= 6.0.3.4)
36       activestorage (= 6.0.3.4)
37       activesupport (= 6.0.3.4)
38       nokogiri (>= 1.8.5)
39     actionview (6.0.3.4)
40       activesupport (= 6.0.3.4)
41       builder (~> 3.1)
42       erubi (~> 1.4)
43       rails-dom-testing (~> 2.0)
44       rails-html-sanitizer (~> 1.1, >= 1.2.0)
45     active_record_union (1.3.0)
46       activerecord (>= 4.0)
47     activejob (6.0.3.4)
48       activesupport (= 6.0.3.4)
49       globalid (>= 0.3.6)
50     activemodel (6.0.3.4)
51       activesupport (= 6.0.3.4)
52     activerecord (6.0.3.4)
53       activemodel (= 6.0.3.4)
54       activesupport (= 6.0.3.4)
55     activerecord-import (1.0.7)
56       activerecord (>= 3.2)
57     activestorage (6.0.3.4)
58       actionpack (= 6.0.3.4)
59       activejob (= 6.0.3.4)
60       activerecord (= 6.0.3.4)
61       marcel (~> 0.3.1)
62     activesupport (6.0.3.4)
63       concurrent-ruby (~> 1.0, >= 1.0.2)
64       i18n (>= 0.7, < 2)
65       minitest (~> 5.1)
66       tzinfo (~> 1.1)
67       zeitwerk (~> 2.2, >= 2.2.2)
68     addressable (2.7.0)
69       public_suffix (>= 2.0.2, < 5.0)
70     annotate (3.1.1)
71       activerecord (>= 3.2, < 7.0)
72       rake (>= 10.4, < 14.0)
73     ast (2.4.1)
74     autoprefixer-rails (10.0.3.0)
75       execjs
76     aws-eventstream (1.1.0)
77     aws-partitions (1.402.0)
78     aws-sdk-core (3.110.0)
79       aws-eventstream (~> 1, >= 1.0.2)
80       aws-partitions (~> 1, >= 1.239.0)
81       aws-sigv4 (~> 1.1)
82       jmespath (~> 1.0)
83     aws-sdk-kms (1.39.0)
84       aws-sdk-core (~> 3, >= 3.109.0)
85       aws-sigv4 (~> 1.1)
86     aws-sdk-s3 (1.86.0)
87       aws-sdk-core (~> 3, >= 3.109.0)
88       aws-sdk-kms (~> 1)
89       aws-sigv4 (~> 1.1)
90     aws-sigv4 (1.2.2)
91       aws-eventstream (~> 1, >= 1.0.2)
92     better_errors (2.9.1)
93       coderay (>= 1.0.0)
94       erubi (>= 1.0.0)
95       rack (>= 0.9.0)
96     better_html (1.0.15)
97       actionview (>= 4.0)
98       activesupport (>= 4.0)
99       ast (~> 2.0)
100       erubi (~> 1.4)
101       html_tokenizer (~> 0.0.6)
102       parser (>= 2.4)
103       smart_properties
104     bigdecimal (1.1.0)
105     binding_of_caller (0.8.0)
106       debug_inspector (>= 0.0.1)
107     bootsnap (1.5.1)
108       msgpack (~> 1.0)
109     bootstrap (4.5.3)
110       autoprefixer-rails (>= 9.1.0)
111       popper_js (>= 1.14.3, < 2)
112       sassc-rails (>= 2.0.0)
113     bootstrap_form (4.5.0)
114       actionpack (>= 5.2)
115       activemodel (>= 5.2)
116     brakeman (4.10.0)
117     browser (5.1.0)
118     builder (3.2.4)
119     bzip2-ffi (1.0.0)
120       ffi (~> 1.0)
121     cancancan (3.1.0)
122     canonical-rails (0.2.9)
123       rails (>= 4.1, < 6.1)
124     capybara (3.34.0)
125       addressable
126       mini_mime (>= 0.1.3)
127       nokogiri (~> 1.8)
128       rack (>= 1.6.0)
129       rack-test (>= 0.6.3)
130       regexp_parser (~> 1.5)
131       xpath (~> 3.2)
132     childprocess (3.0.0)
133     coderay (1.1.3)
134     composite_primary_keys (12.0.3)
135       activerecord (~> 6.0.0)
136     concurrent-ruby (1.1.7)
137     config (2.2.1)
138       deep_merge (~> 1.2, >= 1.2.1)
139       dry-validation (~> 1.0, >= 1.0.0)
140     crack (0.4.4)
141     crass (1.0.6)
142     dalli (2.7.11)
143     debug_inspector (0.0.3)
144     deep_merge (1.2.1)
145     delayed_job (4.1.8)
146       activesupport (>= 3.0, < 6.1)
147     delayed_job_active_record (4.1.4)
148       activerecord (>= 3.0, < 6.1)
149       delayed_job (>= 3.0, < 5)
150     docile (1.3.2)
151     dry-configurable (0.11.6)
152       concurrent-ruby (~> 1.0)
153       dry-core (~> 0.4, >= 0.4.7)
154       dry-equalizer (~> 0.2)
155     dry-container (0.7.2)
156       concurrent-ruby (~> 1.0)
157       dry-configurable (~> 0.1, >= 0.1.3)
158     dry-core (0.4.10)
159       concurrent-ruby (~> 1.0)
160     dry-equalizer (0.3.0)
161     dry-inflector (0.2.0)
162     dry-initializer (3.0.4)
163     dry-logic (1.0.8)
164       concurrent-ruby (~> 1.0)
165       dry-core (~> 0.2)
166       dry-equalizer (~> 0.2)
167     dry-schema (1.5.6)
168       concurrent-ruby (~> 1.0)
169       dry-configurable (~> 0.8, >= 0.8.3)
170       dry-core (~> 0.4)
171       dry-equalizer (~> 0.2)
172       dry-initializer (~> 3.0)
173       dry-logic (~> 1.0)
174       dry-types (~> 1.4)
175     dry-types (1.4.0)
176       concurrent-ruby (~> 1.0)
177       dry-container (~> 0.3)
178       dry-core (~> 0.4, >= 0.4.4)
179       dry-equalizer (~> 0.3)
180       dry-inflector (~> 0.1, >= 0.1.2)
181       dry-logic (~> 1.0, >= 1.0.2)
182     dry-validation (1.6.0)
183       concurrent-ruby (~> 1.0)
184       dry-container (~> 0.7, >= 0.7.1)
185       dry-core (~> 0.4)
186       dry-equalizer (~> 0.2)
187       dry-initializer (~> 3.0)
188       dry-schema (~> 1.5, >= 1.5.2)
189     dynamic_form (1.1.4)
190     erb_lint (0.0.35)
191       activesupport
192       better_html (~> 1.0.7)
193       html_tokenizer
194       parser (>= 2.7.1.4)
195       rainbow
196       rubocop (~> 0.79)
197       smart_properties
198     erubi (1.10.0)
199     execjs (2.7.0)
200     exifr (1.3.9)
201     factory_bot (6.1.0)
202       activesupport (>= 5.0.0)
203     factory_bot_rails (6.1.0)
204       factory_bot (~> 6.1.0)
205       railties (>= 5.0.0)
206     faraday (1.1.0)
207       multipart-post (>= 1.2, < 3)
208       ruby2_keywords
209     ffi (1.13.1)
210     ffi-libarchive (1.0.4)
211       ffi (~> 1.0)
212     fspath (3.1.2)
213     gd2-ffij (0.4.0)
214       ffi (>= 1.0.0)
215     globalid (0.4.2)
216       activesupport (>= 4.2.0)
217     hashdiff (1.0.1)
218     hashie (4.1.0)
219     html_tokenizer (0.0.7)
220     htmlentities (4.3.4)
221     http_accept_language (2.1.1)
222     i18n (1.8.5)
223       concurrent-ruby (~> 1.0)
224     i18n-js (3.8.0)
225       i18n (>= 0.6.6)
226     image_optim (0.27.1)
227       exifr (~> 1.2, >= 1.2.2)
228       fspath (~> 3.0)
229       image_size (>= 1.5, < 3)
230       in_threads (~> 1.3)
231       progress (~> 3.0, >= 3.0.1)
232     image_optim_rails (0.4.3)
233       image_optim (~> 0.24)
234       rails
235       sprockets
236     image_size (2.1.0)
237     in_threads (1.5.4)
238     jbuilder (2.10.1)
239       activesupport (>= 5.0.0)
240     jmespath (1.4.0)
241     jquery-rails (4.4.0)
242       rails-dom-testing (>= 1, < 3)
243       railties (>= 4.2.0)
244       thor (>= 0.14, < 2.0)
245     json (2.3.1)
246     jwt (2.2.2)
247     kgio (2.11.3)
248     kramdown (2.3.0)
249       rexml
250     libxml-ruby (3.2.1)
251     listen (3.3.3)
252       rb-fsevent (~> 0.10, >= 0.10.3)
253       rb-inotify (~> 0.9, >= 0.9.10)
254     logstash-event (1.2.02)
255     logstasher (1.3.0)
256       activesupport (>= 4.0)
257       logstash-event (~> 1.2.0)
258       request_store
259     loofah (2.8.0)
260       crass (~> 1.0.2)
261       nokogiri (>= 1.5.9)
262     mail (2.7.1)
263       mini_mime (>= 0.1.1)
264     marcel (0.3.3)
265       mimemagic (~> 0.3.2)
266     maxminddb (0.1.22)
267     method_source (1.0.0)
268     mimemagic (0.3.5)
269     mini_magick (4.11.0)
270     mini_mime (1.0.2)
271     mini_portile2 (2.4.0)
272     minitest (5.14.2)
273     msgpack (1.3.3)
274     multi_json (1.15.0)
275     multi_xml (0.6.0)
276     multipart-post (2.1.1)
277     nio4r (2.5.4)
278     nokogiri (1.10.10)
279       mini_portile2 (~> 2.4.0)
280     nokogumbo (2.0.4)
281       nokogiri (~> 1.8, >= 1.8.4)
282     oauth (0.4.7)
283     oauth-plugin (0.5.1)
284       multi_json
285       oauth (~> 0.4.4)
286       oauth2 (>= 0.5.0)
287       rack
288     oauth2 (1.4.4)
289       faraday (>= 0.8, < 2.0)
290       jwt (>= 1.0, < 3.0)
291       multi_json (~> 1.3)
292       multi_xml (~> 0.5)
293       rack (>= 1.2, < 3)
294     omniauth (1.9.1)
295       hashie (>= 3.4.6)
296       rack (>= 1.6.2, < 3)
297     omniauth-facebook (8.0.0)
298       omniauth-oauth2 (~> 1.2)
299     omniauth-github (1.4.0)
300       omniauth (~> 1.5)
301       omniauth-oauth2 (>= 1.4.0, < 2.0)
302     omniauth-google-oauth2 (0.8.0)
303       jwt (>= 2.0)
304       omniauth (>= 1.1.1)
305       omniauth-oauth2 (>= 1.6)
306     omniauth-mediawiki (0.0.4)
307       jwt (~> 2.0)
308       omniauth-oauth (~> 1.0)
309     omniauth-oauth (1.1.0)
310       oauth
311       omniauth (~> 1.0)
312     omniauth-oauth2 (1.7.0)
313       oauth2 (~> 1.4)
314       omniauth (~> 1.9)
315     omniauth-openid (1.0.1)
316       omniauth (~> 1.0)
317       rack-openid (~> 1.3.1)
318     omniauth-windowslive (0.0.12)
319       multi_json (~> 1.12)
320       omniauth-oauth2 (~> 1.4)
321     openstreetmap-deadlock_retry (1.3.0)
322     parallel (1.20.1)
323     parser (2.7.2.0)
324       ast (~> 2.4.1)
325     pg (1.2.3)
326     popper_js (1.16.0)
327     progress (3.5.2)
328     psych (3.2.0)
329     public_suffix (4.0.6)
330     puma (5.1.0)
331       nio4r (~> 2.0)
332     quad_tile (1.0.1)
333     r2 (0.2.7)
334     rack (2.2.3)
335     rack-cors (1.1.1)
336       rack (>= 2.0.0)
337     rack-openid (1.3.1)
338       rack (>= 1.1.0)
339       ruby-openid (>= 2.1.8)
340     rack-test (1.1.0)
341       rack (>= 1.0, < 3)
342     rack-uri_sanitizer (0.0.2)
343     rails (6.0.3.4)
344       actioncable (= 6.0.3.4)
345       actionmailbox (= 6.0.3.4)
346       actionmailer (= 6.0.3.4)
347       actionpack (= 6.0.3.4)
348       actiontext (= 6.0.3.4)
349       actionview (= 6.0.3.4)
350       activejob (= 6.0.3.4)
351       activemodel (= 6.0.3.4)
352       activerecord (= 6.0.3.4)
353       activestorage (= 6.0.3.4)
354       activesupport (= 6.0.3.4)
355       bundler (>= 1.3.0)
356       railties (= 6.0.3.4)
357       sprockets-rails (>= 2.0.0)
358     rails-controller-testing (1.0.5)
359       actionpack (>= 5.0.1.rc1)
360       actionview (>= 5.0.1.rc1)
361       activesupport (>= 5.0.1.rc1)
362     rails-dom-testing (2.0.3)
363       activesupport (>= 4.2.0)
364       nokogiri (>= 1.6)
365     rails-html-sanitizer (1.3.0)
366       loofah (~> 2.3)
367     rails-i18n (6.0.0)
368       i18n (>= 0.7, < 2)
369       railties (>= 6.0.0, < 7)
370     railties (6.0.3.4)
371       actionpack (= 6.0.3.4)
372       activesupport (= 6.0.3.4)
373       method_source
374       rake (>= 0.8.7)
375       thor (>= 0.20.3, < 2.0)
376     rainbow (3.0.0)
377     rake (13.0.1)
378     rb-fsevent (0.10.4)
379     rb-inotify (0.10.1)
380       ffi (~> 1.0)
381     regexp_parser (1.8.2)
382     request_store (1.5.0)
383       rack (>= 1.4)
384     rexml (3.2.4)
385     rinku (2.0.6)
386     rotp (6.2.0)
387     rubocop (0.93.1)
388       parallel (~> 1.10)
389       parser (>= 2.7.1.5)
390       rainbow (>= 2.2.2, < 4.0)
391       regexp_parser (>= 1.8)
392       rexml
393       rubocop-ast (>= 0.6.0)
394       ruby-progressbar (~> 1.7)
395       unicode-display_width (>= 1.4.0, < 2.0)
396     rubocop-ast (1.3.0)
397       parser (>= 2.7.1.5)
398     rubocop-minitest (0.10.1)
399       rubocop (>= 0.87)
400     rubocop-performance (1.9.1)
401       rubocop (>= 0.90.0, < 2.0)
402       rubocop-ast (>= 0.4.0)
403     rubocop-rails (2.8.1)
404       activesupport (>= 4.2.0)
405       rack (>= 1.1)
406       rubocop (>= 0.87.0)
407     ruby-openid (2.9.2)
408     ruby-progressbar (1.10.1)
409     ruby2_keywords (0.0.2)
410     rubyzip (2.3.0)
411     sanitize (5.2.1)
412       crass (~> 1.0.2)
413       nokogiri (>= 1.8.0)
414       nokogumbo (~> 2.0)
415     sassc (2.4.0)
416       ffi (~> 1.9)
417     sassc-rails (2.1.2)
418       railties (>= 4.0.0)
419       sassc (>= 2.0)
420       sprockets (> 3.0)
421       sprockets-rails
422       tilt
423     secure_headers (6.3.1)
424     selenium-webdriver (3.142.7)
425       childprocess (>= 0.5, < 4.0)
426       rubyzip (>= 1.2.2)
427     simplecov (0.16.1)
428       docile (~> 1.1)
429       json (>= 1.8, < 3)
430       simplecov-html (~> 0.10.0)
431     simplecov-html (0.10.2)
432     simplecov-lcov (0.8.0)
433     smart_properties (1.15.0)
434     sprockets (4.0.2)
435       concurrent-ruby (~> 1.0)
436       rack (> 1, < 3)
437     sprockets-rails (3.2.2)
438       actionpack (>= 4.0)
439       activesupport (>= 4.0)
440       sprockets (>= 3.0.0)
441     strong_migrations (0.7.3)
442       activerecord (>= 5)
443     thor (1.0.1)
444     thread_safe (0.3.6)
445     tilt (2.0.10)
446     tzinfo (1.2.8)
447       thread_safe (~> 0.1)
448     uglifier (4.2.0)
449       execjs (>= 0.3.0, < 3)
450     unicode-display_width (1.7.0)
451     validates_email_format_of (1.6.3)
452       i18n
453     vendorer (0.2.0)
454     webmock (3.10.0)
455       addressable (>= 2.3.6)
456       crack (>= 0.3.2)
457       hashdiff (>= 0.4.0, < 2.0.0)
458     websocket-driver (0.7.3)
459       websocket-extensions (>= 0.1.0)
460     websocket-extensions (0.1.5)
461     xpath (3.2.0)
462       nokogiri (~> 1.8)
463     zeitwerk (2.4.2)
464
465 PLATFORMS
466   ruby
467
468 DEPENDENCIES
469   SystemTimer (>= 1.1.3)
470   aasm
471   actionpack-page_caching (>= 1.2.0)
472   active_record_union
473   activerecord-import
474   annotate
475   autoprefixer-rails
476   aws-sdk-s3
477   better_errors
478   bigdecimal (~> 1.1.0)
479   binding_of_caller
480   bootsnap (>= 1.4.2)
481   bootstrap (~> 4.5.0)
482   bootstrap_form (~> 4.0)
483   brakeman
484   browser
485   bzip2-ffi
486   cancancan
487   canonical-rails
488   capybara (>= 2.15)
489   composite_primary_keys (~> 12.0.0)
490   config
491   dalli
492   delayed_job_active_record
493   dynamic_form
494   erb_lint
495   factory_bot_rails
496   faraday
497   ffi-libarchive
498   gd2-ffij (>= 0.4.0)
499   htmlentities
500   http_accept_language (~> 2.1.1)
501   i18n-js (>= 3.0.0)
502   image_optim_rails
503   jbuilder (~> 2.7)
504   jquery-rails
505   json
506   kgio
507   kramdown
508   libxml-ruby (>= 2.0.5)
509   listen
510   logstasher
511   maxminddb
512   mimemagic
513   mini_magick
514   minitest (~> 5.1)
515   oauth-plugin (>= 0.5.1)
516   omniauth
517   omniauth-facebook
518   omniauth-github
519   omniauth-google-oauth2 (>= 0.6.0)
520   omniauth-mediawiki (>= 0.0.4)
521   omniauth-openid
522   omniauth-windowslive
523   openstreetmap-deadlock_retry (>= 1.3.0)
524   pg
525   psych
526   puma (~> 5.0)
527   quad_tile (~> 1.0.1)
528   r2 (~> 0.2.7)
529   rack-cors
530   rack-uri_sanitizer
531   rails (= 6.0.3.4)
532   rails-controller-testing
533   rails-i18n (~> 6.0.0)
534   rinku (>= 2.0.6)
535   rotp
536   rubocop (~> 0.93)
537   rubocop-minitest
538   rubocop-performance
539   rubocop-rails
540   sanitize
541   sassc-rails
542   secure_headers
543   selenium-webdriver
544   simplecov
545   simplecov-lcov
546   strong_migrations
547   uglifier (>= 1.3.0)
548   validates_email_format_of (>= 1.5.1)
549   vendorer
550   webmock
551
552 BUNDLED WITH
553    2.1.4