Improve model tests for issues
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.1.0)
6     actioncable (5.1.5)
7       actionpack (= 5.1.5)
8       nio4r (~> 2.0)
9       websocket-driver (~> 0.6.1)
10     actionmailer (5.1.5)
11       actionpack (= 5.1.5)
12       actionview (= 5.1.5)
13       activejob (= 5.1.5)
14       mail (~> 2.5, >= 2.5.4)
15       rails-dom-testing (~> 2.0)
16     actionpack (5.1.5)
17       actionview (= 5.1.5)
18       activesupport (= 5.1.5)
19       rack (~> 2.0)
20       rack-test (>= 0.6.3)
21       rails-dom-testing (~> 2.0)
22       rails-html-sanitizer (~> 1.0, >= 1.0.2)
23     actionpack-page_caching (1.1.0)
24       actionpack (>= 4.0.0, < 6)
25     actionview (5.1.5)
26       activesupport (= 5.1.5)
27       builder (~> 3.1)
28       erubi (~> 1.4)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.0.3)
31     activejob (5.1.5)
32       activesupport (= 5.1.5)
33       globalid (>= 0.3.6)
34     activemodel (5.1.5)
35       activesupport (= 5.1.5)
36     activerecord (5.1.5)
37       activemodel (= 5.1.5)
38       activesupport (= 5.1.5)
39       arel (~> 8.0)
40     activesupport (5.1.5)
41       concurrent-ruby (~> 1.0, >= 1.0.2)
42       i18n (~> 0.7)
43       minitest (~> 5.1)
44       tzinfo (~> 1.1)
45     addressable (2.5.2)
46       public_suffix (>= 2.0.2, < 4.0)
47     annotate (2.7.3)
48       activerecord (>= 3.2, < 6.0)
49       rake (>= 10.4, < 13.0)
50     arel (8.0.0)
51     ast (2.4.0)
52     autoprefixer-rails (8.5.1)
53       execjs
54     better_errors (2.4.0)
55       coderay (>= 1.0.0)
56       erubi (>= 1.0.0)
57       rack (>= 0.9.0)
58     bigdecimal (1.1.0)
59     binding_of_caller (0.8.0)
60       debug_inspector (>= 0.0.1)
61     builder (3.2.3)
62     canonical-rails (0.2.3)
63       rails (>= 4.1, < 5.3)
64     capybara (2.18.0)
65       addressable
66       mini_mime (>= 0.1.3)
67       nokogiri (>= 1.3.3)
68       rack (>= 1.0.0)
69       rack-test (>= 0.5.4)
70       xpath (>= 2.0, < 4.0)
71     climate_control (0.2.0)
72     cliver (0.3.2)
73     coderay (1.1.2)
74     coffee-rails (4.2.2)
75       coffee-script (>= 2.2.0)
76       railties (>= 4.0.0)
77     coffee-script (2.4.1)
78       coffee-script-source
79       execjs
80     coffee-script-source (1.12.2)
81     composite_primary_keys (10.0.3)
82       activerecord (~> 5.1.0, >= 5.1.5)
83     concurrent-ruby (1.0.5)
84     coveralls (0.8.21)
85       json (>= 1.8, < 3)
86       simplecov (~> 0.14.1)
87       term-ansicolor (~> 1.3)
88       thor (~> 0.19.4)
89       tins (~> 1.6)
90     crack (0.4.3)
91       safe_yaml (~> 1.0.0)
92     crass (1.0.4)
93     dalli (2.7.8)
94     debug_inspector (0.0.3)
95     docile (1.1.5)
96     dynamic_form (1.1.4)
97     erubi (1.7.1)
98     execjs (2.7.0)
99     exifr (1.3.4)
100     factory_bot (4.10.0)
101       activesupport (>= 3.0.0)
102     factory_bot_rails (4.10.0)
103       factory_bot (~> 4.10.0)
104       railties (>= 3.0.0)
105     faraday (0.12.2)
106       multipart-post (>= 1.2, < 3)
107     ffi (1.9.23)
108     fspath (3.1.0)
109     geoip (1.6.4)
110     globalid (0.4.1)
111       activesupport (>= 4.2.0)
112     hashdiff (0.3.7)
113     hashie (3.5.7)
114     htmlentities (4.3.4)
115     http_accept_language (2.0.5)
116     i18n (0.9.5)
117       concurrent-ruby (~> 1.0)
118     i18n-js (3.0.5)
119       i18n (>= 0.6.6, < 2)
120     image_optim (0.26.1)
121       exifr (~> 1.2, >= 1.2.2)
122       fspath (~> 3.0)
123       image_size (~> 1.5)
124       in_threads (~> 1.3)
125       progress (~> 3.0, >= 3.0.1)
126     image_optim_rails (0.4.1)
127       image_optim (~> 0.24)
128       rails
129       sprockets
130     image_size (1.5.0)
131     in_threads (1.5.0)
132     jquery-rails (4.3.3)
133       rails-dom-testing (>= 1, < 3)
134       railties (>= 4.2.0)
135       thor (>= 0.14, < 2.0)
136     jshint (1.5.0)
137       execjs (>= 1.4.0)
138       multi_json (~> 1.0)
139       therubyracer (~> 0.12.1)
140     json (2.1.0)
141     jsonify (0.3.1)
142       multi_json (~> 1.0)
143     jsonify-rails (0.3.2)
144       actionpack
145       jsonify (< 0.4.0)
146     jwt (1.5.6)
147     kgio (2.11.2)
148     libv8 (3.16.14.19)
149     libxml-ruby (3.1.0)
150     listen (3.1.5)
151       rb-fsevent (~> 0.9, >= 0.9.4)
152       rb-inotify (~> 0.9, >= 0.9.7)
153       ruby_dep (~> 1.2)
154     logstash-event (1.2.02)
155     logstasher (1.2.2)
156       activesupport (>= 4.0)
157       logstash-event (~> 1.2.0)
158       request_store
159     loofah (2.2.2)
160       crass (~> 1.0.2)
161       nokogiri (>= 1.5.9)
162     mail (2.7.0)
163       mini_mime (>= 0.1.1)
164     method_source (0.9.0)
165     mime-types (3.1)
166       mime-types-data (~> 3.2015)
167     mime-types-data (3.2016.0521)
168     mimemagic (0.3.2)
169     mini_mime (1.0.0)
170     mini_portile2 (2.3.0)
171     minitest (5.11.3)
172     multi_json (1.13.1)
173     multi_xml (0.6.0)
174     multipart-post (2.0.0)
175     nio4r (2.3.1)
176     nokogiri (1.8.2)
177       mini_portile2 (~> 2.3.0)
178     nokogumbo (1.5.0)
179       nokogiri
180     oauth (0.4.7)
181     oauth-plugin (0.5.1)
182       multi_json
183       oauth (~> 0.4.4)
184       oauth2 (>= 0.5.0)
185       rack
186     oauth2 (1.4.0)
187       faraday (>= 0.8, < 0.13)
188       jwt (~> 1.0)
189       multi_json (~> 1.3)
190       multi_xml (~> 0.5)
191       rack (>= 1.2, < 3)
192     omniauth (1.8.1)
193       hashie (>= 3.4.6, < 3.6.0)
194       rack (>= 1.6.2, < 3)
195     omniauth-facebook (5.0.0)
196       omniauth-oauth2 (~> 1.2)
197     omniauth-github (1.3.0)
198       omniauth (~> 1.5)
199       omniauth-oauth2 (>= 1.4.0, < 2.0)
200     omniauth-google-oauth2 (0.5.3)
201       jwt (>= 1.5)
202       omniauth (>= 1.1.1)
203       omniauth-oauth2 (>= 1.5)
204     omniauth-mediawiki (0.0.3)
205       jwt (~> 1.0)
206       omniauth-oauth (~> 1.0)
207     omniauth-oauth (1.1.0)
208       oauth
209       omniauth (~> 1.0)
210     omniauth-oauth2 (1.5.0)
211       oauth2 (~> 1.1)
212       omniauth (~> 1.2)
213     omniauth-openid (1.0.1)
214       omniauth (~> 1.0)
215       rack-openid (~> 1.3.1)
216     omniauth-windowslive (0.0.12)
217       multi_json (~> 1.12)
218       omniauth-oauth2 (~> 1.4)
219     openstreetmap-deadlock_retry (1.3.0)
220     paperclip (5.3.0)
221       activemodel (>= 4.2.0)
222       activesupport (>= 4.2.0)
223       mime-types
224       mimemagic (~> 0.3.0)
225       terrapin (~> 0.6.0)
226     parallel (1.12.1)
227     parser (2.5.1.0)
228       ast (~> 2.4.0)
229     pg (0.21.0)
230     poltergeist (1.18.1)
231       capybara (>= 2.1, < 4)
232       cliver (~> 0.3.1)
233       websocket-driver (>= 0.2.0)
234     powerpack (0.1.1)
235     progress (3.4.0)
236     psych (3.0.2)
237     public_suffix (3.0.2)
238     puma (3.11.4)
239     r2 (0.2.7)
240     rack (2.0.5)
241     rack-cors (1.0.2)
242     rack-openid (1.3.1)
243       rack (>= 1.1.0)
244       ruby-openid (>= 2.1.8)
245     rack-test (1.0.0)
246       rack (>= 1.0, < 3)
247     rack-uri_sanitizer (0.0.2)
248     rails (5.1.5)
249       actioncable (= 5.1.5)
250       actionmailer (= 5.1.5)
251       actionpack (= 5.1.5)
252       actionview (= 5.1.5)
253       activejob (= 5.1.5)
254       activemodel (= 5.1.5)
255       activerecord (= 5.1.5)
256       activesupport (= 5.1.5)
257       bundler (>= 1.3.0)
258       railties (= 5.1.5)
259       sprockets-rails (>= 2.0.0)
260     rails-controller-testing (1.0.2)
261       actionpack (~> 5.x, >= 5.0.1)
262       actionview (~> 5.x, >= 5.0.1)
263       activesupport (~> 5.x)
264     rails-dom-testing (2.0.3)
265       activesupport (>= 4.2.0)
266       nokogiri (>= 1.6)
267     rails-html-sanitizer (1.0.4)
268       loofah (~> 2.2, >= 2.2.2)
269     rails-i18n (4.0.2)
270       i18n (~> 0.6)
271       rails (>= 4.0)
272     railties (5.1.5)
273       actionpack (= 5.1.5)
274       activesupport (= 5.1.5)
275       method_source
276       rake (>= 0.8.7)
277       thor (>= 0.18.1, < 2.0)
278     rainbow (3.0.0)
279     rake (12.3.1)
280     rb-fsevent (0.10.3)
281     rb-inotify (0.9.10)
282       ffi (>= 0.5.0, < 2)
283     record_tag_helper (1.0.0)
284       actionview (~> 5.x)
285     redcarpet (3.4.0)
286     ref (2.0.0)
287     request_store (1.4.1)
288       rack (>= 1.4)
289     rinku (2.0.4)
290     rotp (3.3.1)
291     rubocop (0.56.0)
292       parallel (~> 1.10)
293       parser (>= 2.5)
294       powerpack (~> 0.1)
295       rainbow (>= 2.2.2, < 4.0)
296       ruby-progressbar (~> 1.7)
297       unicode-display_width (~> 1.0, >= 1.0.1)
298     ruby-openid (2.7.0)
299     ruby-progressbar (1.9.0)
300     ruby_dep (1.5.0)
301     safe_yaml (1.0.4)
302     sanitize (4.6.5)
303       crass (~> 1.0.2)
304       nokogiri (>= 1.4.4)
305       nokogumbo (~> 1.4)
306     sass (3.5.6)
307       sass-listen (~> 4.0.0)
308     sass-listen (4.0.0)
309       rb-fsevent (~> 0.9, >= 0.9.4)
310       rb-inotify (~> 0.9, >= 0.9.7)
311     sass-rails (5.0.7)
312       railties (>= 4.0.0, < 6)
313       sass (~> 3.1)
314       sprockets (>= 2.8, < 4.0)
315       sprockets-rails (>= 2.0, < 4.0)
316       tilt (>= 1.1, < 3)
317     secure_headers (6.0.0)
318     simplecov (0.14.1)
319       docile (~> 1.1.0)
320       json (>= 1.8, < 3)
321       simplecov-html (~> 0.10.0)
322     simplecov-html (0.10.2)
323     sprockets (3.7.1)
324       concurrent-ruby (~> 1.0)
325       rack (> 1, < 3)
326     sprockets-rails (3.2.1)
327       actionpack (>= 4.0)
328       activesupport (>= 4.0)
329       sprockets (>= 3.0.0)
330     term-ansicolor (1.6.0)
331       tins (~> 1.0)
332     terrapin (0.6.0)
333       climate_control (>= 0.0.3, < 1.0)
334     therubyracer (0.12.3)
335       libv8 (~> 3.16.14.15)
336       ref
337     thor (0.19.4)
338     thread_safe (0.3.6)
339     tilt (2.0.8)
340     tins (1.16.3)
341     tzinfo (1.2.5)
342       thread_safe (~> 0.1)
343     uglifier (4.1.10)
344       execjs (>= 0.3.0, < 3)
345     unicode-display_width (1.3.2)
346     validates_email_format_of (1.6.3)
347       i18n
348     vendorer (0.1.16)
349     webmock (3.4.1)
350       addressable (>= 2.3.6)
351       crack (>= 0.3.2)
352       hashdiff
353     websocket-driver (0.6.5)
354       websocket-extensions (>= 0.1.0)
355     websocket-extensions (0.1.3)
356     xpath (3.1.0)
357       nokogiri (~> 1.8)
358
359 PLATFORMS
360   ruby
361
362 DEPENDENCIES
363   SystemTimer (>= 1.1.3)
364   aasm
365   actionpack-page_caching
366   annotate
367   autoprefixer-rails
368   better_errors
369   bigdecimal (~> 1.1.0)
370   binding_of_caller
371   canonical-rails
372   capybara (~> 2.13)
373   coffee-rails (~> 4.2)
374   composite_primary_keys (~> 10.0.0)
375   coveralls
376   dalli
377   dynamic_form
378   factory_bot_rails
379   faraday
380   geoip
381   htmlentities
382   http_accept_language (~> 2.0.0)
383   i18n-js (>= 3.0.0)
384   image_optim_rails
385   jquery-rails
386   jshint
387   json
388   jsonify-rails
389   kgio
390   libxml-ruby (>= 2.0.5)
391   listen
392   logstasher
393   minitest (~> 5.1)
394   oauth-plugin (>= 0.5.1)
395   omniauth
396   omniauth-facebook
397   omniauth-github
398   omniauth-google-oauth2 (>= 0.2.7)
399   omniauth-mediawiki (>= 0.0.3)
400   omniauth-openid
401   omniauth-windowslive
402   openstreetmap-deadlock_retry (>= 1.3.0)
403   paperclip (~> 5.2)
404   pg (~> 0.18)
405   poltergeist
406   psych
407   puma (~> 3.7)
408   r2 (~> 0.2.7)
409   rack-cors
410   rack-uri_sanitizer
411   rails (= 5.1.5)
412   rails-controller-testing
413   rails-i18n (~> 4.0.0)
414   record_tag_helper
415   redcarpet
416   rinku (>= 1.2.2)
417   rotp
418   rubocop
419   sanitize
420   sass-rails (~> 5.0)
421   secure_headers
422   uglifier (>= 1.3.0)
423   validates_email_format_of (>= 1.5.1)
424   vendorer
425   webmock
426
427 BUNDLED WITH
428    1.16.2