It's to_sym not to_symbol
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.5)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.3)
8       actionpack (= 5.2.3)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.3)
12       actionpack (= 5.2.3)
13       actionview (= 5.2.3)
14       activejob (= 5.2.3)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.3)
18       actionview (= 5.2.3)
19       activesupport (= 5.2.3)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.3)
27       activesupport (= 5.2.3)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.3)
35       activesupport (= 5.2.3)
36       globalid (>= 0.3.6)
37     activemodel (5.2.3)
38       activesupport (= 5.2.3)
39     activerecord (5.2.3)
40       activemodel (= 5.2.3)
41       activesupport (= 5.2.3)
42       arel (>= 9.0)
43     activerecord-import (1.0.2)
44       activerecord (>= 3.2)
45     activestorage (5.2.3)
46       actionpack (= 5.2.3)
47       activerecord (= 5.2.3)
48       marcel (~> 0.3.1)
49     activesupport (5.2.3)
50       concurrent-ruby (~> 1.0, >= 1.0.2)
51       i18n (>= 0.7, < 2)
52       minitest (~> 5.1)
53       tzinfo (~> 1.1)
54     addressable (2.6.0)
55       public_suffix (>= 2.0.2, < 4.0)
56     annotate (2.7.5)
57       activerecord (>= 3.2, < 7.0)
58       rake (>= 10.4, < 13.0)
59     arel (9.0.0)
60     ast (2.4.0)
61     autoprefixer-rails (8.6.5)
62       execjs
63     aws-eventstream (1.0.3)
64     aws-partitions (1.184.0)
65     aws-sdk-core (3.59.0)
66       aws-eventstream (~> 1.0, >= 1.0.2)
67       aws-partitions (~> 1.0)
68       aws-sigv4 (~> 1.1)
69       jmespath (~> 1.0)
70     aws-sdk-kms (1.23.0)
71       aws-sdk-core (~> 3, >= 3.58.0)
72       aws-sigv4 (~> 1.1)
73     aws-sdk-s3 (1.45.0)
74       aws-sdk-core (~> 3, >= 3.58.0)
75       aws-sdk-kms (~> 1)
76       aws-sigv4 (~> 1.1)
77     aws-sigv4 (1.1.0)
78       aws-eventstream (~> 1.0, >= 1.0.2)
79     better_errors (2.5.1)
80       coderay (>= 1.0.0)
81       erubi (>= 1.0.0)
82       rack (>= 0.9.0)
83     better_html (1.0.14)
84       actionview (>= 4.0)
85       activesupport (>= 4.0)
86       ast (~> 2.0)
87       erubi (~> 1.4)
88       html_tokenizer (~> 0.0.6)
89       parser (>= 2.4)
90       smart_properties
91     bigdecimal (1.1.0)
92     binding_of_caller (0.8.0)
93       debug_inspector (>= 0.0.1)
94     bootsnap (1.4.4)
95       msgpack (~> 1.0)
96     browser (2.5.3)
97     builder (3.2.3)
98     bzip2-ffi (1.0.0)
99       ffi (~> 1.0)
100     cancancan (3.0.1)
101     canonical-rails (0.2.6)
102       rails (>= 4.1, < 6.1)
103     capybara (2.18.0)
104       addressable
105       mini_mime (>= 0.1.3)
106       nokogiri (>= 1.3.3)
107       rack (>= 1.0.0)
108       rack-test (>= 0.5.4)
109       xpath (>= 2.0, < 4.0)
110     climate_control (0.2.0)
111     cliver (0.3.2)
112     coderay (1.1.2)
113     coffee-rails (4.2.2)
114       coffee-script (>= 2.2.0)
115       railties (>= 4.0.0)
116     coffee-script (2.4.1)
117       coffee-script-source
118       execjs
119     coffee-script-source (1.12.2)
120     composite_primary_keys (11.1.0)
121       activerecord (~> 5.2.1)
122     concurrent-ruby (1.1.5)
123     config (2.0.0)
124       activesupport (>= 4.2)
125       deep_merge (~> 1.2, >= 1.2.1)
126       dry-schema (~> 1.0)
127     coveralls (0.8.23)
128       json (>= 1.8, < 3)
129       simplecov (~> 0.16.1)
130       term-ansicolor (~> 1.3)
131       thor (>= 0.19.4, < 2.0)
132       tins (~> 1.6)
133     crack (0.4.3)
134       safe_yaml (~> 1.0.0)
135     crass (1.0.4)
136     dalli (2.7.10)
137     debug_inspector (0.0.3)
138     deep_merge (1.2.1)
139     delayed_job (4.1.7)
140       activesupport (>= 3.0, < 5.3)
141     delayed_job_active_record (4.1.3)
142       activerecord (>= 3.0, < 5.3)
143       delayed_job (>= 3.0, < 5)
144     docile (1.3.2)
145     dry-configurable (0.8.3)
146       concurrent-ruby (~> 1.0)
147       dry-core (~> 0.4, >= 0.4.7)
148     dry-container (0.7.1)
149       concurrent-ruby (~> 1.0)
150       dry-configurable (~> 0.1, >= 0.1.3)
151     dry-core (0.4.8)
152       concurrent-ruby (~> 1.0)
153     dry-equalizer (0.2.2)
154     dry-inflector (0.1.2)
155     dry-initializer (3.0.1)
156     dry-logic (1.0.2)
157       concurrent-ruby (~> 1.0)
158       dry-core (~> 0.2)
159       dry-equalizer (~> 0.2)
160     dry-schema (1.3.0)
161       concurrent-ruby (~> 1.0)
162       dry-configurable (~> 0.8, >= 0.8.3)
163       dry-core (~> 0.4)
164       dry-equalizer (~> 0.2)
165       dry-initializer (~> 3.0)
166       dry-logic (~> 1.0)
167       dry-types (~> 1.0)
168     dry-types (1.1.0)
169       concurrent-ruby (~> 1.0)
170       dry-container (~> 0.3)
171       dry-core (~> 0.4, >= 0.4.4)
172       dry-equalizer (~> 0.2, >= 0.2.2)
173       dry-inflector (~> 0.1, >= 0.1.2)
174       dry-logic (~> 1.0, >= 1.0.2)
175     dynamic_form (1.1.4)
176     erb_lint (0.0.29)
177       activesupport
178       better_html (~> 1.0.7)
179       html_tokenizer
180       rainbow
181       rubocop (~> 0.51)
182       smart_properties
183     erubi (1.8.0)
184     execjs (2.7.0)
185     exifr (1.3.6)
186     factory_bot (5.0.2)
187       activesupport (>= 4.2.0)
188     factory_bot_rails (5.0.2)
189       factory_bot (~> 5.0.2)
190       railties (>= 4.2.0)
191     fakefs (0.20.1)
192     faraday (0.15.4)
193       multipart-post (>= 1.2, < 3)
194     ffi (1.11.1)
195     ffi-libarchive (0.4.10)
196       ffi (~> 1.0)
197     fspath (3.1.1)
198     gd2-ffij (0.4.0)
199       ffi (>= 1.0.0)
200     geoip (1.6.4)
201     globalid (0.4.2)
202       activesupport (>= 4.2.0)
203     hashdiff (0.4.0)
204     hashie (3.6.0)
205     html_tokenizer (0.0.7)
206     htmlentities (4.3.4)
207     http_accept_language (2.0.5)
208     i18n (0.9.5)
209       concurrent-ruby (~> 1.0)
210     i18n-js (3.3.0)
211       i18n (>= 0.6.6)
212     image_optim (0.26.4)
213       exifr (~> 1.2, >= 1.2.2)
214       fspath (~> 3.0)
215       image_size (>= 1.5, < 3)
216       in_threads (~> 1.3)
217       progress (~> 3.0, >= 3.0.1)
218     image_optim_rails (0.4.2)
219       image_optim (~> 0.24)
220       rails
221       sprockets
222     image_size (2.0.1)
223     in_threads (1.5.2)
224     jaro_winkler (1.5.3)
225     jmespath (1.4.0)
226     jquery-rails (4.3.5)
227       rails-dom-testing (>= 1, < 3)
228       railties (>= 4.2.0)
229       thor (>= 0.14, < 2.0)
230     json (2.2.0)
231     jsonify (0.3.1)
232       multi_json (~> 1.0)
233     jsonify-rails (0.3.2)
234       actionpack
235       jsonify (< 0.4.0)
236     jwt (2.2.1)
237     kgio (2.11.2)
238     kramdown (2.1.0)
239     libxml-ruby (3.1.0)
240     listen (3.1.5)
241       rb-fsevent (~> 0.9, >= 0.9.4)
242       rb-inotify (~> 0.9, >= 0.9.7)
243       ruby_dep (~> 1.2)
244     logstash-event (1.2.02)
245     logstasher (1.3.0)
246       activesupport (>= 4.0)
247       logstash-event (~> 1.2.0)
248       request_store
249     loofah (2.2.3)
250       crass (~> 1.0.2)
251       nokogiri (>= 1.5.9)
252     mail (2.7.1)
253       mini_mime (>= 0.1.1)
254     marcel (0.3.3)
255       mimemagic (~> 0.3.2)
256     method_source (0.9.2)
257     mime-types (3.2.2)
258       mime-types-data (~> 3.2015)
259     mime-types-data (3.2019.0331)
260     mimemagic (0.3.3)
261     mini_magick (4.9.3)
262     mini_mime (1.0.1)
263     mini_portile2 (2.4.0)
264     minitest (5.11.3)
265     msgpack (1.3.0)
266     multi_json (1.13.1)
267     multi_xml (0.6.0)
268     multipart-post (2.1.1)
269     nio4r (2.4.0)
270     nokogiri (1.10.3)
271       mini_portile2 (~> 2.4.0)
272     nokogumbo (2.0.1)
273       nokogiri (~> 1.8, >= 1.8.4)
274     oauth (0.4.7)
275     oauth-plugin (0.5.1)
276       multi_json
277       oauth (~> 0.4.4)
278       oauth2 (>= 0.5.0)
279       rack
280     oauth2 (1.4.1)
281       faraday (>= 0.8, < 0.16.0)
282       jwt (>= 1.0, < 3.0)
283       multi_json (~> 1.3)
284       multi_xml (~> 0.5)
285       rack (>= 1.2, < 3)
286     omniauth (1.9.0)
287       hashie (>= 3.4.6, < 3.7.0)
288       rack (>= 1.6.2, < 3)
289     omniauth-facebook (5.0.0)
290       omniauth-oauth2 (~> 1.2)
291     omniauth-github (1.3.0)
292       omniauth (~> 1.5)
293       omniauth-oauth2 (>= 1.4.0, < 2.0)
294     omniauth-google-oauth2 (0.7.0)
295       jwt (>= 2.0)
296       omniauth (>= 1.1.1)
297       omniauth-oauth2 (>= 1.5)
298     omniauth-mediawiki (0.0.4)
299       jwt (~> 2.0)
300       omniauth-oauth (~> 1.0)
301     omniauth-oauth (1.1.0)
302       oauth
303       omniauth (~> 1.0)
304     omniauth-oauth2 (1.6.0)
305       oauth2 (~> 1.1)
306       omniauth (~> 1.9)
307     omniauth-openid (1.0.1)
308       omniauth (~> 1.0)
309       rack-openid (~> 1.3.1)
310     omniauth-windowslive (0.0.12)
311       multi_json (~> 1.12)
312       omniauth-oauth2 (~> 1.4)
313     openstreetmap-deadlock_retry (1.3.0)
314     paperclip (5.3.0)
315       activemodel (>= 4.2.0)
316       activesupport (>= 4.2.0)
317       mime-types
318       mimemagic (~> 0.3.0)
319       terrapin (~> 0.6.0)
320     parallel (1.17.0)
321     parser (2.6.3.0)
322       ast (~> 2.4.0)
323     pg (1.1.4)
324     poltergeist (1.18.1)
325       capybara (>= 2.1, < 4)
326       cliver (~> 0.3.1)
327       websocket-driver (>= 0.2.0)
328     progress (3.5.1)
329     psych (3.1.0)
330     public_suffix (3.1.1)
331     puma (3.12.1)
332     quad_tile (1.0.1)
333     r2 (0.2.7)
334     rack (2.0.7)
335     rack-cors (1.0.3)
336     rack-openid (1.3.1)
337       rack (>= 1.1.0)
338       ruby-openid (>= 2.1.8)
339     rack-test (1.1.0)
340       rack (>= 1.0, < 3)
341     rack-uri_sanitizer (0.0.2)
342     rails (5.2.3)
343       actioncable (= 5.2.3)
344       actionmailer (= 5.2.3)
345       actionpack (= 5.2.3)
346       actionview (= 5.2.3)
347       activejob (= 5.2.3)
348       activemodel (= 5.2.3)
349       activerecord (= 5.2.3)
350       activestorage (= 5.2.3)
351       activesupport (= 5.2.3)
352       bundler (>= 1.3.0)
353       railties (= 5.2.3)
354       sprockets-rails (>= 2.0.0)
355     rails-controller-testing (1.0.4)
356       actionpack (>= 5.0.1.x)
357       actionview (>= 5.0.1.x)
358       activesupport (>= 5.0.1.x)
359     rails-dom-testing (2.0.3)
360       activesupport (>= 4.2.0)
361       nokogiri (>= 1.6)
362     rails-html-sanitizer (1.0.4)
363       loofah (~> 2.2, >= 2.2.2)
364     rails-i18n (4.0.2)
365       i18n (~> 0.6)
366       rails (>= 4.0)
367     railties (5.2.3)
368       actionpack (= 5.2.3)
369       activesupport (= 5.2.3)
370       method_source
371       rake (>= 0.8.7)
372       thor (>= 0.19.0, < 2.0)
373     rainbow (3.0.0)
374     rake (12.3.2)
375     rb-fsevent (0.10.3)
376     rb-inotify (0.10.0)
377       ffi (~> 1.0)
378     record_tag_helper (1.0.0)
379       actionview (~> 5.x)
380     request_store (1.4.1)
381       rack (>= 1.4)
382     rinku (2.0.6)
383     rotp (5.1.0)
384       addressable (~> 2.5)
385     rubocop (0.72.0)
386       jaro_winkler (~> 1.5.1)
387       parallel (~> 1.10)
388       parser (>= 2.6)
389       rainbow (>= 2.2.2, < 4.0)
390       ruby-progressbar (~> 1.7)
391       unicode-display_width (>= 1.4.0, < 1.7)
392     rubocop-performance (1.4.0)
393       rubocop (>= 0.71.0)
394     rubocop-rails (2.2.0)
395       rack (>= 1.1)
396       rubocop (>= 0.72.0)
397     ruby-openid (2.7.0)
398     ruby-progressbar (1.10.1)
399     ruby_dep (1.5.0)
400     safe_yaml (1.0.5)
401     sanitize (5.0.0)
402       crass (~> 1.0.2)
403       nokogiri (>= 1.8.0)
404       nokogumbo (~> 2.0)
405     sassc (2.0.1)
406       ffi (~> 1.9)
407       rake
408     sassc-rails (2.1.2)
409       railties (>= 4.0.0)
410       sassc (>= 2.0)
411       sprockets (> 3.0)
412       sprockets-rails
413       tilt
414     secure_headers (6.1.1)
415     simplecov (0.16.1)
416       docile (~> 1.1)
417       json (>= 1.8, < 3)
418       simplecov-html (~> 0.10.0)
419     simplecov-html (0.10.2)
420     smart_properties (1.15.0)
421     sprockets (3.7.2)
422       concurrent-ruby (~> 1.0)
423       rack (> 1, < 3)
424     sprockets-rails (3.2.1)
425       actionpack (>= 4.0)
426       activesupport (>= 4.0)
427       sprockets (>= 3.0.0)
428     strong_migrations (0.4.0)
429       activerecord (>= 5)
430     term-ansicolor (1.7.1)
431       tins (~> 1.0)
432     terrapin (0.6.0)
433       climate_control (>= 0.0.3, < 1.0)
434     thor (0.20.3)
435     thread_safe (0.3.6)
436     tilt (2.0.9)
437     tins (1.21.0)
438     tzinfo (1.2.5)
439       thread_safe (~> 0.1)
440     uglifier (4.1.20)
441       execjs (>= 0.3.0, < 3)
442     unicode-display_width (1.6.0)
443     validates_email_format_of (1.6.3)
444       i18n
445     vendorer (0.2.0)
446     webmock (3.6.0)
447       addressable (>= 2.3.6)
448       crack (>= 0.3.2)
449       hashdiff (>= 0.4.0, < 2.0.0)
450     websocket-driver (0.7.1)
451       websocket-extensions (>= 0.1.0)
452     websocket-extensions (0.1.4)
453     xpath (3.2.0)
454       nokogiri (~> 1.8)
455
456 PLATFORMS
457   ruby
458
459 DEPENDENCIES
460   SystemTimer (>= 1.1.3)
461   aasm
462   actionpack-page_caching
463   active_record_union
464   activerecord-import
465   annotate
466   autoprefixer-rails (~> 8.6.3)
467   aws-sdk-s3
468   better_errors
469   bigdecimal (~> 1.1.0)
470   binding_of_caller
471   bootsnap (>= 1.1.0)
472   browser
473   bzip2-ffi
474   cancancan
475   canonical-rails
476   capybara (~> 2.13)
477   coffee-rails (~> 4.2)
478   composite_primary_keys (~> 11.1.0)
479   config
480   coveralls
481   dalli
482   delayed_job_active_record
483   dynamic_form
484   erb_lint
485   factory_bot_rails
486   fakefs
487   faraday
488   ffi-libarchive
489   gd2-ffij (>= 0.4.0)
490   geoip
491   htmlentities
492   http_accept_language (~> 2.0.0)
493   i18n-js (>= 3.0.0)
494   image_optim_rails
495   jquery-rails
496   json
497   jsonify-rails
498   kgio
499   kramdown
500   libxml-ruby (>= 2.0.5)
501   listen
502   logstasher
503   mimemagic
504   mini_magick
505   minitest (~> 5.1)
506   oauth-plugin (>= 0.5.1)
507   omniauth
508   omniauth-facebook
509   omniauth-github
510   omniauth-google-oauth2 (>= 0.6.0)
511   omniauth-mediawiki (>= 0.0.4)
512   omniauth-openid
513   omniauth-windowslive
514   openstreetmap-deadlock_retry (>= 1.3.0)
515   paperclip (~> 5.2)
516   pg
517   poltergeist
518   psych
519   puma (~> 3.7)
520   quad_tile (~> 1.0.1)
521   r2 (~> 0.2.7)
522   rack-cors
523   rack-uri_sanitizer
524   rails (= 5.2.3)
525   rails-controller-testing
526   rails-i18n (~> 4.0.0)
527   record_tag_helper
528   rinku (>= 2.0.6)
529   rotp
530   rubocop
531   rubocop-performance
532   rubocop-rails
533   sanitize
534   sassc-rails
535   secure_headers
536   strong_migrations
537   uglifier (>= 1.3.0)
538   validates_email_format_of (>= 1.5.1)
539   vendorer
540   webmock
541
542 BUNDLED WITH
543    1.17.2