Update bundle
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.5)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.3)
8       actionpack (= 5.2.3)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.3)
12       actionpack (= 5.2.3)
13       actionview (= 5.2.3)
14       activejob (= 5.2.3)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.3)
18       actionview (= 5.2.3)
19       activesupport (= 5.2.3)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.3)
27       activesupport (= 5.2.3)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.3)
35       activesupport (= 5.2.3)
36       globalid (>= 0.3.6)
37     activemodel (5.2.3)
38       activesupport (= 5.2.3)
39     activerecord (5.2.3)
40       activemodel (= 5.2.3)
41       activesupport (= 5.2.3)
42       arel (>= 9.0)
43     activerecord-import (1.0.1)
44       activerecord (>= 3.2)
45     activestorage (5.2.3)
46       actionpack (= 5.2.3)
47       activerecord (= 5.2.3)
48       marcel (~> 0.3.1)
49     activesupport (5.2.3)
50       concurrent-ruby (~> 1.0, >= 1.0.2)
51       i18n (>= 0.7, < 2)
52       minitest (~> 5.1)
53       tzinfo (~> 1.1)
54     addressable (2.6.0)
55       public_suffix (>= 2.0.2, < 4.0)
56     annotate (2.7.5)
57       activerecord (>= 3.2, < 7.0)
58       rake (>= 10.4, < 13.0)
59     arel (9.0.0)
60     ast (2.4.0)
61     autoprefixer-rails (8.6.5)
62       execjs
63     better_errors (2.5.1)
64       coderay (>= 1.0.0)
65       erubi (>= 1.0.0)
66       rack (>= 0.9.0)
67     better_html (1.0.13)
68       actionview (>= 4.0)
69       activesupport (>= 4.0)
70       ast (~> 2.0)
71       erubi (~> 1.4)
72       html_tokenizer (~> 0.0.6)
73       parser (>= 2.4)
74       smart_properties
75     bigdecimal (1.1.0)
76     binding_of_caller (0.8.0)
77       debug_inspector (>= 0.0.1)
78     bootsnap (1.4.4)
79       msgpack (~> 1.0)
80     browser (2.5.3)
81     builder (3.2.3)
82     cancancan (3.0.1)
83     canonical-rails (0.2.5)
84       rails (>= 4.1, < 6.1)
85     capybara (2.18.0)
86       addressable
87       mini_mime (>= 0.1.3)
88       nokogiri (>= 1.3.3)
89       rack (>= 1.0.0)
90       rack-test (>= 0.5.4)
91       xpath (>= 2.0, < 4.0)
92     climate_control (0.2.0)
93     cliver (0.3.2)
94     coderay (1.1.2)
95     coffee-rails (4.2.2)
96       coffee-script (>= 2.2.0)
97       railties (>= 4.0.0)
98     coffee-script (2.4.1)
99       coffee-script-source
100       execjs
101     coffee-script-source (1.12.2)
102     colorize (0.8.1)
103     composite_primary_keys (11.1.0)
104       activerecord (~> 5.2.1)
105     concurrent-ruby (1.1.5)
106     config (1.7.1)
107       activesupport (>= 3.0)
108       deep_merge (~> 1.2.1)
109       dry-validation (>= 0.12.2)
110     coveralls (0.8.23)
111       json (>= 1.8, < 3)
112       simplecov (~> 0.16.1)
113       term-ansicolor (~> 1.3)
114       thor (>= 0.19.4, < 2.0)
115       tins (~> 1.6)
116     crack (0.4.3)
117       safe_yaml (~> 1.0.0)
118     crass (1.0.4)
119     dalli (2.7.10)
120     debug_inspector (0.0.3)
121     deep_merge (1.2.1)
122     delayed_job (4.1.5)
123       activesupport (>= 3.0, < 5.3)
124     delayed_job_active_record (4.1.3)
125       activerecord (>= 3.0, < 5.3)
126       delayed_job (>= 3.0, < 5)
127     docile (1.3.1)
128     dry-configurable (0.8.3)
129       concurrent-ruby (~> 1.0)
130       dry-core (~> 0.4, >= 0.4.7)
131     dry-container (0.7.0)
132       concurrent-ruby (~> 1.0)
133       dry-configurable (~> 0.1, >= 0.1.3)
134     dry-core (0.4.7)
135       concurrent-ruby (~> 1.0)
136     dry-equalizer (0.2.2)
137     dry-inflector (0.1.2)
138     dry-logic (0.6.1)
139       concurrent-ruby (~> 1.0)
140       dry-core (~> 0.2)
141       dry-equalizer (~> 0.2)
142     dry-types (0.14.1)
143       concurrent-ruby (~> 1.0)
144       dry-container (~> 0.3)
145       dry-core (~> 0.4, >= 0.4.4)
146       dry-equalizer (~> 0.2)
147       dry-inflector (~> 0.1, >= 0.1.2)
148       dry-logic (~> 0.5, >= 0.5)
149     dry-validation (0.13.3)
150       concurrent-ruby (~> 1.0)
151       dry-configurable (~> 0.1, >= 0.1.3)
152       dry-core (~> 0.2, >= 0.2.1)
153       dry-equalizer (~> 0.2)
154       dry-logic (~> 0.5, >= 0.5.0)
155       dry-types (~> 0.14.0)
156     dynamic_form (1.1.4)
157     erb_lint (0.0.28)
158       activesupport
159       better_html (~> 1.0.7)
160       html_tokenizer
161       rainbow
162       rubocop (~> 0.51)
163       smart_properties
164     erubi (1.8.0)
165     eslint-rails-ee (1.0.2)
166       colorize
167       execjs
168       railties (>= 3.2)
169     execjs (2.7.0)
170     exifr (1.3.6)
171     factory_bot (5.0.2)
172       activesupport (>= 4.2.0)
173     factory_bot_rails (5.0.2)
174       factory_bot (~> 5.0.2)
175       railties (>= 4.2.0)
176     fakefs (0.20.1)
177     faraday (0.15.4)
178       multipart-post (>= 1.2, < 3)
179     ffi (1.11.1)
180     fspath (3.1.1)
181     gd2-ffij (0.3.0)
182       ffi (>= 1.0.0)
183     geoip (1.6.4)
184     globalid (0.4.2)
185       activesupport (>= 4.2.0)
186     hashdiff (0.4.0)
187     hashie (3.6.0)
188     html_tokenizer (0.0.7)
189     htmlentities (4.3.4)
190     http_accept_language (2.0.5)
191     i18n (0.9.5)
192       concurrent-ruby (~> 1.0)
193     i18n-js (3.2.3)
194       i18n (>= 0.6.6)
195     image_optim (0.26.4)
196       exifr (~> 1.2, >= 1.2.2)
197       fspath (~> 3.0)
198       image_size (>= 1.5, < 3)
199       in_threads (~> 1.3)
200       progress (~> 3.0, >= 3.0.1)
201     image_optim_rails (0.4.2)
202       image_optim (~> 0.24)
203       rails
204       sprockets
205     image_size (2.0.1)
206     in_threads (1.5.2)
207     jaro_winkler (1.5.2)
208     jquery-rails (4.3.3)
209       rails-dom-testing (>= 1, < 3)
210       railties (>= 4.2.0)
211       thor (>= 0.14, < 2.0)
212     json (2.2.0)
213     jsonify (0.3.1)
214       multi_json (~> 1.0)
215     jsonify-rails (0.3.2)
216       actionpack
217       jsonify (< 0.4.0)
218     jwt (2.2.1)
219     kgio (2.11.2)
220     kramdown (2.1.0)
221     libv8 (3.16.14.19)
222     libxml-ruby (3.1.0)
223     listen (3.1.5)
224       rb-fsevent (~> 0.9, >= 0.9.4)
225       rb-inotify (~> 0.9, >= 0.9.7)
226       ruby_dep (~> 1.2)
227     logstash-event (1.2.02)
228     logstasher (1.3.0)
229       activesupport (>= 4.0)
230       logstash-event (~> 1.2.0)
231       request_store
232     loofah (2.2.3)
233       crass (~> 1.0.2)
234       nokogiri (>= 1.5.9)
235     mail (2.7.1)
236       mini_mime (>= 0.1.1)
237     marcel (0.3.3)
238       mimemagic (~> 0.3.2)
239     method_source (0.9.2)
240     mime-types (3.2.2)
241       mime-types-data (~> 3.2015)
242     mime-types-data (3.2019.0331)
243     mimemagic (0.3.3)
244     mini_mime (1.0.1)
245     mini_portile2 (2.4.0)
246     minitest (5.11.3)
247     msgpack (1.2.10)
248     multi_json (1.13.1)
249     multi_xml (0.6.0)
250     multipart-post (2.1.1)
251     nio4r (2.3.1)
252     nokogiri (1.10.3)
253       mini_portile2 (~> 2.4.0)
254     nokogumbo (2.0.1)
255       nokogiri (~> 1.8, >= 1.8.4)
256     oauth (0.4.7)
257     oauth-plugin (0.5.1)
258       multi_json
259       oauth (~> 0.4.4)
260       oauth2 (>= 0.5.0)
261       rack
262     oauth2 (1.4.1)
263       faraday (>= 0.8, < 0.16.0)
264       jwt (>= 1.0, < 3.0)
265       multi_json (~> 1.3)
266       multi_xml (~> 0.5)
267       rack (>= 1.2, < 3)
268     omniauth (1.9.0)
269       hashie (>= 3.4.6, < 3.7.0)
270       rack (>= 1.6.2, < 3)
271     omniauth-facebook (5.0.0)
272       omniauth-oauth2 (~> 1.2)
273     omniauth-github (1.3.0)
274       omniauth (~> 1.5)
275       omniauth-oauth2 (>= 1.4.0, < 2.0)
276     omniauth-google-oauth2 (0.6.1)
277       jwt (>= 2.0)
278       omniauth (>= 1.1.1)
279       omniauth-oauth2 (>= 1.5)
280     omniauth-mediawiki (0.0.4)
281       jwt (~> 2.0)
282       omniauth-oauth (~> 1.0)
283     omniauth-oauth (1.1.0)
284       oauth
285       omniauth (~> 1.0)
286     omniauth-oauth2 (1.6.0)
287       oauth2 (~> 1.1)
288       omniauth (~> 1.9)
289     omniauth-openid (1.0.1)
290       omniauth (~> 1.0)
291       rack-openid (~> 1.3.1)
292     omniauth-windowslive (0.0.12)
293       multi_json (~> 1.12)
294       omniauth-oauth2 (~> 1.4)
295     openstreetmap-deadlock_retry (1.3.0)
296     paperclip (5.3.0)
297       activemodel (>= 4.2.0)
298       activesupport (>= 4.2.0)
299       mime-types
300       mimemagic (~> 0.3.0)
301       terrapin (~> 0.6.0)
302     parallel (1.17.0)
303     parser (2.6.3.0)
304       ast (~> 2.4.0)
305     pg (1.1.4)
306     poltergeist (1.18.1)
307       capybara (>= 2.1, < 4)
308       cliver (~> 0.3.1)
309       websocket-driver (>= 0.2.0)
310     progress (3.5.1)
311     psych (3.1.0)
312     public_suffix (3.1.0)
313     puma (3.12.1)
314     quad_tile (1.0.1)
315     r2 (0.2.7)
316     rack (2.0.7)
317     rack-cors (1.0.3)
318     rack-openid (1.3.1)
319       rack (>= 1.1.0)
320       ruby-openid (>= 2.1.8)
321     rack-test (1.1.0)
322       rack (>= 1.0, < 3)
323     rack-uri_sanitizer (0.0.2)
324     rails (5.2.3)
325       actioncable (= 5.2.3)
326       actionmailer (= 5.2.3)
327       actionpack (= 5.2.3)
328       actionview (= 5.2.3)
329       activejob (= 5.2.3)
330       activemodel (= 5.2.3)
331       activerecord (= 5.2.3)
332       activestorage (= 5.2.3)
333       activesupport (= 5.2.3)
334       bundler (>= 1.3.0)
335       railties (= 5.2.3)
336       sprockets-rails (>= 2.0.0)
337     rails-controller-testing (1.0.4)
338       actionpack (>= 5.0.1.x)
339       actionview (>= 5.0.1.x)
340       activesupport (>= 5.0.1.x)
341     rails-dom-testing (2.0.3)
342       activesupport (>= 4.2.0)
343       nokogiri (>= 1.6)
344     rails-html-sanitizer (1.0.4)
345       loofah (~> 2.2, >= 2.2.2)
346     rails-i18n (4.0.2)
347       i18n (~> 0.6)
348       rails (>= 4.0)
349     railties (5.2.3)
350       actionpack (= 5.2.3)
351       activesupport (= 5.2.3)
352       method_source
353       rake (>= 0.8.7)
354       thor (>= 0.19.0, < 2.0)
355     rainbow (3.0.0)
356     rake (12.3.2)
357     rb-fsevent (0.10.3)
358     rb-inotify (0.10.0)
359       ffi (~> 1.0)
360     record_tag_helper (1.0.0)
361       actionview (~> 5.x)
362     ref (2.0.0)
363     request_store (1.4.1)
364       rack (>= 1.4)
365     rinku (2.0.6)
366     rotp (5.0.0)
367       addressable (~> 2.5)
368     rubocop (0.70.0)
369       jaro_winkler (~> 1.5.1)
370       parallel (~> 1.10)
371       parser (>= 2.6)
372       rainbow (>= 2.2.2, < 4.0)
373       ruby-progressbar (~> 1.7)
374       unicode-display_width (>= 1.4.0, < 1.7)
375     rubocop-performance (1.3.0)
376       rubocop (>= 0.68.0)
377     ruby-openid (2.7.0)
378     ruby-progressbar (1.10.1)
379     ruby_dep (1.5.0)
380     safe_yaml (1.0.5)
381     sanitize (5.0.0)
382       crass (~> 1.0.2)
383       nokogiri (>= 1.8.0)
384       nokogumbo (~> 2.0)
385     sassc (2.0.1)
386       ffi (~> 1.9)
387       rake
388     sassc-rails (2.1.1)
389       railties (>= 4.0.0)
390       sassc (>= 2.0)
391       sprockets (> 3.0)
392       sprockets-rails
393       tilt
394     secure_headers (6.1.0)
395     simplecov (0.16.1)
396       docile (~> 1.1)
397       json (>= 1.8, < 3)
398       simplecov-html (~> 0.10.0)
399     simplecov-html (0.10.2)
400     smart_properties (1.14.0)
401     sprockets (3.7.2)
402       concurrent-ruby (~> 1.0)
403       rack (> 1, < 3)
404     sprockets-rails (3.2.1)
405       actionpack (>= 4.0)
406       activesupport (>= 4.0)
407       sprockets (>= 3.0.0)
408     strong_migrations (0.4.0)
409       activerecord (>= 5)
410     term-ansicolor (1.7.1)
411       tins (~> 1.0)
412     terrapin (0.6.0)
413       climate_control (>= 0.0.3, < 1.0)
414     therubyracer (0.12.3)
415       libv8 (~> 3.16.14.15)
416       ref
417     thor (0.20.3)
418     thread_safe (0.3.6)
419     tilt (2.0.9)
420     tins (1.20.2)
421     tzinfo (1.2.5)
422       thread_safe (~> 0.1)
423     uglifier (4.1.20)
424       execjs (>= 0.3.0, < 3)
425     unicode-display_width (1.6.0)
426     validates_email_format_of (1.6.3)
427       i18n
428     vendorer (0.2.0)
429     webmock (3.5.1)
430       addressable (>= 2.3.6)
431       crack (>= 0.3.2)
432       hashdiff
433     websocket-driver (0.7.0)
434       websocket-extensions (>= 0.1.0)
435     websocket-extensions (0.1.3)
436     xpath (3.2.0)
437       nokogiri (~> 1.8)
438
439 PLATFORMS
440   ruby
441
442 DEPENDENCIES
443   SystemTimer (>= 1.1.3)
444   aasm
445   actionpack-page_caching
446   active_record_union
447   activerecord-import
448   annotate
449   autoprefixer-rails (~> 8.6.3)
450   better_errors
451   bigdecimal (~> 1.1.0)
452   binding_of_caller
453   bootsnap (>= 1.1.0)
454   browser
455   cancancan
456   canonical-rails
457   capybara (~> 2.13)
458   coffee-rails (~> 4.2)
459   composite_primary_keys (~> 11.1.0)
460   config
461   coveralls
462   dalli
463   delayed_job_active_record
464   dynamic_form
465   erb_lint
466   eslint-rails-ee
467   execjs
468   factory_bot_rails
469   fakefs
470   faraday
471   gd2-ffij
472   geoip
473   htmlentities
474   http_accept_language (~> 2.0.0)
475   i18n-js (>= 3.0.0)
476   image_optim_rails
477   jquery-rails
478   json
479   jsonify-rails
480   kgio
481   kramdown
482   libxml-ruby (>= 2.0.5)
483   listen
484   logstasher
485   minitest (~> 5.1)
486   oauth-plugin (>= 0.5.1)
487   omniauth
488   omniauth-facebook
489   omniauth-github
490   omniauth-google-oauth2 (>= 0.6.0)
491   omniauth-mediawiki (>= 0.0.4)
492   omniauth-openid
493   omniauth-windowslive
494   openstreetmap-deadlock_retry (>= 1.3.0)
495   paperclip (~> 5.2)
496   pg
497   poltergeist
498   psych
499   puma (~> 3.7)
500   quad_tile (~> 1.0.1)
501   r2 (~> 0.2.7)
502   rack-cors
503   rack-uri_sanitizer
504   rails (= 5.2.3)
505   rails-controller-testing
506   rails-i18n (~> 4.0.0)
507   record_tag_helper
508   rinku (>= 2.0.6)
509   rotp
510   rubocop
511   rubocop-performance
512   sanitize
513   sassc-rails
514   secure_headers
515   strong_migrations
516   therubyracer
517   uglifier (>= 1.3.0)
518   validates_email_format_of (>= 1.5.1)
519   vendorer
520   webmock
521
522 BUNDLED WITH
523    1.17.2