Replace jshint with eslint
[rails.git] / config / eslint.json
1 {
2   "env": {
3     "browser": true,
4     "jquery": true
5   },
6   "extends": [
7     "eslint:recommended"
8   ],
9   "globals": {
10     "bowser": "readonly",
11     "I18n": "readonly",
12     "L": "readonly",
13     "OSM": "writable",
14     "Piwik": "readonly",
15     "querystring": "readonly",
16     "require": "readonly",
17     "updateLinks": "readonly"
18   },
19   "rules": {
20     "eqeqeq": ["error", "smart"],
21     "no-caller": "error",
22     "no-extend-native": "error",
23     "no-new": "error",
24     "no-trailing-spaces": "error",
25     "no-undef": "error",
26     "no-unused-vars": "error",
27     "no-use-before-define": ["error", {"functions": false}],
28     "semi": ["error", "always"]
29   }
30 }