Add JSHint support
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     actionmailer (4.2.0)
6       actionpack (= 4.2.0)
7       actionview (= 4.2.0)
8       activejob (= 4.2.0)
9       mail (~> 2.5, >= 2.5.4)
10       rails-dom-testing (~> 1.0, >= 1.0.5)
11     actionpack (4.2.0)
12       actionview (= 4.2.0)
13       activesupport (= 4.2.0)
14       rack (~> 1.6.0)
15       rack-test (~> 0.6.2)
16       rails-dom-testing (~> 1.0, >= 1.0.5)
17       rails-html-sanitizer (~> 1.0, >= 1.0.1)
18     actionpack-page_caching (1.0.2)
19       actionpack (>= 4.0.0, < 5)
20     actionview (4.2.0)
21       activesupport (= 4.2.0)
22       builder (~> 3.1)
23       erubis (~> 2.7.0)
24       rails-dom-testing (~> 1.0, >= 1.0.5)
25       rails-html-sanitizer (~> 1.0, >= 1.0.1)
26     activejob (4.2.0)
27       activesupport (= 4.2.0)
28       globalid (>= 0.3.0)
29     activemodel (4.2.0)
30       activesupport (= 4.2.0)
31       builder (~> 3.1)
32     activerecord (4.2.0)
33       activemodel (= 4.2.0)
34       activesupport (= 4.2.0)
35       arel (~> 6.0)
36     activesupport (4.2.0)
37       i18n (~> 0.7)
38       json (~> 1.7, >= 1.7.7)
39       minitest (~> 5.1)
40       thread_safe (~> 0.3, >= 0.3.4)
41       tzinfo (~> 1.1)
42     arel (6.0.0)
43     ast (2.0.0)
44     astrolabe (1.3.0)
45       parser (>= 2.2.0.pre.3, < 3.0)
46     autoprefixer-rails (5.1.7)
47       execjs
48       json
49     bigdecimal (1.1.0)
50     builder (3.2.2)
51     capybara (2.4.4)
52       mime-types (>= 1.16)
53       nokogiri (>= 1.3.3)
54       rack (>= 1.0.0)
55       rack-test (>= 0.5.4)
56       xpath (~> 2.0)
57     climate_control (0.0.3)
58       activesupport (>= 3.0)
59     cliver (0.3.2)
60     cocaine (0.5.5)
61       climate_control (>= 0.0.3, < 1.0)
62     coffee-rails (4.1.0)
63       coffee-script (>= 2.2.0)
64       railties (>= 4.0.0, < 5.0)
65     coffee-script (2.3.0)
66       coffee-script-source
67       execjs
68     coffee-script-source (1.9.1)
69     colorize (0.7.5)
70     composite_primary_keys (8.0.0)
71       activerecord (~> 4.2.0)
72     crass (1.0.1)
73     dalli (2.7.2)
74     deadlock_retry (1.2.0)
75     dynamic_form (1.1.4)
76     erubis (2.7.0)
77     execjs (2.3.0)
78     faraday (0.9.1)
79       multipart-post (>= 1.2, < 3)
80     globalid (0.3.3)
81       activesupport (>= 4.1.0)
82     hike (1.2.3)
83     htmlentities (4.3.3)
84     http_accept_language (2.0.5)
85     httpclient (2.6.0.1)
86     i18n (0.7.0)
87     jquery-rails (4.0.3)
88       rails-dom-testing (~> 1.0)
89       railties (>= 4.2.0)
90       thor (>= 0.14, < 2.0)
91     jshint (1.3.1)
92       execjs (>= 1.4.0)
93       multi_json (~> 1.0)
94       therubyracer (~> 0.12.1)
95     json (1.8.2)
96     jsonify (0.3.1)
97       multi_json (~> 1.0)
98     jsonify-rails (0.3.2)
99       actionpack
100       jsonify (< 0.4.0)
101     jwt (1.2.1)
102     kgio (2.9.3)
103     konacha (3.3.0)
104       actionpack (>= 3.1, < 5)
105       capybara
106       colorize
107       railties (>= 3.1, < 5)
108       sprockets
109     libv8 (3.16.14.7)
110     libxml-ruby (2.8.0)
111     loofah (2.0.1)
112       nokogiri (>= 1.5.9)
113     mail (2.6.3)
114       mime-types (>= 1.16, < 3)
115     mime-types (2.4.3)
116     mini_portile (0.6.2)
117     minitest (5.5.1)
118     multi_json (1.10.1)
119     multi_xml (0.5.5)
120     multipart-post (2.0.0)
121     nokogiri (1.6.6.2)
122       mini_portile (~> 0.6.0)
123     nokogumbo (1.2.0)
124       nokogiri
125     oauth (0.4.7)
126     oauth-plugin (0.5.1)
127       multi_json
128       oauth (~> 0.4.4)
129       oauth2 (>= 0.5.0)
130       rack
131     oauth2 (1.0.0)
132       faraday (>= 0.8, < 0.10)
133       jwt (~> 1.0)
134       multi_json (~> 1.3)
135       multi_xml (~> 0.5)
136       rack (~> 1.2)
137     open_id_authentication (1.2.0)
138       rack-openid (~> 1.3)
139     openstreetmap-i18n-js (3.0.0.rc5.3)
140       i18n
141     paperclip (4.2.1)
142       activemodel (>= 3.0.0)
143       activesupport (>= 3.0.0)
144       cocaine (~> 0.5.3)
145       mime-types
146     parser (2.2.0.3)
147       ast (>= 1.1, < 3.0)
148     pg (0.18.1)
149     poltergeist (1.6.0)
150       capybara (~> 2.1)
151       cliver (~> 0.3.1)
152       multi_json (~> 1.0)
153       websocket-driver (>= 0.2.0)
154     powerpack (0.1.0)
155     psych (2.0.13)
156     r2 (0.2.5)
157     rack (1.6.0)
158     rack-cors (0.3.1)
159     rack-openid (1.4.2)
160       rack (>= 1.1.0)
161       ruby-openid (>= 2.1.8)
162     rack-test (0.6.3)
163       rack (>= 1.0)
164     rails (4.2.0)
165       actionmailer (= 4.2.0)
166       actionpack (= 4.2.0)
167       actionview (= 4.2.0)
168       activejob (= 4.2.0)
169       activemodel (= 4.2.0)
170       activerecord (= 4.2.0)
171       activesupport (= 4.2.0)
172       bundler (>= 1.3.0, < 2.0)
173       railties (= 4.2.0)
174       sprockets-rails
175     rails-deprecated_sanitizer (1.0.3)
176       activesupport (>= 4.2.0.alpha)
177     rails-dom-testing (1.0.5)
178       activesupport (>= 4.2.0.beta, < 5.0)
179       nokogiri (~> 1.6.0)
180       rails-deprecated_sanitizer (>= 1.0.1)
181     rails-html-sanitizer (1.0.1)
182       loofah (~> 2.0)
183     rails-i18n (4.0.3)
184       i18n (~> 0.6)
185       railties (~> 4.0)
186     railties (4.2.0)
187       actionpack (= 4.2.0)
188       activesupport (= 4.2.0)
189       rake (>= 0.8.7)
190       thor (>= 0.18.1, < 2.0)
191     rainbow (2.0.0)
192     rake (10.4.2)
193     redcarpet (3.2.2)
194     ref (1.0.5)
195     rinku (1.7.3)
196     rubocop (0.29.1)
197       astrolabe (~> 1.3)
198       parser (>= 2.2.0.1, < 3.0)
199       powerpack (~> 0.1)
200       rainbow (>= 1.99.1, < 3.0)
201       ruby-progressbar (~> 1.4)
202     ruby-openid (2.6.0)
203     ruby-progressbar (1.7.1)
204     sanitize (3.1.2)
205       crass (~> 1.0.1)
206       nokogiri (>= 1.4.4)
207       nokogumbo (= 1.2.0)
208     sass (3.4.12)
209     sass-rails (5.0.1)
210       railties (>= 4.0.0, < 5.0)
211       sass (~> 3.1)
212       sprockets (>= 2.8, < 4.0)
213       sprockets-rails (>= 2.0, < 4.0)
214       tilt (~> 1.1)
215     soap4r-ruby1.9 (2.0.5)
216     sprockets (2.12.3)
217       hike (~> 1.2)
218       multi_json (~> 1.0)
219       rack (~> 1.0)
220       tilt (~> 1.1, != 1.3.0)
221     sprockets-rails (2.2.4)
222       actionpack (>= 3.0)
223       activesupport (>= 3.0)
224       sprockets (>= 2.8, < 4.0)
225     therubyracer (0.12.1)
226       libv8 (~> 3.16.14.0)
227       ref
228     thor (0.19.1)
229     thread_safe (0.3.4)
230     tilt (1.4.1)
231     timecop (0.7.3)
232     tzinfo (1.2.2)
233       thread_safe (~> 0.1)
234     uglifier (2.7.0)
235       execjs (>= 0.3.0)
236       json (>= 1.8.0)
237     validates_email_format_of (1.6.2)
238       i18n
239     vendorer (0.1.16)
240     websocket-driver (0.5.3)
241       websocket-extensions (>= 0.1.0)
242     websocket-extensions (0.1.2)
243     xpath (2.0.0)
244       nokogiri (~> 1.3)
245
246 PLATFORMS
247   ruby
248
249 DEPENDENCIES
250   SystemTimer (>= 1.1.3)
251   actionpack-page_caching
252   autoprefixer-rails
253   bigdecimal (~> 1.1.0)
254   coffee-rails (~> 4.1.0)
255   composite_primary_keys (~> 8.0.0)
256   dalli
257   deadlock_retry (>= 1.2.0)
258   dynamic_form
259   htmlentities
260   http_accept_language (~> 2.0.0)
261   httpclient
262   jquery-rails
263   jshint
264   json
265   jsonify-rails
266   kgio
267   konacha
268   libxml-ruby (>= 2.0.5)
269   minitest (~> 5.1)
270   oauth-plugin (>= 0.5.1)
271   open_id_authentication (>= 1.1.0)
272   openstreetmap-i18n-js (>= 3.0.0.rc5.3)
273   paperclip (~> 4.0)
274   pg
275   poltergeist
276   psych
277   r2
278   rack-cors
279   rails (= 4.2.0)
280   rails-i18n (~> 4.0.0)
281   redcarpet
282   rinku (>= 1.2.2)
283   rubocop
284   ruby-openid (>= 2.2.0)
285   sanitize
286   sass-rails (~> 5.0)
287   soap4r-ruby1.9
288   timecop
289   uglifier (>= 1.3.0)
290   validates_email_format_of (>= 1.5.1)
291   vendorer