Allow indexing of diary entries again
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.5)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.3)
8       actionpack (= 5.2.3)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.3)
12       actionpack (= 5.2.3)
13       actionview (= 5.2.3)
14       activejob (= 5.2.3)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.3)
18       actionview (= 5.2.3)
19       activesupport (= 5.2.3)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.3)
27       activesupport (= 5.2.3)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.3)
35       activesupport (= 5.2.3)
36       globalid (>= 0.3.6)
37     activemodel (5.2.3)
38       activesupport (= 5.2.3)
39     activerecord (5.2.3)
40       activemodel (= 5.2.3)
41       activesupport (= 5.2.3)
42       arel (>= 9.0)
43     activerecord-import (1.0.2)
44       activerecord (>= 3.2)
45     activestorage (5.2.3)
46       actionpack (= 5.2.3)
47       activerecord (= 5.2.3)
48       marcel (~> 0.3.1)
49     activesupport (5.2.3)
50       concurrent-ruby (~> 1.0, >= 1.0.2)
51       i18n (>= 0.7, < 2)
52       minitest (~> 5.1)
53       tzinfo (~> 1.1)
54     addressable (2.6.0)
55       public_suffix (>= 2.0.2, < 4.0)
56     annotate (2.7.5)
57       activerecord (>= 3.2, < 7.0)
58       rake (>= 10.4, < 13.0)
59     arel (9.0.0)
60     ast (2.4.0)
61     autoprefixer-rails (8.6.5)
62       execjs
63     better_errors (2.5.1)
64       coderay (>= 1.0.0)
65       erubi (>= 1.0.0)
66       rack (>= 0.9.0)
67     better_html (1.0.13)
68       actionview (>= 4.0)
69       activesupport (>= 4.0)
70       ast (~> 2.0)
71       erubi (~> 1.4)
72       html_tokenizer (~> 0.0.6)
73       parser (>= 2.4)
74       smart_properties
75     bigdecimal (1.1.0)
76     binding_of_caller (0.8.0)
77       debug_inspector (>= 0.0.1)
78     bootsnap (1.4.4)
79       msgpack (~> 1.0)
80     browser (2.5.3)
81     builder (3.2.3)
82     bzip2-ffi (1.0.0)
83       ffi (~> 1.0)
84     cancancan (3.0.1)
85     canonical-rails (0.2.5)
86       rails (>= 4.1, < 6.1)
87     capybara (2.18.0)
88       addressable
89       mini_mime (>= 0.1.3)
90       nokogiri (>= 1.3.3)
91       rack (>= 1.0.0)
92       rack-test (>= 0.5.4)
93       xpath (>= 2.0, < 4.0)
94     climate_control (0.2.0)
95     cliver (0.3.2)
96     coderay (1.1.2)
97     coffee-rails (4.2.2)
98       coffee-script (>= 2.2.0)
99       railties (>= 4.0.0)
100     coffee-script (2.4.1)
101       coffee-script-source
102       execjs
103     coffee-script-source (1.12.2)
104     composite_primary_keys (11.1.0)
105       activerecord (~> 5.2.1)
106     concurrent-ruby (1.1.5)
107     config (1.7.1)
108       activesupport (>= 3.0)
109       deep_merge (~> 1.2.1)
110       dry-validation (>= 0.12.2)
111     coveralls (0.8.23)
112       json (>= 1.8, < 3)
113       simplecov (~> 0.16.1)
114       term-ansicolor (~> 1.3)
115       thor (>= 0.19.4, < 2.0)
116       tins (~> 1.6)
117     crack (0.4.3)
118       safe_yaml (~> 1.0.0)
119     crass (1.0.4)
120     dalli (2.7.10)
121     debug_inspector (0.0.3)
122     deep_merge (1.2.1)
123     delayed_job (4.1.5)
124       activesupport (>= 3.0, < 5.3)
125     delayed_job_active_record (4.1.3)
126       activerecord (>= 3.0, < 5.3)
127       delayed_job (>= 3.0, < 5)
128     docile (1.3.1)
129     dry-configurable (0.8.3)
130       concurrent-ruby (~> 1.0)
131       dry-core (~> 0.4, >= 0.4.7)
132     dry-container (0.7.0)
133       concurrent-ruby (~> 1.0)
134       dry-configurable (~> 0.1, >= 0.1.3)
135     dry-core (0.4.7)
136       concurrent-ruby (~> 1.0)
137     dry-equalizer (0.2.2)
138     dry-inflector (0.1.2)
139     dry-logic (0.6.1)
140       concurrent-ruby (~> 1.0)
141       dry-core (~> 0.2)
142       dry-equalizer (~> 0.2)
143     dry-types (0.14.1)
144       concurrent-ruby (~> 1.0)
145       dry-container (~> 0.3)
146       dry-core (~> 0.4, >= 0.4.4)
147       dry-equalizer (~> 0.2)
148       dry-inflector (~> 0.1, >= 0.1.2)
149       dry-logic (~> 0.5, >= 0.5)
150     dry-validation (0.13.3)
151       concurrent-ruby (~> 1.0)
152       dry-configurable (~> 0.1, >= 0.1.3)
153       dry-core (~> 0.2, >= 0.2.1)
154       dry-equalizer (~> 0.2)
155       dry-logic (~> 0.5, >= 0.5.0)
156       dry-types (~> 0.14.0)
157     dynamic_form (1.1.4)
158     erb_lint (0.0.28)
159       activesupport
160       better_html (~> 1.0.7)
161       html_tokenizer
162       rainbow
163       rubocop (~> 0.51)
164       smart_properties
165     erubi (1.8.0)
166     execjs (2.7.0)
167     exifr (1.3.6)
168     factory_bot (5.0.2)
169       activesupport (>= 4.2.0)
170     factory_bot_rails (5.0.2)
171       factory_bot (~> 5.0.2)
172       railties (>= 4.2.0)
173     fakefs (0.20.1)
174     faraday (0.15.4)
175       multipart-post (>= 1.2, < 3)
176     ffi (1.11.1)
177     ffi-libarchive (0.4.6)
178       ffi (~> 1.0)
179     fspath (3.1.1)
180     gd2-ffij (0.4.0)
181       ffi (>= 1.0.0)
182     geoip (1.6.4)
183     globalid (0.4.2)
184       activesupport (>= 4.2.0)
185     hashdiff (0.4.0)
186     hashie (3.6.0)
187     html_tokenizer (0.0.7)
188     htmlentities (4.3.4)
189     http_accept_language (2.0.5)
190     i18n (0.9.5)
191       concurrent-ruby (~> 1.0)
192     i18n-js (3.2.3)
193       i18n (>= 0.6.6)
194     image_optim (0.26.4)
195       exifr (~> 1.2, >= 1.2.2)
196       fspath (~> 3.0)
197       image_size (>= 1.5, < 3)
198       in_threads (~> 1.3)
199       progress (~> 3.0, >= 3.0.1)
200     image_optim_rails (0.4.2)
201       image_optim (~> 0.24)
202       rails
203       sprockets
204     image_size (2.0.1)
205     in_threads (1.5.2)
206     jaro_winkler (1.5.2)
207     jquery-rails (4.3.3)
208       rails-dom-testing (>= 1, < 3)
209       railties (>= 4.2.0)
210       thor (>= 0.14, < 2.0)
211     json (2.2.0)
212     jsonify (0.3.1)
213       multi_json (~> 1.0)
214     jsonify-rails (0.3.2)
215       actionpack
216       jsonify (< 0.4.0)
217     jwt (2.2.1)
218     kgio (2.11.2)
219     kramdown (2.1.0)
220     libxml-ruby (3.1.0)
221     listen (3.1.5)
222       rb-fsevent (~> 0.9, >= 0.9.4)
223       rb-inotify (~> 0.9, >= 0.9.7)
224       ruby_dep (~> 1.2)
225     logstash-event (1.2.02)
226     logstasher (1.3.0)
227       activesupport (>= 4.0)
228       logstash-event (~> 1.2.0)
229       request_store
230     loofah (2.2.3)
231       crass (~> 1.0.2)
232       nokogiri (>= 1.5.9)
233     mail (2.7.1)
234       mini_mime (>= 0.1.1)
235     marcel (0.3.3)
236       mimemagic (~> 0.3.2)
237     method_source (0.9.2)
238     mime-types (3.2.2)
239       mime-types-data (~> 3.2015)
240     mime-types-data (3.2019.0331)
241     mimemagic (0.3.3)
242     mini_mime (1.0.1)
243     mini_portile2 (2.4.0)
244     minitest (5.11.3)
245     msgpack (1.2.10)
246     multi_json (1.13.1)
247     multi_xml (0.6.0)
248     multipart-post (2.1.1)
249     nio4r (2.3.1)
250     nokogiri (1.10.3)
251       mini_portile2 (~> 2.4.0)
252     nokogumbo (2.0.1)
253       nokogiri (~> 1.8, >= 1.8.4)
254     oauth (0.4.7)
255     oauth-plugin (0.5.1)
256       multi_json
257       oauth (~> 0.4.4)
258       oauth2 (>= 0.5.0)
259       rack
260     oauth2 (1.4.1)
261       faraday (>= 0.8, < 0.16.0)
262       jwt (>= 1.0, < 3.0)
263       multi_json (~> 1.3)
264       multi_xml (~> 0.5)
265       rack (>= 1.2, < 3)
266     omniauth (1.9.0)
267       hashie (>= 3.4.6, < 3.7.0)
268       rack (>= 1.6.2, < 3)
269     omniauth-facebook (5.0.0)
270       omniauth-oauth2 (~> 1.2)
271     omniauth-github (1.3.0)
272       omniauth (~> 1.5)
273       omniauth-oauth2 (>= 1.4.0, < 2.0)
274     omniauth-google-oauth2 (0.7.0)
275       jwt (>= 2.0)
276       omniauth (>= 1.1.1)
277       omniauth-oauth2 (>= 1.5)
278     omniauth-mediawiki (0.0.4)
279       jwt (~> 2.0)
280       omniauth-oauth (~> 1.0)
281     omniauth-oauth (1.1.0)
282       oauth
283       omniauth (~> 1.0)
284     omniauth-oauth2 (1.6.0)
285       oauth2 (~> 1.1)
286       omniauth (~> 1.9)
287     omniauth-openid (1.0.1)
288       omniauth (~> 1.0)
289       rack-openid (~> 1.3.1)
290     omniauth-windowslive (0.0.12)
291       multi_json (~> 1.12)
292       omniauth-oauth2 (~> 1.4)
293     openstreetmap-deadlock_retry (1.3.0)
294     paperclip (5.3.0)
295       activemodel (>= 4.2.0)
296       activesupport (>= 4.2.0)
297       mime-types
298       mimemagic (~> 0.3.0)
299       terrapin (~> 0.6.0)
300     parallel (1.17.0)
301     parser (2.6.3.0)
302       ast (~> 2.4.0)
303     pg (1.1.4)
304     poltergeist (1.18.1)
305       capybara (>= 2.1, < 4)
306       cliver (~> 0.3.1)
307       websocket-driver (>= 0.2.0)
308     progress (3.5.1)
309     psych (3.1.0)
310     public_suffix (3.1.0)
311     puma (3.12.1)
312     quad_tile (1.0.1)
313     r2 (0.2.7)
314     rack (2.0.7)
315     rack-cors (1.0.3)
316     rack-openid (1.3.1)
317       rack (>= 1.1.0)
318       ruby-openid (>= 2.1.8)
319     rack-test (1.1.0)
320       rack (>= 1.0, < 3)
321     rack-uri_sanitizer (0.0.2)
322     rails (5.2.3)
323       actioncable (= 5.2.3)
324       actionmailer (= 5.2.3)
325       actionpack (= 5.2.3)
326       actionview (= 5.2.3)
327       activejob (= 5.2.3)
328       activemodel (= 5.2.3)
329       activerecord (= 5.2.3)
330       activestorage (= 5.2.3)
331       activesupport (= 5.2.3)
332       bundler (>= 1.3.0)
333       railties (= 5.2.3)
334       sprockets-rails (>= 2.0.0)
335     rails-controller-testing (1.0.4)
336       actionpack (>= 5.0.1.x)
337       actionview (>= 5.0.1.x)
338       activesupport (>= 5.0.1.x)
339     rails-dom-testing (2.0.3)
340       activesupport (>= 4.2.0)
341       nokogiri (>= 1.6)
342     rails-html-sanitizer (1.0.4)
343       loofah (~> 2.2, >= 2.2.2)
344     rails-i18n (4.0.2)
345       i18n (~> 0.6)
346       rails (>= 4.0)
347     railties (5.2.3)
348       actionpack (= 5.2.3)
349       activesupport (= 5.2.3)
350       method_source
351       rake (>= 0.8.7)
352       thor (>= 0.19.0, < 2.0)
353     rainbow (3.0.0)
354     rake (12.3.2)
355     rb-fsevent (0.10.3)
356     rb-inotify (0.10.0)
357       ffi (~> 1.0)
358     record_tag_helper (1.0.0)
359       actionview (~> 5.x)
360     request_store (1.4.1)
361       rack (>= 1.4)
362     rinku (2.0.6)
363     rotp (5.0.0)
364       addressable (~> 2.5)
365     rubocop (0.71.0)
366       jaro_winkler (~> 1.5.1)
367       parallel (~> 1.10)
368       parser (>= 2.6)
369       rainbow (>= 2.2.2, < 4.0)
370       ruby-progressbar (~> 1.7)
371       unicode-display_width (>= 1.4.0, < 1.7)
372     rubocop-performance (1.3.0)
373       rubocop (>= 0.68.0)
374     rubocop-rails (2.0.0)
375       rack (>= 2.0)
376       rubocop (>= 0.70.0)
377     ruby-openid (2.7.0)
378     ruby-progressbar (1.10.1)
379     ruby_dep (1.5.0)
380     safe_yaml (1.0.5)
381     sanitize (5.0.0)
382       crass (~> 1.0.2)
383       nokogiri (>= 1.8.0)
384       nokogumbo (~> 2.0)
385     sassc (2.0.1)
386       ffi (~> 1.9)
387       rake
388     sassc-rails (2.1.1)
389       railties (>= 4.0.0)
390       sassc (>= 2.0)
391       sprockets (> 3.0)
392       sprockets-rails
393       tilt
394     secure_headers (6.1.0)
395     simplecov (0.16.1)
396       docile (~> 1.1)
397       json (>= 1.8, < 3)
398       simplecov-html (~> 0.10.0)
399     simplecov-html (0.10.2)
400     smart_properties (1.14.0)
401     sprockets (3.7.2)
402       concurrent-ruby (~> 1.0)
403       rack (> 1, < 3)
404     sprockets-rails (3.2.1)
405       actionpack (>= 4.0)
406       activesupport (>= 4.0)
407       sprockets (>= 3.0.0)
408     strong_migrations (0.4.0)
409       activerecord (>= 5)
410     term-ansicolor (1.7.1)
411       tins (~> 1.0)
412     terrapin (0.6.0)
413       climate_control (>= 0.0.3, < 1.0)
414     thor (0.20.3)
415     thread_safe (0.3.6)
416     tilt (2.0.9)
417     tins (1.20.3)
418     tzinfo (1.2.5)
419       thread_safe (~> 0.1)
420     uglifier (4.1.20)
421       execjs (>= 0.3.0, < 3)
422     unicode-display_width (1.6.0)
423     validates_email_format_of (1.6.3)
424       i18n
425     vendorer (0.2.0)
426     webmock (3.6.0)
427       addressable (>= 2.3.6)
428       crack (>= 0.3.2)
429       hashdiff (>= 0.4.0, < 2.0.0)
430     websocket-driver (0.7.0)
431       websocket-extensions (>= 0.1.0)
432     websocket-extensions (0.1.3)
433     xpath (3.2.0)
434       nokogiri (~> 1.8)
435
436 PLATFORMS
437   ruby
438
439 DEPENDENCIES
440   SystemTimer (>= 1.1.3)
441   aasm
442   actionpack-page_caching
443   active_record_union
444   activerecord-import
445   annotate
446   autoprefixer-rails (~> 8.6.3)
447   better_errors
448   bigdecimal (~> 1.1.0)
449   binding_of_caller
450   bootsnap (>= 1.1.0)
451   browser
452   bzip2-ffi
453   cancancan
454   canonical-rails
455   capybara (~> 2.13)
456   coffee-rails (~> 4.2)
457   composite_primary_keys (~> 11.1.0)
458   config
459   coveralls
460   dalli
461   delayed_job_active_record
462   dynamic_form
463   erb_lint
464   factory_bot_rails
465   fakefs
466   faraday
467   ffi-libarchive
468   gd2-ffij (>= 0.4.0)
469   geoip
470   htmlentities
471   http_accept_language (~> 2.0.0)
472   i18n-js (>= 3.0.0)
473   image_optim_rails
474   jquery-rails
475   json
476   jsonify-rails
477   kgio
478   kramdown
479   libxml-ruby (>= 2.0.5)
480   listen
481   logstasher
482   mimemagic
483   minitest (~> 5.1)
484   oauth-plugin (>= 0.5.1)
485   omniauth
486   omniauth-facebook
487   omniauth-github
488   omniauth-google-oauth2 (>= 0.6.0)
489   omniauth-mediawiki (>= 0.0.4)
490   omniauth-openid
491   omniauth-windowslive
492   openstreetmap-deadlock_retry (>= 1.3.0)
493   paperclip (~> 5.2)
494   pg
495   poltergeist
496   psych
497   puma (~> 3.7)
498   quad_tile (~> 1.0.1)
499   r2 (~> 0.2.7)
500   rack-cors
501   rack-uri_sanitizer
502   rails (= 5.2.3)
503   rails-controller-testing
504   rails-i18n (~> 4.0.0)
505   record_tag_helper
506   rinku (>= 2.0.6)
507   rotp
508   rubocop
509   rubocop-performance
510   rubocop-rails
511   sanitize
512   sassc-rails
513   secure_headers
514   strong_migrations
515   uglifier (>= 1.3.0)
516   validates_email_format_of (>= 1.5.1)
517   vendorer
518   webmock
519
520 BUNDLED WITH
521    1.17.2