Extract the hostip.info stubbing into a common method.
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     actionmailer (4.2.7.1)
6       actionpack (= 4.2.7.1)
7       actionview (= 4.2.7.1)
8       activejob (= 4.2.7.1)
9       mail (~> 2.5, >= 2.5.4)
10       rails-dom-testing (~> 1.0, >= 1.0.5)
11     actionpack (4.2.7.1)
12       actionview (= 4.2.7.1)
13       activesupport (= 4.2.7.1)
14       rack (~> 1.6)
15       rack-test (~> 0.6.2)
16       rails-dom-testing (~> 1.0, >= 1.0.5)
17       rails-html-sanitizer (~> 1.0, >= 1.0.2)
18     actionpack-page_caching (1.0.2)
19       actionpack (>= 4.0.0, < 5)
20     actionview (4.2.7.1)
21       activesupport (= 4.2.7.1)
22       builder (~> 3.1)
23       erubis (~> 2.7.0)
24       rails-dom-testing (~> 1.0, >= 1.0.5)
25       rails-html-sanitizer (~> 1.0, >= 1.0.2)
26     activejob (4.2.7.1)
27       activesupport (= 4.2.7.1)
28       globalid (>= 0.3.0)
29     activemodel (4.2.7.1)
30       activesupport (= 4.2.7.1)
31       builder (~> 3.1)
32     activerecord (4.2.7.1)
33       activemodel (= 4.2.7.1)
34       activesupport (= 4.2.7.1)
35       arel (~> 6.0)
36     activesupport (4.2.7.1)
37       i18n (~> 0.7)
38       json (~> 1.7, >= 1.7.7)
39       minitest (~> 5.1)
40       thread_safe (~> 0.3, >= 0.3.4)
41       tzinfo (~> 1.1)
42     addressable (2.4.0)
43     arel (6.0.3)
44     ast (2.3.0)
45     autoprefixer-rails (6.5.1)
46       execjs
47     bigdecimal (1.1.0)
48     builder (3.2.2)
49     capybara (2.10.1)
50       addressable
51       mime-types (>= 1.16)
52       nokogiri (>= 1.3.3)
53       rack (>= 1.0.0)
54       rack-test (>= 0.5.4)
55       xpath (~> 2.0)
56     climate_control (0.0.3)
57       activesupport (>= 3.0)
58     cliver (0.3.2)
59     cocaine (0.5.8)
60       climate_control (>= 0.0.3, < 1.0)
61     coffee-rails (4.1.1)
62       coffee-script (>= 2.2.0)
63       railties (>= 4.0.0, < 5.1.x)
64     coffee-script (2.4.1)
65       coffee-script-source
66       execjs
67     coffee-script-source (1.10.0)
68     colorize (0.8.1)
69     composite_primary_keys (8.1.4)
70       activerecord (~> 4.2.0)
71     concurrent-ruby (1.0.2)
72     coveralls (0.8.15)
73       json (>= 1.8, < 3)
74       simplecov (~> 0.12.0)
75       term-ansicolor (~> 1.3)
76       thor (~> 0.19.1)
77       tins (>= 1.6.0, < 2)
78     crack (0.4.3)
79       safe_yaml (~> 1.0.0)
80     crass (1.0.2)
81     dalli (2.7.6)
82     deadlock_retry (1.2.0)
83     docile (1.1.5)
84     dynamic_form (1.1.4)
85     erubis (2.7.0)
86     execjs (2.7.0)
87     exifr (1.2.5)
88     factory_girl (4.7.0)
89       activesupport (>= 3.0.0)
90     factory_girl_rails (4.7.0)
91       factory_girl (~> 4.7.0)
92       railties (>= 3.0.0)
93     faraday (0.9.2)
94       multipart-post (>= 1.2, < 3)
95     fspath (3.0.1)
96     geoip (1.6.2)
97     globalid (0.3.7)
98       activesupport (>= 4.1.0)
99     hashdiff (0.3.0)
100     hashie (3.4.6)
101     htmlentities (4.3.4)
102     http_accept_language (2.0.5)
103     i18n (0.7.0)
104     i18n-js (3.0.0.rc14)
105       i18n (~> 0.6, >= 0.6.6)
106     image_optim (0.24.0)
107       exifr (~> 1.2, >= 1.2.2)
108       fspath (~> 3.0)
109       image_size (~> 1.3)
110       in_threads (~> 1.3)
111       progress (~> 3.0, >= 3.0.1)
112     image_size (1.4.2)
113     in_threads (1.3.1)
114     jquery-rails (4.2.1)
115       rails-dom-testing (>= 1, < 3)
116       railties (>= 4.2.0)
117       thor (>= 0.14, < 2.0)
118     jshint (1.4.0)
119       execjs (>= 1.4.0)
120       multi_json (~> 1.0)
121       therubyracer (~> 0.12.1)
122     json (1.8.3)
123     jsonify (0.3.1)
124       multi_json (~> 1.0)
125     jsonify-rails (0.3.2)
126       actionpack
127       jsonify (< 0.4.0)
128     jwt (1.5.6)
129     kgio (2.10.0)
130     konacha (4.0.0)
131       actionpack (>= 4.1, < 5)
132       capybara
133       colorize
134       railties (>= 4.1, < 5)
135       sprockets (>= 2, < 4)
136       sprockets-rails (>= 2, < 4)
137       tilt
138     libv8 (3.16.14.15)
139     libxml-ruby (2.9.0)
140     logstash-event (1.2.02)
141     logstasher (1.0.1)
142       activerecord (>= 4.0)
143       activesupport (>= 4.0)
144       logstash-event (~> 1.2.0)
145       request_store
146     loofah (2.0.3)
147       nokogiri (>= 1.5.9)
148     mail (2.6.4)
149       mime-types (>= 1.16, < 4)
150     mime-types (3.1)
151       mime-types-data (~> 3.2015)
152     mime-types-data (3.2016.0521)
153     mimemagic (0.3.0)
154     mini_portile2 (2.1.0)
155     minitest (5.9.1)
156     multi_json (1.12.1)
157     multi_xml (0.5.5)
158     multipart-post (2.0.0)
159     nokogiri (1.6.8.1)
160       mini_portile2 (~> 2.1.0)
161     nokogumbo (1.4.9)
162       nokogiri
163     oauth (0.4.7)
164     oauth-plugin (0.5.1)
165       multi_json
166       oauth (~> 0.4.4)
167       oauth2 (>= 0.5.0)
168       rack
169     oauth2 (1.2.0)
170       faraday (>= 0.8, < 0.10)
171       jwt (~> 1.0)
172       multi_json (~> 1.3)
173       multi_xml (~> 0.5)
174       rack (>= 1.2, < 3)
175     omniauth (1.3.1)
176       hashie (>= 1.2, < 4)
177       rack (>= 1.0, < 3)
178     omniauth-facebook (4.0.0)
179       omniauth-oauth2 (~> 1.2)
180     omniauth-github (1.1.2)
181       omniauth (~> 1.0)
182       omniauth-oauth2 (~> 1.1)
183     omniauth-google-oauth2 (0.4.1)
184       jwt (~> 1.5.2)
185       multi_json (~> 1.3)
186       omniauth (>= 1.1.1)
187       omniauth-oauth2 (>= 1.3.1)
188     omniauth-oauth2 (1.4.0)
189       oauth2 (~> 1.0)
190       omniauth (~> 1.2)
191     omniauth-openid (1.0.1)
192       omniauth (~> 1.0)
193       rack-openid (~> 1.3.1)
194     omniauth-windowslive (0.0.11)
195       multi_json (>= 1.0.3)
196       omniauth-oauth2 (~> 1.4)
197     paperclip (4.3.7)
198       activemodel (>= 3.2.0)
199       activesupport (>= 3.2.0)
200       cocaine (~> 0.5.5)
201       mime-types
202       mimemagic (= 0.3.0)
203     parser (2.3.1.4)
204       ast (~> 2.2)
205     pg (0.19.0)
206     poltergeist (1.11.0)
207       capybara (~> 2.1)
208       cliver (~> 0.3.1)
209       websocket-driver (>= 0.2.0)
210     powerpack (0.1.1)
211     progress (3.2.2)
212     psych (2.1.1)
213     r2 (0.2.6)
214     rack (1.6.4)
215     rack-cors (0.4.0)
216     rack-openid (1.3.1)
217       rack (>= 1.1.0)
218       ruby-openid (>= 2.1.8)
219     rack-test (0.6.3)
220       rack (>= 1.0)
221     rack-uri_sanitizer (0.0.2)
222     rails (4.2.7.1)
223       actionmailer (= 4.2.7.1)
224       actionpack (= 4.2.7.1)
225       actionview (= 4.2.7.1)
226       activejob (= 4.2.7.1)
227       activemodel (= 4.2.7.1)
228       activerecord (= 4.2.7.1)
229       activesupport (= 4.2.7.1)
230       bundler (>= 1.3.0, < 2.0)
231       railties (= 4.2.7.1)
232       sprockets-rails
233     rails-deprecated_sanitizer (1.0.3)
234       activesupport (>= 4.2.0.alpha)
235     rails-dom-testing (1.0.7)
236       activesupport (>= 4.2.0.beta, < 5.0)
237       nokogiri (~> 1.6.0)
238       rails-deprecated_sanitizer (>= 1.0.1)
239     rails-html-sanitizer (1.0.3)
240       loofah (~> 2.0)
241     rails-i18n (4.0.9)
242       i18n (~> 0.7)
243       railties (~> 4.0)
244     railties (4.2.7.1)
245       actionpack (= 4.2.7.1)
246       activesupport (= 4.2.7.1)
247       rake (>= 0.8.7)
248       thor (>= 0.18.1, < 2.0)
249     rainbow (2.1.0)
250     rake (11.3.0)
251     redcarpet (3.3.4)
252     ref (2.0.0)
253     request_store (1.3.1)
254     rinku (2.0.2)
255     rubocop (0.44.1)
256       parser (>= 2.3.1.1, < 3.0)
257       powerpack (~> 0.1)
258       rainbow (>= 1.99.1, < 3.0)
259       ruby-progressbar (~> 1.7)
260       unicode-display_width (~> 1.0, >= 1.0.1)
261     ruby-openid (2.7.0)
262     ruby-progressbar (1.8.1)
263     safe_yaml (1.0.4)
264     sanitize (4.4.0)
265       crass (~> 1.0.2)
266       nokogiri (>= 1.4.4)
267       nokogumbo (~> 1.4.1)
268     sass (3.4.22)
269     sass-rails (5.0.6)
270       railties (>= 4.0.0, < 6)
271       sass (~> 3.1)
272       sprockets (>= 2.8, < 4.0)
273       sprockets-rails (>= 2.0, < 4.0)
274       tilt (>= 1.1, < 3)
275     simplecov (0.12.0)
276       docile (~> 1.1.0)
277       json (>= 1.8, < 3)
278       simplecov-html (~> 0.10.0)
279     simplecov-html (0.10.0)
280     sprockets (3.7.0)
281       concurrent-ruby (~> 1.0)
282       rack (> 1, < 3)
283     sprockets-rails (3.2.0)
284       actionpack (>= 4.0)
285       activesupport (>= 4.0)
286       sprockets (>= 3.0.0)
287     term-ansicolor (1.4.0)
288       tins (~> 1.0)
289     therubyracer (0.12.2)
290       libv8 (~> 3.16.14.0)
291       ref
292     thor (0.19.1)
293     thread_safe (0.3.5)
294     tilt (2.0.5)
295     timecop (0.8.1)
296     tins (1.12.0)
297     tzinfo (1.2.2)
298       thread_safe (~> 0.1)
299     uglifier (3.0.2)
300       execjs (>= 0.3.0, < 3)
301     unicode-display_width (1.1.1)
302     validates_email_format_of (1.6.3)
303       i18n
304     vendorer (0.1.16)
305     webmock (1.24.2)
306       addressable (>= 2.3.6)
307       crack (>= 0.3.2)
308       hashdiff
309     websocket-driver (0.6.4)
310       websocket-extensions (>= 0.1.0)
311     websocket-extensions (0.1.2)
312     xpath (2.0.0)
313       nokogiri (~> 1.3)
314
315 PLATFORMS
316   ruby
317
318 DEPENDENCIES
319   SystemTimer (>= 1.1.3)
320   actionpack-page_caching
321   autoprefixer-rails
322   bigdecimal (~> 1.1.0)
323   coffee-rails (~> 4.1.0)
324   composite_primary_keys (~> 8.1.0)
325   coveralls
326   dalli
327   deadlock_retry (>= 1.2.0)
328   dynamic_form
329   factory_girl_rails
330   faraday
331   geoip
332   htmlentities
333   http_accept_language (~> 2.0.0)
334   i18n-js (>= 3.0.0.rc10)
335   image_optim (>= 0.22.0)
336   jquery-rails
337   jshint
338   json
339   jsonify-rails
340   kgio
341   konacha
342   libxml-ruby (>= 2.0.5)
343   logstasher
344   minitest (~> 5.1)
345   oauth-plugin (>= 0.5.1)
346   omniauth
347   omniauth-facebook
348   omniauth-github
349   omniauth-google-oauth2 (>= 0.2.7)
350   omniauth-openid
351   omniauth-windowslive
352   paperclip (~> 4.0)
353   pg
354   poltergeist
355   psych
356   r2
357   rack-cors
358   rack-uri_sanitizer
359   rails (= 4.2.7.1)
360   rails-i18n (~> 4.0.0)
361   redcarpet
362   rinku (>= 1.2.2)
363   rubocop
364   sanitize
365   sass-rails (~> 5.0)
366   timecop
367   uglifier (>= 1.3.0)
368   validates_email_format_of (>= 1.5.1)
369   vendorer
370   webmock
371
372 BUNDLED WITH
373    1.11.2