Merge remote-tracking branch 'upstream/pull/2182'
[rails.git] / Gemfile
1 source "https://rubygems.org"
2
3 # Require rails
4 gem "rails", "5.2.2.1"
5
6 # Require things which have moved to gems in ruby 1.9
7 gem "bigdecimal", "~> 1.1.0", :platforms => :ruby_19
8
9 # Require things which have moved to gems in ruby 2.0
10 gem "psych", :platforms => :ruby_20
11
12 # Require json for multi_json
13 gem "json"
14
15 # Use postgres as the database
16 gem "pg", "~> 0.18"
17
18 # Use SCSS for stylesheets
19 gem "sassc-rails"
20
21 # Use Uglifier as compressor for JavaScript assets
22 gem "uglifier", ">= 1.3.0"
23
24 # Use CoffeeScript for .js.coffee assets and views
25 gem "coffee-rails", "~> 4.2"
26
27 # Use jquery as the JavaScript library
28 gem "jquery-rails"
29
30 # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
31 # gem 'jbuilder', '~> 2.0'
32 gem "jsonify-rails"
33
34 # Reduces boot times through caching; required in config/boot.rb
35 gem "bootsnap", ">= 1.1.0", :require => false
36
37 # Use R2 for RTL conversion
38 gem "r2", "~> 0.2.7"
39
40 # Use autoprefixer to generate CSS prefixes
41 gem "autoprefixer-rails", "~> 8.6.3"
42
43 # Use image_optim to optimise images
44 gem "image_optim_rails"
45
46 # Load rails plugins
47 gem "actionpack-page_caching"
48 gem "active_record_union"
49 gem "cancancan"
50 gem "composite_primary_keys", "~> 11.1.0"
51 gem "config"
52 gem "delayed_job_active_record"
53 gem "dynamic_form"
54 gem "http_accept_language", "~> 2.0.0"
55 gem "i18n-js", ">= 3.0.0"
56 gem "oauth-plugin", ">= 0.5.1"
57 gem "openstreetmap-deadlock_retry", ">= 1.3.0", :require => "deadlock_retry"
58 gem "paperclip", "~> 5.2"
59 gem "rack-cors"
60 gem "rails-i18n", "~> 4.0.0"
61 gem "record_tag_helper"
62 gem "rinku", "= 2.0.4", :require => "rails_rinku"
63 gem "validates_email_format_of", ">= 1.5.1"
64
65 # Native OSM extensions
66 gem "quad_tile", "~> 1.0.1"
67
68 # Sanitise URIs
69 gem "rack-uri_sanitizer"
70
71 # Omniauth for authentication
72 gem "omniauth"
73 gem "omniauth-facebook"
74 gem "omniauth-github"
75 gem "omniauth-google-oauth2", ">= 0.6.0"
76 gem "omniauth-mediawiki", ">= 0.0.4"
77 gem "omniauth-openid"
78 gem "omniauth-windowslive"
79
80 # Markdown formatting support
81 gem "kramdown"
82
83 # For status transitions of Issues
84 gem "aasm"
85
86 # Load libxml support for XML parsing and generation
87 gem "libxml-ruby", ">= 2.0.5", :require => "libxml"
88
89 # Use for HTML sanitisation
90 gem "htmlentities"
91 gem "sanitize"
92
93 # Load SystemTimer for implementing request timeouts
94 gem "SystemTimer", ">= 1.1.3", :require => "system_timer", :platforms => :ruby_18
95
96 # Load faraday for mockable HTTP client
97 gem "faraday"
98
99 # Load geoip for querying Maxmind GeoIP database
100 gem "geoip"
101
102 # Load rotp to generate TOTP tokens
103 gem "rotp"
104
105 # Load memcache client in case we are using it
106 gem "dalli"
107 gem "kgio"
108
109 # Load secure_headers for Content-Security-Policy support
110 gem "secure_headers"
111
112 # Load canonical-rails to generate canonical URLs
113 gem "canonical-rails"
114
115 # Used to generate logstash friendly log files
116 gem "logstasher"
117
118 # Used to generate images for traces
119 gem "gd2-ffij"
120
121 # Used for browser detection
122 gem "browser"
123
124 # Gems useful for development
125 group :development do
126   gem "annotate"
127   gem "better_errors"
128   gem "binding_of_caller"
129   gem "listen"
130   gem "vendorer"
131 end
132
133 # Gems needed for running tests
134 group :test do
135   gem "fakefs", :require => "fakefs/safe"
136   gem "minitest", "~> 5.1", :platforms => [:ruby_19, :ruby_20]
137   gem "rails-controller-testing"
138   gem "rubocop"
139   gem "webmock"
140 end
141
142 # Needed in development as well so rake can see konacha tasks
143 group :development, :test do
144   gem "capybara", "~> 2.13"
145   gem "coveralls", :require => false
146   gem "factory_bot_rails"
147   gem "jshint"
148   gem "poltergeist"
149   gem "puma", "~> 3.7"
150 end