Reduce user location to be between -180 and 180 degrees
[rails.git] / Gemfile
1 # Gem source to use
2 source 'http://rubygems.org'
3
4 # Require rails
5 gem 'rails', '3.2.12'
6
7 # Require things which have moved to gems in ruby 1.9
8 gem 'bigdecimal', "~> 1.1.0", :platforms => :ruby_19
9
10 # Require things which have moved to gems in ruby 2.0
11 gem 'psych', :platforms => :ruby_20
12
13 # Require the postgres database driver
14 gem 'pg'
15
16 # Load jquery support
17 gem 'jquery-rails'
18
19 # Load R2 for RTL conversion
20 gem 'r2'
21
22 # Load rails plugins
23 gem 'rails-i18n', ">= 0.6.3"
24 gem 'dynamic_form'
25 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
26 gem 'oauth-plugin', '>= 0.4.1', :require => 'oauth-plugin'
27 gem 'open_id_authentication', '>= 1.1.0'
28 gem 'validates_email_format_of', '>= 1.5.1'
29 gem 'composite_primary_keys', '>= 5.0.10'
30 gem 'http_accept_language', '>= 1.0.2'
31 gem 'paperclip', '~> 2.0'
32 gem 'deadlock_retry', '>= 1.2.0'
33 gem 'i18n-js', '>= 3.0.0.rc2'
34 gem 'rack-cors'
35 gem 'jsonify-rails'
36
37 # We need ruby-openid 2.2.0 or later for ruby 1.9 support
38 gem 'ruby-openid', '>= 2.2.0'
39
40 # Markdown formatting support
41 gem 'redcarpet'
42
43 # Character conversion support for ruby 1.8
44 gem 'iconv', '= 0.1', :platforms => :ruby_18
45
46 # Load libxml support for XML parsing and generation
47 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
48
49 # Use for HTML sanitisation
50 gem 'sanitize'
51 gem 'htmlentities'
52
53 # Load SystemTimer for implementing request timeouts
54 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer', :platforms => :ruby_18
55
56 # Load httpclient for SOAP support for Quova GeoIP queries
57 gem 'httpclient'
58
59 # Load memcache in case we are using it
60 gem 'memcached', '>= 1.4.1'
61
62 # Gems useful for development
63 group :development do
64   gem 'vendorer'
65 end
66
67 # Gems needed for running tests
68 group :test do
69   gem 'timecop'
70   gem 'minitest', '~> 4.7.0', :platforms => [:ruby_19, :ruby_20]
71 end
72
73 # Gems needed for compiling assets
74 group :assets do
75   gem 'sass-rails', '~> 3.2.3'
76   gem 'coffee-rails', '~> 3.2.1'
77   gem 'uglifier', '>= 1.0.3'
78   gem 'therubyracer', '~> 0.10.2'
79   gem 'ejs'
80 end