Merge branch 'master' into moderation
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.1.0)
6     actioncable (5.1.5)
7       actionpack (= 5.1.5)
8       nio4r (~> 2.0)
9       websocket-driver (~> 0.6.1)
10     actionmailer (5.1.5)
11       actionpack (= 5.1.5)
12       actionview (= 5.1.5)
13       activejob (= 5.1.5)
14       mail (~> 2.5, >= 2.5.4)
15       rails-dom-testing (~> 2.0)
16     actionpack (5.1.5)
17       actionview (= 5.1.5)
18       activesupport (= 5.1.5)
19       rack (~> 2.0)
20       rack-test (>= 0.6.3)
21       rails-dom-testing (~> 2.0)
22       rails-html-sanitizer (~> 1.0, >= 1.0.2)
23     actionpack-page_caching (1.1.0)
24       actionpack (>= 4.0.0, < 6)
25     actionview (5.1.5)
26       activesupport (= 5.1.5)
27       builder (~> 3.1)
28       erubi (~> 1.4)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.0.3)
31     activejob (5.1.5)
32       activesupport (= 5.1.5)
33       globalid (>= 0.3.6)
34     activemodel (5.1.5)
35       activesupport (= 5.1.5)
36     activerecord (5.1.5)
37       activemodel (= 5.1.5)
38       activesupport (= 5.1.5)
39       arel (~> 8.0)
40     activesupport (5.1.5)
41       concurrent-ruby (~> 1.0, >= 1.0.2)
42       i18n (~> 0.7)
43       minitest (~> 5.1)
44       tzinfo (~> 1.1)
45     addressable (2.5.2)
46       public_suffix (>= 2.0.2, < 4.0)
47     annotate (2.7.2)
48       activerecord (>= 3.2, < 6.0)
49       rake (>= 10.4, < 13.0)
50     arel (8.0.0)
51     ast (2.4.0)
52     autoprefixer-rails (8.2.0)
53       execjs
54     bigdecimal (1.1.0)
55     builder (3.2.3)
56     canonical-rails (0.2.2)
57       rails (>= 4.1, < 5.2)
58     capybara (2.18.0)
59       addressable
60       mini_mime (>= 0.1.3)
61       nokogiri (>= 1.3.3)
62       rack (>= 1.0.0)
63       rack-test (>= 0.5.4)
64       xpath (>= 2.0, < 4.0)
65     climate_control (0.2.0)
66     cliver (0.3.2)
67     coffee-rails (4.2.2)
68       coffee-script (>= 2.2.0)
69       railties (>= 4.0.0)
70     coffee-script (2.4.1)
71       coffee-script-source
72       execjs
73     coffee-script-source (1.12.2)
74     composite_primary_keys (10.0.3)
75       activerecord (~> 5.1.0, >= 5.1.5)
76     concurrent-ruby (1.0.5)
77     coveralls (0.8.21)
78       json (>= 1.8, < 3)
79       simplecov (~> 0.14.1)
80       term-ansicolor (~> 1.3)
81       thor (~> 0.19.4)
82       tins (~> 1.6)
83     crack (0.4.3)
84       safe_yaml (~> 1.0.0)
85     crass (1.0.3)
86     dalli (2.7.6)
87     docile (1.1.5)
88     dynamic_form (1.1.4)
89     erubi (1.7.1)
90     execjs (2.7.0)
91     exifr (1.3.3)
92     factory_bot (4.8.2)
93       activesupport (>= 3.0.0)
94     factory_bot_rails (4.8.2)
95       factory_bot (~> 4.8.2)
96       railties (>= 3.0.0)
97     faraday (0.12.2)
98       multipart-post (>= 1.2, < 3)
99     ffi (1.9.23)
100     fspath (3.1.0)
101     geoip (1.6.4)
102     globalid (0.4.1)
103       activesupport (>= 4.2.0)
104     hashdiff (0.3.7)
105     hashie (3.5.7)
106     htmlentities (4.3.4)
107     http_accept_language (2.0.5)
108     i18n (0.9.5)
109       concurrent-ruby (~> 1.0)
110     i18n-js (3.0.5)
111       i18n (>= 0.6.6, < 2)
112     image_optim (0.26.1)
113       exifr (~> 1.2, >= 1.2.2)
114       fspath (~> 3.0)
115       image_size (~> 1.5)
116       in_threads (~> 1.3)
117       progress (~> 3.0, >= 3.0.1)
118     image_optim_rails (0.4.1)
119       image_optim (~> 0.24)
120       rails
121       sprockets
122     image_size (1.5.0)
123     in_threads (1.5.0)
124     jquery-rails (4.3.1)
125       rails-dom-testing (>= 1, < 3)
126       railties (>= 4.2.0)
127       thor (>= 0.14, < 2.0)
128     jshint (1.5.0)
129       execjs (>= 1.4.0)
130       multi_json (~> 1.0)
131       therubyracer (~> 0.12.1)
132     json (2.1.0)
133     jsonify (0.3.1)
134       multi_json (~> 1.0)
135     jsonify-rails (0.3.2)
136       actionpack
137       jsonify (< 0.4.0)
138     jwt (1.5.6)
139     kgio (2.11.2)
140     libv8 (3.16.14.19)
141     libxml-ruby (3.1.0)
142     listen (3.1.5)
143       rb-fsevent (~> 0.9, >= 0.9.4)
144       rb-inotify (~> 0.9, >= 0.9.7)
145       ruby_dep (~> 1.2)
146     logstash-event (1.2.02)
147     logstasher (1.2.2)
148       activesupport (>= 4.0)
149       logstash-event (~> 1.2.0)
150       request_store
151     loofah (2.2.2)
152       crass (~> 1.0.2)
153       nokogiri (>= 1.5.9)
154     mail (2.7.0)
155       mini_mime (>= 0.1.1)
156     method_source (0.9.0)
157     mime-types (3.1)
158       mime-types-data (~> 3.2015)
159     mime-types-data (3.2016.0521)
160     mimemagic (0.3.2)
161     mini_mime (1.0.0)
162     mini_portile2 (2.3.0)
163     minitest (5.11.3)
164     multi_json (1.13.1)
165     multi_xml (0.6.0)
166     multipart-post (2.0.0)
167     nio4r (2.3.0)
168     nokogiri (1.8.2)
169       mini_portile2 (~> 2.3.0)
170     nokogumbo (1.5.0)
171       nokogiri
172     oauth (0.4.7)
173     oauth-plugin (0.5.1)
174       multi_json
175       oauth (~> 0.4.4)
176       oauth2 (>= 0.5.0)
177       rack
178     oauth2 (1.4.0)
179       faraday (>= 0.8, < 0.13)
180       jwt (~> 1.0)
181       multi_json (~> 1.3)
182       multi_xml (~> 0.5)
183       rack (>= 1.2, < 3)
184     omniauth (1.8.1)
185       hashie (>= 3.4.6, < 3.6.0)
186       rack (>= 1.6.2, < 3)
187     omniauth-facebook (4.0.0)
188       omniauth-oauth2 (~> 1.2)
189     omniauth-github (1.3.0)
190       omniauth (~> 1.5)
191       omniauth-oauth2 (>= 1.4.0, < 2.0)
192     omniauth-google-oauth2 (0.5.3)
193       jwt (>= 1.5)
194       omniauth (>= 1.1.1)
195       omniauth-oauth2 (>= 1.5)
196     omniauth-mediawiki (0.0.3)
197       jwt (~> 1.0)
198       omniauth-oauth (~> 1.0)
199     omniauth-oauth (1.1.0)
200       oauth
201       omniauth (~> 1.0)
202     omniauth-oauth2 (1.5.0)
203       oauth2 (~> 1.1)
204       omniauth (~> 1.2)
205     omniauth-openid (1.0.1)
206       omniauth (~> 1.0)
207       rack-openid (~> 1.3.1)
208     omniauth-windowslive (0.0.12)
209       multi_json (~> 1.12)
210       omniauth-oauth2 (~> 1.4)
211     openstreetmap-deadlock_retry (1.3.0)
212     paperclip (5.3.0)
213       activemodel (>= 4.2.0)
214       activesupport (>= 4.2.0)
215       mime-types
216       mimemagic (~> 0.3.0)
217       terrapin (~> 0.6.0)
218     parallel (1.12.1)
219     parser (2.5.0.5)
220       ast (~> 2.4.0)
221     pg (0.21.0)
222     poltergeist (1.17.0)
223       capybara (~> 2.1)
224       cliver (~> 0.3.1)
225       websocket-driver (>= 0.2.0)
226     powerpack (0.1.1)
227     progress (3.4.0)
228     psych (3.0.2)
229     public_suffix (3.0.2)
230     puma (3.11.3)
231     r2 (0.2.7)
232     rack (2.0.4)
233     rack-cors (1.0.2)
234     rack-openid (1.3.1)
235       rack (>= 1.1.0)
236       ruby-openid (>= 2.1.8)
237     rack-test (0.8.3)
238       rack (>= 1.0, < 3)
239     rack-uri_sanitizer (0.0.2)
240     rails (5.1.5)
241       actioncable (= 5.1.5)
242       actionmailer (= 5.1.5)
243       actionpack (= 5.1.5)
244       actionview (= 5.1.5)
245       activejob (= 5.1.5)
246       activemodel (= 5.1.5)
247       activerecord (= 5.1.5)
248       activesupport (= 5.1.5)
249       bundler (>= 1.3.0)
250       railties (= 5.1.5)
251       sprockets-rails (>= 2.0.0)
252     rails-controller-testing (1.0.2)
253       actionpack (~> 5.x, >= 5.0.1)
254       actionview (~> 5.x, >= 5.0.1)
255       activesupport (~> 5.x)
256     rails-dom-testing (2.0.3)
257       activesupport (>= 4.2.0)
258       nokogiri (>= 1.6)
259     rails-html-sanitizer (1.0.4)
260       loofah (~> 2.2, >= 2.2.2)
261     rails-i18n (4.0.2)
262       i18n (~> 0.6)
263       rails (>= 4.0)
264     railties (5.1.5)
265       actionpack (= 5.1.5)
266       activesupport (= 5.1.5)
267       method_source
268       rake (>= 0.8.7)
269       thor (>= 0.18.1, < 2.0)
270     rainbow (3.0.0)
271     rake (12.3.1)
272     rb-fsevent (0.10.3)
273     rb-inotify (0.9.10)
274       ffi (>= 0.5.0, < 2)
275     record_tag_helper (1.0.0)
276       actionview (~> 5.x)
277     redcarpet (3.4.0)
278     ref (2.0.0)
279     request_store (1.4.1)
280       rack (>= 1.4)
281     rinku (2.0.4)
282     rotp (3.3.1)
283     rubocop (0.54.0)
284       parallel (~> 1.10)
285       parser (>= 2.5)
286       powerpack (~> 0.1)
287       rainbow (>= 2.2.2, < 4.0)
288       ruby-progressbar (~> 1.7)
289       unicode-display_width (~> 1.0, >= 1.0.1)
290     ruby-openid (2.7.0)
291     ruby-progressbar (1.9.0)
292     ruby_dep (1.5.0)
293     safe_yaml (1.0.4)
294     sanitize (4.6.4)
295       crass (~> 1.0.2)
296       nokogiri (>= 1.4.4)
297       nokogumbo (~> 1.4)
298     sass (3.5.6)
299       sass-listen (~> 4.0.0)
300     sass-listen (4.0.0)
301       rb-fsevent (~> 0.9, >= 0.9.4)
302       rb-inotify (~> 0.9, >= 0.9.7)
303     sass-rails (5.0.7)
304       railties (>= 4.0.0, < 6)
305       sass (~> 3.1)
306       sprockets (>= 2.8, < 4.0)
307       sprockets-rails (>= 2.0, < 4.0)
308       tilt (>= 1.1, < 3)
309     secure_headers (5.0.5)
310       useragent (>= 0.15.0)
311     simplecov (0.14.1)
312       docile (~> 1.1.0)
313       json (>= 1.8, < 3)
314       simplecov-html (~> 0.10.0)
315     simplecov-html (0.10.2)
316     sprockets (3.7.1)
317       concurrent-ruby (~> 1.0)
318       rack (> 1, < 3)
319     sprockets-rails (3.2.1)
320       actionpack (>= 4.0)
321       activesupport (>= 4.0)
322       sprockets (>= 3.0.0)
323     term-ansicolor (1.6.0)
324       tins (~> 1.0)
325     terrapin (0.6.0)
326       climate_control (>= 0.0.3, < 1.0)
327     therubyracer (0.12.3)
328       libv8 (~> 3.16.14.15)
329       ref
330     thor (0.19.4)
331     thread_safe (0.3.6)
332     tilt (2.0.8)
333     tins (1.16.3)
334     tzinfo (1.2.5)
335       thread_safe (~> 0.1)
336     uglifier (4.1.8)
337       execjs (>= 0.3.0, < 3)
338     unicode-display_width (1.3.0)
339     useragent (0.16.10)
340     validates_email_format_of (1.6.3)
341       i18n
342     vendorer (0.1.16)
343     webmock (3.3.0)
344       addressable (>= 2.3.6)
345       crack (>= 0.3.2)
346       hashdiff
347     websocket-driver (0.6.5)
348       websocket-extensions (>= 0.1.0)
349     websocket-extensions (0.1.3)
350     xpath (3.0.0)
351       nokogiri (~> 1.8)
352
353 PLATFORMS
354   ruby
355
356 DEPENDENCIES
357   SystemTimer (>= 1.1.3)
358   aasm
359   actionpack-page_caching
360   annotate
361   autoprefixer-rails
362   bigdecimal (~> 1.1.0)
363   canonical-rails
364   capybara (~> 2.13)
365   coffee-rails (~> 4.2)
366   composite_primary_keys (~> 10.0.0)
367   coveralls
368   dalli
369   dynamic_form
370   factory_bot_rails
371   faraday
372   geoip
373   htmlentities
374   http_accept_language (~> 2.0.0)
375   i18n-js (>= 3.0.0)
376   image_optim_rails
377   jquery-rails
378   jshint
379   json
380   jsonify-rails
381   kgio
382   libxml-ruby (>= 2.0.5)
383   listen
384   logstasher
385   minitest (~> 5.1)
386   oauth-plugin (>= 0.5.1)
387   omniauth
388   omniauth-facebook
389   omniauth-github
390   omniauth-google-oauth2 (>= 0.2.7)
391   omniauth-mediawiki (>= 0.0.3)
392   omniauth-openid
393   omniauth-windowslive
394   openstreetmap-deadlock_retry (>= 1.3.0)
395   paperclip (~> 5.2)
396   pg (~> 0.18)
397   poltergeist
398   psych
399   puma (~> 3.7)
400   r2 (~> 0.2.7)
401   rack-cors
402   rack-uri_sanitizer
403   rails (= 5.1.5)
404   rails-controller-testing
405   rails-i18n (~> 4.0.0)
406   record_tag_helper
407   redcarpet
408   rinku (>= 1.2.2)
409   rotp
410   rubocop
411   sanitize
412   sass-rails (~> 5.0)
413   secure_headers
414   uglifier (>= 1.3.0)
415   validates_email_format_of (>= 1.5.1)
416   vendorer
417   webmock
418
419 BUNDLED WITH
420    1.15.4