Upgrade to rails 3.1.0
[rails.git] / Gemfile
1 source 'http://rubygems.org'
2
3 gem 'rails', '3.1.0'
4
5 gem 'pg'
6 gem 'arel', '>= 2.0.9'
7 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
8 gem 'rmagick', :require => 'RMagick'
9 gem 'oauth', '>= 0.4.4'
10 gem 'oauth-plugin', '>= 0.4.0.pre4'
11 gem 'httpclient'
12 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer'
13 gem 'sanitize'
14 gem 'rails-i18n-updater'
15 gem 'validates_email_format_of', '>= 1.5.1'
16 gem 'open_id_authentication', '>= 1.1.0'
17 gem 'prototype-rails'
18
19 # Should only load if memcache is in use
20 #gem 'memcached'
21
22 # Should only load if we're not in database offline mode
23 gem 'composite_primary_keys', '= 4.0.0'
24
25 # Bundle gems for the local environment. Make sure to
26 # put test-only gems in this group so their generators
27 # and rake tasks are available in development mode:
28 group :development, :test do
29   gem 'timecop'
30 end
31
32 # Gems used only for assets and not required
33 # in production environments by default.
34 group :assets do
35   gem 'sass-rails', "  ~> 3.1.0"
36   gem 'coffee-rails', "~> 3.1.0"
37   gem 'uglifier'
38 end