Upgrade to rails 3.1.0
[rails.git] / config / application.rb
1 require File.expand_path('../boot', __FILE__)
2
3 require File.expand_path('../preinitializer', __FILE__)
4
5 require 'rails/all'
6
7 if defined?(Bundler)
8   # If you precompile assets before deploying to production, use this line
9   Bundler.require *Rails.groups(:assets => %w(development test))
10   # If you want your assets lazily compiled in production, use this line
11   # Bundler.require(:default, :assets, Rails.env)
12 end
13
14 module OpenStreetMap
15   class Application < Rails::Application
16     # Settings in config/environments/* take precedence over those specified here.
17     # Application configuration should go into files in config/initializers
18     # -- all .rb files in that directory are automatically loaded.
19
20     # Custom directories with classes and modules you want to be autoloadable.
21     config.autoload_paths += %W(#{config.root}/lib)
22
23     # Only load the plugins named here, in the order given (default is alphabetical).
24     # :all can be used as a placeholder for all plugins not explicitly named.
25     # config.plugins = [ :exception_notification, :ssl_requirement, :all ]
26
27     # Activate observers that should always be running.
28     config.active_record.observers = :spam_observer
29
30     # Set Time.zone default to the specified zone and make Active Record auto-convert to this zone.
31     # Run "rake -D time" for a list of tasks for finding time zone names. Default is UTC.
32     # config.time_zone = 'Central Time (US & Canada)'
33
34     # The default locale is :en and all translations from config/locales/*.rb,yml are auto loaded.
35     # config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.{rb,yml}').to_s]
36     # config.i18n.default_locale = :de
37
38     # Configure the default encoding used in templates for Ruby 1.9.
39     config.encoding = "utf-8"
40
41     # Configure sensitive parameters which will be filtered from the log file.
42     config.filter_parameters += [:password, :pass_crypt, :pass_crypt_confirmation]
43
44     # Enable the asset pipeline
45     config.assets.enabled = true
46
47     # Version of your assets, change this if you want to expire all your assets
48     config.assets.version = '1.0'
49
50     # Use SQL instead of Active Record's schema dumper when creating the test database.
51     # This is necessary if your schema can't be completely dumped by the schema dumper,
52     # like if you have constraints or database-specific column types
53     config.active_record.schema_format = :sql
54   end
55 end