]> git.openstreetmap.org Git - rails.git/blob - db/migrate/018_create_acls.rb
Require the migration helper code in some more migrations.
[rails.git] / db / migrate / 018_create_acls.rb
1 require 'lib/migrate'
2
3 class CreateAcls < ActiveRecord::Migration
4   def self.up
5     create_table "acls", myisam_table do |t|
6       t.column "id",      :integer_pk, :null => false
7       t.column "address", :inet,       :null => false
8       t.column "netmask", :inet,       :null => false
9       t.column "k",       :string,     :null => false
10       t.column "v",       :string
11     end
12
13     add_index "acls", ["k"], :name => "acls_k_idx"
14   end
15
16   def self.down
17     drop_table "acls"
18   end
19 end