Revert to bootsnap 1.3.2
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.1)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2)
8       actionpack (= 5.2.2)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2)
12       actionpack (= 5.2.2)
13       actionview (= 5.2.2)
14       activejob (= 5.2.2)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2)
18       actionview (= 5.2.2)
19       activesupport (= 5.2.2)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2)
27       activesupport (= 5.2.2)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2)
35       activesupport (= 5.2.2)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2)
38       activesupport (= 5.2.2)
39     activerecord (5.2.2)
40       activemodel (= 5.2.2)
41       activesupport (= 5.2.2)
42       arel (>= 9.0)
43     activestorage (5.2.2)
44       actionpack (= 5.2.2)
45       activerecord (= 5.2.2)
46       marcel (~> 0.3.1)
47     activesupport (5.2.2)
48       concurrent-ruby (~> 1.0, >= 1.0.2)
49       i18n (>= 0.7, < 2)
50       minitest (~> 5.1)
51       tzinfo (~> 1.1)
52     addressable (2.6.0)
53       public_suffix (>= 2.0.2, < 4.0)
54     annotate (2.7.4)
55       activerecord (>= 3.2, < 6.0)
56       rake (>= 10.4, < 13.0)
57     arel (9.0.0)
58     ast (2.4.0)
59     autoprefixer-rails (8.6.5)
60       execjs
61     better_errors (2.5.0)
62       coderay (>= 1.0.0)
63       erubi (>= 1.0.0)
64       rack (>= 0.9.0)
65     bigdecimal (1.1.0)
66     binding_of_caller (0.8.0)
67       debug_inspector (>= 0.0.1)
68     bootsnap (1.3.2)
69       msgpack (~> 1.0)
70     browser (2.5.3)
71     builder (3.2.3)
72     cancancan (2.3.0)
73     canonical-rails (0.2.5)
74       rails (>= 4.1, < 6.1)
75     capybara (2.18.0)
76       addressable
77       mini_mime (>= 0.1.3)
78       nokogiri (>= 1.3.3)
79       rack (>= 1.0.0)
80       rack-test (>= 0.5.4)
81       xpath (>= 2.0, < 4.0)
82     climate_control (0.2.0)
83     cliver (0.3.2)
84     coderay (1.1.2)
85     coffee-rails (4.2.2)
86       coffee-script (>= 2.2.0)
87       railties (>= 4.0.0)
88     coffee-script (2.4.1)
89       coffee-script-source
90       execjs
91     coffee-script-source (1.12.2)
92     composite_primary_keys (11.1.0)
93       activerecord (~> 5.2.1)
94     concurrent-ruby (1.1.4)
95     coveralls (0.8.22)
96       json (>= 1.8, < 3)
97       simplecov (~> 0.16.1)
98       term-ansicolor (~> 1.3)
99       thor (~> 0.19.4)
100       tins (~> 1.6)
101     crack (0.4.3)
102       safe_yaml (~> 1.0.0)
103     crass (1.0.4)
104     dalli (2.7.9)
105     debug_inspector (0.0.3)
106     delayed_job (4.1.5)
107       activesupport (>= 3.0, < 5.3)
108     delayed_job_active_record (4.1.3)
109       activerecord (>= 3.0, < 5.3)
110       delayed_job (>= 3.0, < 5)
111     docile (1.3.1)
112     dynamic_form (1.1.4)
113     erubi (1.8.0)
114     execjs (2.7.0)
115     exifr (1.3.6)
116     factory_bot (5.0.0)
117       activesupport (>= 4.2.0)
118     factory_bot_rails (5.0.1)
119       factory_bot (~> 5.0.0)
120       railties (>= 4.2.0)
121     fakefs (0.19.1)
122     faraday (0.15.4)
123       multipart-post (>= 1.2, < 3)
124     ffi (1.9.25)
125     fspath (3.1.0)
126     gd2-ffij (0.3.0)
127       ffi (>= 1.0.0)
128     geoip (1.6.4)
129     globalid (0.4.2)
130       activesupport (>= 4.2.0)
131     hashdiff (0.3.8)
132     hashie (3.6.0)
133     htmlentities (4.3.4)
134     http_accept_language (2.0.5)
135     i18n (0.9.5)
136       concurrent-ruby (~> 1.0)
137     i18n-js (3.2.1)
138       i18n (>= 0.6.6)
139     image_optim (0.26.3)
140       exifr (~> 1.2, >= 1.2.2)
141       fspath (~> 3.0)
142       image_size (>= 1.5, < 3)
143       in_threads (~> 1.3)
144       progress (~> 3.0, >= 3.0.1)
145     image_optim_rails (0.4.1)
146       image_optim (~> 0.24)
147       rails
148       sprockets
149     image_size (2.0.0)
150     in_threads (1.5.1)
151     jaro_winkler (1.5.2)
152     jquery-rails (4.3.3)
153       rails-dom-testing (>= 1, < 3)
154       railties (>= 4.2.0)
155       thor (>= 0.14, < 2.0)
156     jshint (1.5.0)
157       execjs (>= 1.4.0)
158       multi_json (~> 1.0)
159       therubyracer (~> 0.12.1)
160     json (2.1.0)
161     jsonify (0.3.1)
162       multi_json (~> 1.0)
163     jsonify-rails (0.3.2)
164       actionpack
165       jsonify (< 0.4.0)
166     jwt (2.1.0)
167     kgio (2.11.2)
168     kramdown (2.1.0)
169     libv8 (3.16.14.19)
170     libxml-ruby (3.1.0)
171     listen (3.1.5)
172       rb-fsevent (~> 0.9, >= 0.9.4)
173       rb-inotify (~> 0.9, >= 0.9.7)
174       ruby_dep (~> 1.2)
175     logstash-event (1.2.02)
176     logstasher (1.3.0)
177       activesupport (>= 4.0)
178       logstash-event (~> 1.2.0)
179       request_store
180     loofah (2.2.3)
181       crass (~> 1.0.2)
182       nokogiri (>= 1.5.9)
183     mail (2.7.1)
184       mini_mime (>= 0.1.1)
185     marcel (0.3.3)
186       mimemagic (~> 0.3.2)
187     method_source (0.9.2)
188     mime-types (3.2.2)
189       mime-types-data (~> 3.2015)
190     mime-types-data (3.2018.0812)
191     mimemagic (0.3.3)
192     mini_mime (1.0.1)
193     mini_portile2 (2.4.0)
194     minitest (5.11.3)
195     msgpack (1.2.6)
196     multi_json (1.13.1)
197     multi_xml (0.6.0)
198     multipart-post (2.0.0)
199     nio4r (2.3.1)
200     nokogiri (1.10.1)
201       mini_portile2 (~> 2.4.0)
202     nokogumbo (2.0.1)
203       nokogiri (~> 1.8, >= 1.8.4)
204     oauth (0.4.7)
205     oauth-plugin (0.5.1)
206       multi_json
207       oauth (~> 0.4.4)
208       oauth2 (>= 0.5.0)
209       rack
210     oauth2 (1.4.1)
211       faraday (>= 0.8, < 0.16.0)
212       jwt (>= 1.0, < 3.0)
213       multi_json (~> 1.3)
214       multi_xml (~> 0.5)
215       rack (>= 1.2, < 3)
216     omniauth (1.9.0)
217       hashie (>= 3.4.6, < 3.7.0)
218       rack (>= 1.6.2, < 3)
219     omniauth-facebook (5.0.0)
220       omniauth-oauth2 (~> 1.2)
221     omniauth-github (1.3.0)
222       omniauth (~> 1.5)
223       omniauth-oauth2 (>= 1.4.0, < 2.0)
224     omniauth-google-oauth2 (0.6.0)
225       jwt (>= 2.0)
226       omniauth (>= 1.1.1)
227       omniauth-oauth2 (>= 1.5)
228     omniauth-mediawiki (0.0.4)
229       jwt (~> 2.0)
230       omniauth-oauth (~> 1.0)
231     omniauth-oauth (1.1.0)
232       oauth
233       omniauth (~> 1.0)
234     omniauth-oauth2 (1.6.0)
235       oauth2 (~> 1.1)
236       omniauth (~> 1.9)
237     omniauth-openid (1.0.1)
238       omniauth (~> 1.0)
239       rack-openid (~> 1.3.1)
240     omniauth-windowslive (0.0.12)
241       multi_json (~> 1.12)
242       omniauth-oauth2 (~> 1.4)
243     openstreetmap-deadlock_retry (1.3.0)
244     paperclip (5.3.0)
245       activemodel (>= 4.2.0)
246       activesupport (>= 4.2.0)
247       mime-types
248       mimemagic (~> 0.3.0)
249       terrapin (~> 0.6.0)
250     parallel (1.13.0)
251     parser (2.6.0.0)
252       ast (~> 2.4.0)
253     pg (0.21.0)
254     poltergeist (1.18.1)
255       capybara (>= 2.1, < 4)
256       cliver (~> 0.3.1)
257       websocket-driver (>= 0.2.0)
258     powerpack (0.1.2)
259     progress (3.5.0)
260     psych (3.1.0)
261     public_suffix (3.0.3)
262     puma (3.12.0)
263     quad_tile (1.0.1)
264     r2 (0.2.7)
265     rack (2.0.6)
266     rack-cors (1.0.2)
267     rack-openid (1.3.1)
268       rack (>= 1.1.0)
269       ruby-openid (>= 2.1.8)
270     rack-test (1.1.0)
271       rack (>= 1.0, < 3)
272     rack-uri_sanitizer (0.0.2)
273     rails (5.2.2)
274       actioncable (= 5.2.2)
275       actionmailer (= 5.2.2)
276       actionpack (= 5.2.2)
277       actionview (= 5.2.2)
278       activejob (= 5.2.2)
279       activemodel (= 5.2.2)
280       activerecord (= 5.2.2)
281       activestorage (= 5.2.2)
282       activesupport (= 5.2.2)
283       bundler (>= 1.3.0)
284       railties (= 5.2.2)
285       sprockets-rails (>= 2.0.0)
286     rails-controller-testing (1.0.4)
287       actionpack (>= 5.0.1.x)
288       actionview (>= 5.0.1.x)
289       activesupport (>= 5.0.1.x)
290     rails-dom-testing (2.0.3)
291       activesupport (>= 4.2.0)
292       nokogiri (>= 1.6)
293     rails-html-sanitizer (1.0.4)
294       loofah (~> 2.2, >= 2.2.2)
295     rails-i18n (4.0.2)
296       i18n (~> 0.6)
297       rails (>= 4.0)
298     railties (5.2.2)
299       actionpack (= 5.2.2)
300       activesupport (= 5.2.2)
301       method_source
302       rake (>= 0.8.7)
303       thor (>= 0.19.0, < 2.0)
304     rainbow (3.0.0)
305     rake (12.3.2)
306     rb-fsevent (0.10.3)
307     rb-inotify (0.10.0)
308       ffi (~> 1.0)
309     record_tag_helper (1.0.0)
310       actionview (~> 5.x)
311     ref (2.0.0)
312     request_store (1.4.1)
313       rack (>= 1.4)
314     rinku (2.0.5)
315     rotp (4.0.2)
316       addressable (~> 2.5)
317     rubocop (0.64.0)
318       jaro_winkler (~> 1.5.1)
319       parallel (~> 1.10)
320       parser (>= 2.5, != 2.5.1.1)
321       powerpack (~> 0.1)
322       rainbow (>= 2.2.2, < 4.0)
323       ruby-progressbar (~> 1.7)
324       unicode-display_width (~> 1.4.0)
325     ruby-openid (2.7.0)
326     ruby-progressbar (1.10.0)
327     ruby_dep (1.5.0)
328     safe_yaml (1.0.4)
329     sanitize (5.0.0)
330       crass (~> 1.0.2)
331       nokogiri (>= 1.8.0)
332       nokogumbo (~> 2.0)
333     sassc (2.0.0)
334       ffi (~> 1.9.6)
335       rake
336     sassc-rails (2.1.0)
337       railties (>= 4.0.0)
338       sassc (>= 2.0)
339       sprockets (> 3.0)
340       sprockets-rails
341       tilt
342     secure_headers (6.0.0)
343     simplecov (0.16.1)
344       docile (~> 1.1)
345       json (>= 1.8, < 3)
346       simplecov-html (~> 0.10.0)
347     simplecov-html (0.10.2)
348     sprockets (3.7.2)
349       concurrent-ruby (~> 1.0)
350       rack (> 1, < 3)
351     sprockets-rails (3.2.1)
352       actionpack (>= 4.0)
353       activesupport (>= 4.0)
354       sprockets (>= 3.0.0)
355     term-ansicolor (1.7.1)
356       tins (~> 1.0)
357     terrapin (0.6.0)
358       climate_control (>= 0.0.3, < 1.0)
359     therubyracer (0.12.3)
360       libv8 (~> 3.16.14.15)
361       ref
362     thor (0.19.4)
363     thread_safe (0.3.6)
364     tilt (2.0.9)
365     tins (1.20.2)
366     tzinfo (1.2.5)
367       thread_safe (~> 0.1)
368     uglifier (4.1.20)
369       execjs (>= 0.3.0, < 3)
370     unicode-display_width (1.4.1)
371     validates_email_format_of (1.6.3)
372       i18n
373     vendorer (0.2.0)
374     webmock (3.5.1)
375       addressable (>= 2.3.6)
376       crack (>= 0.3.2)
377       hashdiff
378     websocket-driver (0.7.0)
379       websocket-extensions (>= 0.1.0)
380     websocket-extensions (0.1.3)
381     xpath (3.2.0)
382       nokogiri (~> 1.8)
383
384 PLATFORMS
385   ruby
386
387 DEPENDENCIES
388   SystemTimer (>= 1.1.3)
389   aasm
390   actionpack-page_caching
391   active_record_union
392   annotate
393   autoprefixer-rails (~> 8.6.3)
394   better_errors
395   bigdecimal (~> 1.1.0)
396   binding_of_caller
397   bootsnap (>= 1.1.0)
398   browser
399   cancancan
400   canonical-rails
401   capybara (~> 2.13)
402   coffee-rails (~> 4.2)
403   composite_primary_keys (~> 11.1.0)
404   coveralls
405   dalli
406   delayed_job_active_record
407   dynamic_form
408   factory_bot_rails
409   fakefs
410   faraday
411   gd2-ffij
412   geoip
413   htmlentities
414   http_accept_language (~> 2.0.0)
415   i18n-js (>= 3.0.0)
416   image_optim_rails
417   jquery-rails
418   jshint
419   json
420   jsonify-rails
421   kgio
422   kramdown
423   libxml-ruby (>= 2.0.5)
424   listen
425   logstasher
426   minitest (~> 5.1)
427   oauth-plugin (>= 0.5.1)
428   omniauth
429   omniauth-facebook
430   omniauth-github
431   omniauth-google-oauth2 (>= 0.6.0)
432   omniauth-mediawiki (>= 0.0.4)
433   omniauth-openid
434   omniauth-windowslive
435   openstreetmap-deadlock_retry (>= 1.3.0)
436   paperclip (~> 5.2)
437   pg (~> 0.18)
438   poltergeist
439   psych
440   puma (~> 3.7)
441   quad_tile (~> 1.0.1)
442   r2 (~> 0.2.7)
443   rack-cors
444   rack-uri_sanitizer
445   rails (= 5.2.2)
446   rails-controller-testing
447   rails-i18n (~> 4.0.0)
448   record_tag_helper
449   rinku (>= 1.2.2)
450   rotp
451   rubocop
452   sanitize
453   sassc-rails
454   secure_headers
455   uglifier (>= 1.3.0)
456   validates_email_format_of (>= 1.5.1)
457   vendorer
458   webmock
459
460 BUNDLED WITH
461    1.16.2