Merge remote-tracking branch 'upstream/pull/2237'
[rails.git] / Gemfile
1 source "https://rubygems.org"
2
3 # Require rails
4 gem "rails", "5.2.3"
5
6 # Require things which have moved to gems in ruby 1.9
7 gem "bigdecimal", "~> 1.1.0", :platforms => :ruby_19
8
9 # Require things which have moved to gems in ruby 2.0
10 gem "psych", :platforms => :ruby_20
11
12 # Require json for multi_json
13 gem "json"
14
15 # Use postgres as the database
16 gem "pg"
17
18 # Use SCSS for stylesheets
19 gem "sassc-rails"
20
21 # Use Uglifier as compressor for JavaScript assets
22 gem "uglifier", ">= 1.3.0"
23
24 # Use CoffeeScript for .js.coffee assets and views
25 gem "coffee-rails", "~> 4.2"
26
27 # Use jquery as the JavaScript library
28 gem "jquery-rails"
29
30 # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
31 # gem 'jbuilder', '~> 2.0'
32 gem "jsonify-rails"
33
34 # Reduces boot times through caching; required in config/boot.rb
35 gem "bootsnap", ">= 1.1.0", :require => false
36
37 # Use R2 for RTL conversion
38 gem "r2", "~> 0.2.7"
39
40 # Use autoprefixer to generate CSS prefixes
41 gem "autoprefixer-rails", "~> 8.6.3"
42
43 # Use image_optim to optimise images
44 gem "image_optim_rails"
45
46 # Load rails plugins
47 gem "actionpack-page_caching"
48 gem "active_record_union"
49 gem "activerecord-import"
50 gem "cancancan"
51 gem "composite_primary_keys", "~> 11.1.0"
52 gem "config"
53 gem "delayed_job_active_record"
54 gem "dynamic_form"
55 gem "http_accept_language", "~> 2.0.0"
56 gem "i18n-js", ">= 3.0.0"
57 gem "oauth-plugin", ">= 0.5.1"
58 gem "openstreetmap-deadlock_retry", ">= 1.3.0", :require => "deadlock_retry"
59 gem "paperclip", "~> 5.2"
60 gem "rack-cors"
61 gem "rails-i18n", "~> 4.0.0"
62 gem "record_tag_helper"
63 gem "rinku", ">= 2.0.6", :require => "rails_rinku"
64 gem "strong_migrations"
65 gem "validates_email_format_of", ">= 1.5.1"
66
67 # Native OSM extensions
68 gem "quad_tile", "~> 1.0.1"
69
70 # Sanitise URIs
71 gem "rack-uri_sanitizer"
72
73 # Omniauth for authentication
74 gem "omniauth"
75 gem "omniauth-facebook"
76 gem "omniauth-github"
77 gem "omniauth-google-oauth2", ">= 0.6.0"
78 gem "omniauth-mediawiki", ">= 0.0.4"
79 gem "omniauth-openid"
80 gem "omniauth-windowslive"
81
82 # Markdown formatting support
83 gem "kramdown"
84
85 # For status transitions of Issues
86 gem "aasm"
87
88 # Load libxml support for XML parsing and generation
89 gem "libxml-ruby", ">= 2.0.5", :require => "libxml"
90
91 # Use for HTML sanitisation
92 gem "htmlentities"
93 gem "sanitize"
94
95 # Load SystemTimer for implementing request timeouts
96 gem "SystemTimer", ">= 1.1.3", :require => "system_timer", :platforms => :ruby_18
97
98 # Load faraday for mockable HTTP client
99 gem "faraday"
100
101 # Load geoip for querying Maxmind GeoIP database
102 gem "geoip"
103
104 # Load rotp to generate TOTP tokens
105 gem "rotp"
106
107 # Load memcache client in case we are using it
108 gem "dalli"
109 gem "kgio"
110
111 # Load secure_headers for Content-Security-Policy support
112 gem "secure_headers"
113
114 # Load canonical-rails to generate canonical URLs
115 gem "canonical-rails"
116
117 # Used to generate logstash friendly log files
118 gem "logstasher"
119
120 # Used to generate images for traces
121 gem "gd2-ffij"
122
123 # Used for browser detection
124 gem "browser"
125
126 # Gems useful for development
127 group :development do
128   gem "annotate"
129   gem "better_errors"
130   gem "binding_of_caller"
131   gem "listen"
132   gem "vendorer"
133 end
134
135 # Gems needed for running tests
136 group :test do
137   gem "fakefs", :require => "fakefs/safe"
138   gem "minitest", "~> 5.1", :platforms => [:ruby_19, :ruby_20]
139   gem "rails-controller-testing"
140   gem "rubocop"
141   gem "rubocop-performance"
142   gem "webmock"
143 end
144
145 # Needed in development as well so rake can see konacha tasks
146 group :development, :test do
147   gem "capybara", "~> 2.13"
148   gem "coveralls", :require => false
149   gem "erb_lint", :require => false
150   gem "eslint-rails-ee"
151   gem "execjs"
152   gem "factory_bot_rails"
153   gem "poltergeist"
154   gem "puma", "~> 3.7"
155   gem "therubyracer", :platforms => :ruby
156 end