Stop pretending we support MySQL
[rails.git] / config / example.database.yml
1 # Postgresql version 8.3 recommended.
2 # See http://wiki.openstreetmap.org/wiki/OSM_Protocol_Version_0.6/postgres for detailed setup instructions.
3 #
4 development:
5   adapter: postgresql
6   database: openstreetmap
7 #  username: openstreetmap
8 #  password: openstreetmap
9   host: localhost
10   encoding: utf8
11
12 # Warning: The database defined as 'test' will be erased and
13 # re-generated from your development database when you run 'rake'.
14 # Do not set this db to the same as development or production.
15 test:
16   adapter: postgresql
17   database: osm_test
18 #  username: osm_test
19 #  password: osm_test
20   host: localhost
21   encoding: utf8
22
23 production:
24   adapter: postgresql
25   database: osm
26 #  username: osm
27 #  password: osm
28   host: localhost
29   encoding: utf8