Fix new rubocopy warnings
[rails.git] / .rubocop.yml
1 inherit_from: .rubocop_todo.yml
2
3 AllCops:
4    RunRailsCops: true
5
6 Style/BracesAroundHashParameters:
7   EnforcedStyle: context_dependent
8
9 Style/ExtraSpacing:
10   AllowForAlignment: true
11
12 Style/FileName:
13   Exclude:
14     - 'script/deliver-message'
15     - 'script/locale/reload-languages'
16     - 'script/update-spam-blocks'
17
18 Style/GlobalVars:
19   Exclude:
20     - 'lib/quad_tile/extconf.rb'
21     
22 Style/HashSyntax:
23   EnforcedStyle: hash_rockets
24   Exclude:
25     - 'lib/tasks/testing.rake'
26     - 'config/initializers/wrap_parameters.rb'
27
28 Style/StringLiterals:
29   EnforcedStyle: double_quotes