Standardise on double quoted strings
[rails.git] / Gemfile
1 source "https://rubygems.org"
2
3 # Require rails
4 gem "rails", "4.2.0"
5
6 # Require things which have moved to gems in ruby 1.9
7 gem "bigdecimal", "~> 1.1.0", :platforms => :ruby_19
8
9 # Require things which have moved to gems in ruby 2.0
10 gem "psych", :platforms => :ruby_20
11
12 # Require json for multi_json
13 gem "json"
14
15 # Use postgres as the database
16 gem "pg"
17
18 # Use SCSS for stylesheets
19 gem "sass-rails", "~> 5.0"
20
21 # Use Uglifier as compressor for JavaScript assets
22 gem "uglifier", ">= 1.3.0"
23
24 # Use CoffeeScript for .js.coffee assets and views
25 gem "coffee-rails", "~> 4.1.0"
26
27 # Use jquery as the JavaScript library
28 gem "jquery-rails"
29
30 # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
31 # gem 'jbuilder', '~> 2.0'
32 gem "jsonify-rails"
33
34 # Use R2 for RTL conversion
35 gem "r2"
36
37 # Use autoprefixer to generate CSS prefixes
38 gem "autoprefixer-rails"
39
40 # Load rails plugins
41 gem "rails-i18n", "~> 4.0.0"
42 gem "dynamic_form"
43 gem "rinku", ">= 1.2.2", :require => "rails_rinku"
44 gem "oauth-plugin", ">= 0.5.1"
45 gem "open_id_authentication", ">= 1.1.0"
46 gem "validates_email_format_of", ">= 1.5.1"
47 gem "composite_primary_keys", "~> 8.0.0"
48 gem "http_accept_language", "~> 2.0.0"
49 gem "paperclip", "~> 4.0"
50 gem "deadlock_retry", ">= 1.2.0"
51 gem "openstreetmap-i18n-js", ">= 3.0.0.rc5.3", :require => "i18n-js"
52 gem "rack-cors"
53 gem "actionpack-page_caching"
54
55 # We need ruby-openid 2.2.0 or later for ruby 1.9 support
56 gem "ruby-openid", ">= 2.2.0"
57
58 # Markdown formatting support
59 gem "redcarpet"
60
61 # Character conversion support for ruby 1.8
62 gem "iconv", "= 0.1", :platforms => :ruby_18
63
64 # Load libxml support for XML parsing and generation
65 gem "libxml-ruby", ">= 2.0.5", :require => "libxml"
66
67 # Use for HTML sanitisation
68 gem "sanitize"
69 gem "htmlentities"
70
71 # Load SystemTimer for implementing request timeouts
72 gem "SystemTimer", ">= 1.1.3", :require => "system_timer", :platforms => :ruby_18
73
74 # Load httpclient and soap4r for SOAP support for Quova GeoIP queries
75 gem "httpclient"
76 gem "soap4r-ruby1.9"
77
78 # Load memcache client in case we are using it
79 gem "dalli"
80 gem "kgio"
81
82 # Gems useful for development
83 group :development do
84   gem "vendorer"
85 end
86
87 # Gems needed for running tests
88 group :test do
89   gem "timecop"
90   gem "minitest", "~> 5.1", :platforms => [:ruby_19, :ruby_20]
91 end
92
93 # Needed in development as well so rake can see konacha tasks
94 group :development, :test do
95   gem "konacha"
96   gem "poltergeist"
97 end