Merge branch 'master' into moderation
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.1.0)
6     actioncable (5.0.5)
7       actionpack (= 5.0.5)
8       nio4r (>= 1.2, < 3.0)
9       websocket-driver (~> 0.6.1)
10     actionmailer (5.0.5)
11       actionpack (= 5.0.5)
12       actionview (= 5.0.5)
13       activejob (= 5.0.5)
14       mail (~> 2.5, >= 2.5.4)
15       rails-dom-testing (~> 2.0)
16     actionpack (5.0.5)
17       actionview (= 5.0.5)
18       activesupport (= 5.0.5)
19       rack (~> 2.0)
20       rack-test (~> 0.6.3)
21       rails-dom-testing (~> 2.0)
22       rails-html-sanitizer (~> 1.0, >= 1.0.2)
23     actionpack-page_caching (1.1.0)
24       actionpack (>= 4.0.0, < 6)
25     actionview (5.0.5)
26       activesupport (= 5.0.5)
27       builder (~> 3.1)
28       erubis (~> 2.7.0)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.0.3)
31     activejob (5.0.5)
32       activesupport (= 5.0.5)
33       globalid (>= 0.3.6)
34     activemodel (5.0.5)
35       activesupport (= 5.0.5)
36     activerecord (5.0.5)
37       activemodel (= 5.0.5)
38       activesupport (= 5.0.5)
39       arel (~> 7.0)
40     activesupport (5.0.5)
41       concurrent-ruby (~> 1.0, >= 1.0.2)
42       i18n (~> 0.7)
43       minitest (~> 5.1)
44       tzinfo (~> 1.1)
45     addressable (2.5.1)
46       public_suffix (~> 2.0, >= 2.0.2)
47     arel (7.1.4)
48     ast (2.3.0)
49     autoprefixer-rails (7.1.2.3)
50       execjs
51     bigdecimal (1.1.0)
52     builder (3.2.3)
53     canonical-rails (0.2.1)
54       rails (>= 4.1, < 5.2)
55     capybara (2.14.4)
56       addressable
57       mime-types (>= 1.16)
58       nokogiri (>= 1.3.3)
59       rack (>= 1.0.0)
60       rack-test (>= 0.5.4)
61       xpath (~> 2.0)
62     climate_control (0.2.0)
63     cliver (0.3.2)
64     cocaine (0.5.8)
65       climate_control (>= 0.0.3, < 1.0)
66     coffee-rails (4.2.2)
67       coffee-script (>= 2.2.0)
68       railties (>= 4.0.0)
69     coffee-script (2.4.1)
70       coffee-script-source
71       execjs
72     coffee-script-source (1.12.2)
73     composite_primary_keys (9.0.7)
74       activerecord (~> 5.0.0)
75     concurrent-ruby (1.0.5)
76     coveralls (0.8.21)
77       json (>= 1.8, < 3)
78       simplecov (~> 0.14.1)
79       term-ansicolor (~> 1.3)
80       thor (~> 0.19.4)
81       tins (~> 1.6)
82     crack (0.4.3)
83       safe_yaml (~> 1.0.0)
84     crass (1.0.2)
85     dalli (2.7.6)
86     deadlock_retry (1.2.0)
87     docile (1.1.5)
88     dynamic_form (1.1.4)
89     erubis (2.7.0)
90     execjs (2.7.0)
91     exifr (1.3.1)
92     factory_girl (4.8.0)
93       activesupport (>= 3.0.0)
94     factory_girl_rails (4.8.0)
95       factory_girl (~> 4.8.0)
96       railties (>= 3.0.0)
97     faraday (0.12.2)
98       multipart-post (>= 1.2, < 3)
99     ffi (1.9.18)
100     fspath (3.1.0)
101     geoip (1.6.3)
102     globalid (0.4.0)
103       activesupport (>= 4.2.0)
104     hashdiff (0.3.4)
105     hashie (3.5.6)
106     htmlentities (4.3.4)
107     http_accept_language (2.0.5)
108     i18n (0.8.6)
109     i18n-js (3.0.0)
110       i18n (~> 0.6, >= 0.6.6)
111     image_optim (0.25.0)
112       exifr (~> 1.2, >= 1.2.2)
113       fspath (~> 3.0)
114       image_size (~> 1.5)
115       in_threads (~> 1.3)
116       progress (~> 3.0, >= 3.0.1)
117     image_optim_rails (0.4.1)
118       image_optim (~> 0.24)
119       rails
120       sprockets
121     image_size (1.5.0)
122     in_threads (1.4.0)
123     jquery-rails (4.3.1)
124       rails-dom-testing (>= 1, < 3)
125       railties (>= 4.2.0)
126       thor (>= 0.14, < 2.0)
127     jshint (1.5.0)
128       execjs (>= 1.4.0)
129       multi_json (~> 1.0)
130       therubyracer (~> 0.12.1)
131     json (2.1.0)
132     jsonify (0.3.1)
133       multi_json (~> 1.0)
134     jsonify-rails (0.3.2)
135       actionpack
136       jsonify (< 0.4.0)
137     jwt (1.5.6)
138     kgio (2.11.0)
139     libv8 (3.16.14.19)
140     libxml-ruby (3.0.0)
141     listen (3.1.5)
142       rb-fsevent (~> 0.9, >= 0.9.4)
143       rb-inotify (~> 0.9, >= 0.9.7)
144       ruby_dep (~> 1.2)
145     logstash-event (1.2.02)
146     logstasher (1.2.1)
147       activesupport (>= 4.0)
148       logstash-event (~> 1.2.0)
149       request_store
150     loofah (2.0.3)
151       nokogiri (>= 1.5.9)
152     mail (2.6.6)
153       mime-types (>= 1.16, < 4)
154     method_source (0.8.2)
155     mime-types (3.1)
156       mime-types-data (~> 3.2015)
157     mime-types-data (3.2016.0521)
158     mimemagic (0.3.0)
159     mini_portile2 (2.2.0)
160     minitest (5.10.3)
161     multi_json (1.12.1)
162     multi_xml (0.6.0)
163     multipart-post (2.0.0)
164     nio4r (2.1.0)
165     nokogiri (1.8.0)
166       mini_portile2 (~> 2.2.0)
167     nokogumbo (1.4.13)
168       nokogiri
169     oauth (0.4.7)
170     oauth-plugin (0.5.1)
171       multi_json
172       oauth (~> 0.4.4)
173       oauth2 (>= 0.5.0)
174       rack
175     oauth2 (1.4.0)
176       faraday (>= 0.8, < 0.13)
177       jwt (~> 1.0)
178       multi_json (~> 1.3)
179       multi_xml (~> 0.5)
180       rack (>= 1.2, < 3)
181     omniauth (1.6.1)
182       hashie (>= 3.4.6, < 3.6.0)
183       rack (>= 1.6.2, < 3)
184     omniauth-facebook (4.0.0)
185       omniauth-oauth2 (~> 1.2)
186     omniauth-github (1.3.0)
187       omniauth (~> 1.5)
188       omniauth-oauth2 (>= 1.4.0, < 2.0)
189     omniauth-google-oauth2 (0.5.2)
190       jwt (~> 1.5)
191       multi_json (~> 1.3)
192       omniauth (>= 1.1.1)
193       omniauth-oauth2 (>= 1.3.1)
194     omniauth-mediawiki (0.0.3)
195       jwt (~> 1.0)
196       omniauth-oauth (~> 1.0)
197     omniauth-oauth (1.1.0)
198       oauth
199       omniauth (~> 1.0)
200     omniauth-oauth2 (1.4.0)
201       oauth2 (~> 1.0)
202       omniauth (~> 1.2)
203     omniauth-openid (1.0.1)
204       omniauth (~> 1.0)
205       rack-openid (~> 1.3.1)
206     omniauth-windowslive (0.0.12)
207       multi_json (~> 1.12)
208       omniauth-oauth2 (~> 1.4)
209     paperclip (4.3.7)
210       activemodel (>= 3.2.0)
211       activesupport (>= 3.2.0)
212       cocaine (~> 0.5.5)
213       mime-types
214       mimemagic (= 0.3.0)
215     parallel (1.12.0)
216     parser (2.4.0.0)
217       ast (~> 2.2)
218     pg (0.21.0)
219     poltergeist (1.15.0)
220       capybara (~> 2.1)
221       cliver (~> 0.3.1)
222       websocket-driver (>= 0.2.0)
223     powerpack (0.1.1)
224     progress (3.3.1)
225     psych (2.2.4)
226     public_suffix (2.0.5)
227     r2 (0.2.7)
228     rack (2.0.3)
229     rack-cors (1.0.1)
230     rack-openid (1.3.1)
231       rack (>= 1.1.0)
232       ruby-openid (>= 2.1.8)
233     rack-test (0.6.3)
234       rack (>= 1.0)
235     rack-uri_sanitizer (0.0.2)
236     rails (5.0.5)
237       actioncable (= 5.0.5)
238       actionmailer (= 5.0.5)
239       actionpack (= 5.0.5)
240       actionview (= 5.0.5)
241       activejob (= 5.0.5)
242       activemodel (= 5.0.5)
243       activerecord (= 5.0.5)
244       activesupport (= 5.0.5)
245       bundler (>= 1.3.0)
246       railties (= 5.0.5)
247       sprockets-rails (>= 2.0.0)
248     rails-controller-testing (1.0.2)
249       actionpack (~> 5.x, >= 5.0.1)
250       actionview (~> 5.x, >= 5.0.1)
251       activesupport (~> 5.x)
252     rails-dom-testing (2.0.3)
253       activesupport (>= 4.2.0)
254       nokogiri (>= 1.6)
255     rails-html-sanitizer (1.0.3)
256       loofah (~> 2.0)
257     rails-i18n (4.0.2)
258       i18n (~> 0.6)
259       rails (>= 4.0)
260     railties (5.0.5)
261       actionpack (= 5.0.5)
262       activesupport (= 5.0.5)
263       method_source
264       rake (>= 0.8.7)
265       thor (>= 0.18.1, < 2.0)
266     rainbow (2.2.2)
267       rake
268     rake (12.0.0)
269     rb-fsevent (0.10.2)
270     rb-inotify (0.9.10)
271       ffi (>= 0.5.0, < 2)
272     record_tag_helper (1.0.0)
273       actionview (~> 5.x)
274     redcarpet (3.4.0)
275     ref (2.0.0)
276     request_store (1.3.2)
277     rinku (2.0.2)
278     rotp (3.3.0)
279     rubocop (0.49.1)
280       parallel (~> 1.10)
281       parser (>= 2.3.3.1, < 3.0)
282       powerpack (~> 0.1)
283       rainbow (>= 1.99.1, < 3.0)
284       ruby-progressbar (~> 1.7)
285       unicode-display_width (~> 1.0, >= 1.0.1)
286     ruby-openid (2.7.0)
287     ruby-progressbar (1.8.1)
288     ruby_dep (1.5.0)
289     safe_yaml (1.0.4)
290     sanitize (4.5.0)
291       crass (~> 1.0.2)
292       nokogiri (>= 1.4.4)
293       nokogumbo (~> 1.4.1)
294     sass (3.5.1)
295       sass-listen (~> 4.0.0)
296     sass-listen (4.0.0)
297       rb-fsevent (~> 0.9, >= 0.9.4)
298       rb-inotify (~> 0.9, >= 0.9.7)
299     sass-rails (5.0.6)
300       railties (>= 4.0.0, < 6)
301       sass (~> 3.1)
302       sprockets (>= 2.8, < 4.0)
303       sprockets-rails (>= 2.0, < 4.0)
304       tilt (>= 1.1, < 3)
305     secure_headers (3.6.7)
306       useragent
307     simplecov (0.14.1)
308       docile (~> 1.1.0)
309       json (>= 1.8, < 3)
310       simplecov-html (~> 0.10.0)
311     simplecov-html (0.10.1)
312     sprockets (3.7.1)
313       concurrent-ruby (~> 1.0)
314       rack (> 1, < 3)
315     sprockets-rails (3.2.0)
316       actionpack (>= 4.0)
317       activesupport (>= 4.0)
318       sprockets (>= 3.0.0)
319     term-ansicolor (1.6.0)
320       tins (~> 1.0)
321     therubyracer (0.12.3)
322       libv8 (~> 3.16.14.15)
323       ref
324     thor (0.19.4)
325     thread_safe (0.3.6)
326     tilt (2.0.8)
327     tins (1.15.0)
328     tzinfo (1.2.3)
329       thread_safe (~> 0.1)
330     uglifier (3.2.0)
331       execjs (>= 0.3.0, < 3)
332     unicode-display_width (1.3.0)
333     useragent (0.16.8)
334     validates_email_format_of (1.6.3)
335       i18n
336     vendorer (0.1.16)
337     webmock (3.0.1)
338       addressable (>= 2.3.6)
339       crack (>= 0.3.2)
340       hashdiff
341     websocket-driver (0.6.5)
342       websocket-extensions (>= 0.1.0)
343     websocket-extensions (0.1.2)
344     xpath (2.1.0)
345       nokogiri (~> 1.3)
346
347 PLATFORMS
348   ruby
349
350 DEPENDENCIES
351   SystemTimer (>= 1.1.3)
352   aasm
353   actionpack-page_caching
354   autoprefixer-rails
355   bigdecimal (~> 1.1.0)
356   canonical-rails
357   coffee-rails (~> 4.2)
358   composite_primary_keys (~> 9.0.7)
359   coveralls
360   dalli
361   deadlock_retry (>= 1.2.0)
362   dynamic_form
363   factory_girl_rails
364   faraday
365   geoip
366   htmlentities
367   http_accept_language (~> 2.0.0)
368   i18n-js (>= 3.0.0)
369   image_optim_rails
370   jquery-rails
371   jshint
372   json
373   jsonify-rails
374   kgio
375   libxml-ruby (>= 2.0.5)
376   listen
377   logstasher
378   minitest (~> 5.1)
379   oauth-plugin (>= 0.5.1)
380   omniauth
381   omniauth-facebook
382   omniauth-github
383   omniauth-google-oauth2 (>= 0.2.7)
384   omniauth-mediawiki (>= 0.0.3)
385   omniauth-openid
386   omniauth-windowslive
387   paperclip (~> 4.0)
388   pg
389   poltergeist
390   psych
391   r2
392   rack-cors
393   rack-uri_sanitizer
394   rails (= 5.0.5)
395   rails-controller-testing
396   rails-i18n (~> 4.0.0)
397   record_tag_helper
398   redcarpet
399   rinku (>= 1.2.2)
400   rotp
401   rubocop
402   sanitize
403   sass-rails (~> 5.0)
404   secure_headers
405   uglifier (>= 1.3.0)
406   validates_email_format_of (>= 1.5.1)
407   vendorer
408   webmock
409
410 BUNDLED WITH
411    1.13.7