Use openstreetmap-oauth-plugin for now
[rails.git] / Gemfile
1 # Gem source to use
2 source 'http://rubygems.org'
3
4 # Require rails
5 gem 'rails', '3.2.3'
6
7 # Require the postgres database driver
8 gem 'pg'
9
10 # Load jquery support
11 gem 'jquery-rails'
12
13 # Load rails plugins
14 gem 'rails-i18n', ">= 0.6.3"
15 gem 'dynamic_form'
16 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
17 gem 'openstreetmap-oauth-plugin', '>= 0.4.0.1', :require => 'oauth-plugin'
18 gem 'open_id_authentication', '>= 1.1.0'
19 gem 'validates_email_format_of', '>= 1.5.1'
20 gem 'composite_primary_keys', '>= 5.0.0'
21 gem 'http_accept_language', '>= 1.0.2'
22 gem 'paperclip', '~> 2.0'
23 gem 'deadlock_retry', '>= 1.2.0'
24
25 # Markdown formatting support
26 gem 'redcarpet'
27
28 # Character conversion support for ruby 1.8
29 gem 'iconv', :platforms => :ruby_18
30
31 # Load libxml support for XML parsing and generation
32 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
33
34 # Use for HTML sanitisation
35 gem 'sanitize'
36 gem 'htmlentities'
37
38 # Load SystemTimer for implementing request timeouts
39 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer', :platforms => :ruby_18
40
41 # Load httpclient for SOAP support for Quova GeoIP queries
42 gem 'httpclient'
43
44 # Load memcache in case we are using it
45 gem 'memcached', '>= 1.4.1'
46
47 # Gems needed for running tests
48 group :test do
49   gem 'timecop'
50 end
51
52 # Gems needed for compiling assets
53 group :assets do
54   gem 'sass-rails', '~> 3.2.3'
55   gem 'coffee-rails', '~> 3.2.1'
56   gem 'uglifier', '>= 1.0.3'
57   gem 'therubyracer'
58 end