Fixed node functional tests. A couple of changes to the old_node model and node contr...
[rails.git] / test / functional / node_controller_test.rb
index 59b28e114100f17002fcf543253d41553599d5e1..a8ef700a3aba3f364c33e07b2541656297052ae1 100644 (file)
@@ -21,10 +21,14 @@ class NodeControllerTest < Test::Unit::TestCase
     # create a node with random lat/lon
     lat = rand(100)-50 + rand
     lon = rand(100)-50 + rand
-    content("<osm><node lat='#{lat}' lon='#{lon}' /></osm>")
+    # normal user has a changeset open, so we'll use that.
+    changeset = changesets(:normal_user_first_change)
+    # create a minimal xml file
+    content("<osm><node lat='#{lat}' lon='#{lon}' changeset='#{changeset.id}'/></osm>")
     put :create
     # hope for success
     assert_response :success, "node upload did not return success status"
+
     # read id of created node and search for it
     nodeid = @response.body
     checknode = Node.find(nodeid)
@@ -32,7 +36,7 @@ class NodeControllerTest < Test::Unit::TestCase
     # compare values
     assert_in_delta lat * 10000000, checknode.latitude, 1, "saved node does not match requested latitude"
     assert_in_delta lon * 10000000, checknode.longitude, 1, "saved node does not match requested longitude"
-    assert_equal users(:normal_user).id, checknode.user_id, "saved node does not belong to user that created it"
+    assert_equal changesets(:normal_user_first_change).id, checknode.changeset_id, "saved node does not belong to changeset that it was created in"
     assert_equal true, checknode.visible, "saved node is not visible"
   end
 
@@ -61,11 +65,13 @@ class NodeControllerTest < Test::Unit::TestCase
     # now set auth
     basic_authorization(users(:normal_user).email, "test");  
 
-    # this should work
+    # delete now takes a payload
+    content(nodes(:visible_node).to_xml)
     delete :delete, :id => current_nodes(:visible_node).id
     assert_response :success
 
     # this won't work since the node is already deleted
+    content(nodes(:invisible_node).to_xml)
     delete :delete, :id => current_nodes(:invisible_node).id
     assert_response :gone
 
@@ -74,6 +80,7 @@ class NodeControllerTest < Test::Unit::TestCase
     assert_response :not_found
 
     # this won't work since the node is in use
+    content(nodes(:used_node_1).to_xml)
     delete :delete, :id => current_nodes(:used_node_1).id
     assert_response :precondition_failed
   end
@@ -84,6 +91,6 @@ class NodeControllerTest < Test::Unit::TestCase
   end
 
   def content(c)
-    @request.env["RAW_POST_DATA"] = c
+    @request.env["RAW_POST_DATA"] = c.to_s
   end
 end