Update install instructions - ruby 1.9 is now required
authorDan Stowell <danstowell@users.sourceforge.net>
Tue, 17 Sep 2013 06:48:30 +0000 (07:48 +0100)
committerTom Hughes <tom@compton.nu>
Thu, 26 Sep 2013 16:14:32 +0000 (17:14 +0100)
INSTALL.md

index 7959543..744f9a1 100644 (file)
@@ -17,7 +17,7 @@ of packages required before you can get the various gems installed.
 
 ## Minimum requirements
 
-* Ruby 1.8.7 or 1.9.3
+* Ruby 1.9.3
 * RubyGems 1.3.1+
 * Postgres 8.3+
 * ImageMagick
@@ -26,13 +26,16 @@ of packages required before you can get the various gems installed.
 These can be installed on Ubuntu 10.10 or later with:
 
 ```
-sudo apt-get install ruby libruby ruby-dev rdoc ri ruby-bundler rubygems \
+sudo apt-get install ruby1.9.1 libruby1.9.1 ruby1.9.1-dev ri1.9.1 \
                      libmagickwand-dev libxml2-dev libxslt1-dev \
                      apache2 apache2-threaded-dev build-essential git-core \
                      postgresql postgresql-contrib libpq-dev postgresql-server-dev-all \
                      libsasl2-dev
+gem1.9.1 install bundle
 ```
 
+Note that the "1.9.1" Ubuntu packages do in fact contain ruby 1.9.3.
+
 ### Alternative platforms
 
 #### Fedora