Require version 0.4.0.1 of the oauth-plugin gem
authorTom Hughes <tom@compton.nu>
Tue, 24 Apr 2012 20:27:36 +0000 (21:27 +0100)
committerTom Hughes <tom@compton.nu>
Tue, 24 Apr 2012 20:27:36 +0000 (21:27 +0100)
This is special local build to fix a security issue while a new
upstream release is pending.

Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 1dab25a324e229566a956d493ca7abccf42902d0..bf1f2010d4e8a26800623cc9a6fb3f4e5c7c162a 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -14,7 +14,7 @@ gem 'jquery-rails'
 gem 'rails-i18n', ">= 0.6.3"
 gem 'dynamic_form'
 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
-gem 'oauth-plugin', '>= 0.4.0.pre7'
+gem 'oauth-plugin', '>= 0.4.0.1'
 gem 'open_id_authentication', '>= 1.1.0'
 gem 'validates_email_format_of', '>= 1.5.1'
 gem 'composite_primary_keys', '>= 5.0.0'
index 3fd9aafc9e943d1a051cefa13917985b2601845b..c6394215846faa1e1a00237261f0743ebcb2409d 100644 (file)
@@ -29,7 +29,6 @@ GEM
     activesupport (3.2.3)
       i18n (~> 0.6)
       multi_json (~> 1.0)
-    addressable (2.2.7)
     arel (3.0.2)
     builder (3.0.0)
     cocaine (0.2.1)
@@ -47,10 +46,8 @@ GEM
     erubis (2.7.0)
     execjs (1.3.0)
       multi_json (~> 1.0)
-    faraday (0.7.6)
-      addressable (~> 2.2)
+    faraday (0.8.0)
       multipart-post (~> 1.1)
-      rack (~> 1.1)
     hike (1.2.1)
     htmlentities (4.3.1)
     http_accept_language (1.0.2)
@@ -71,19 +68,20 @@ GEM
       treetop (~> 1.4.8)
     memcached (1.4.1)
     mime-types (1.18)
-    multi_json (1.2.0)
+    multi_json (1.3.2)
     multipart-post (1.1.5)
     nokogiri (1.5.2)
-    oauth (0.4.5)
-    oauth-plugin (0.4.0)
+    oauth (0.4.6)
+    oauth-plugin (0.4.0.1)
       multi_json
       oauth (~> 0.4.4)
       oauth2 (>= 0.5.0)
       rack
-    oauth2 (0.6.0)
-      faraday (~> 0.7)
+    oauth2 (0.7.0)
+      faraday (~> 0.8)
       httpauth (~> 0.1)
-      multi_json (~> 1.0)
+      multi_json (~> 1.3)
+      rack (~> 1.4)
     open_id_authentication (1.1.0)
       rack-openid (~> 1.3)
     paperclip (2.7.0)
@@ -128,7 +126,7 @@ GEM
     ruby-openid (2.1.8)
     sanitize (2.0.3)
       nokogiri (>= 1.4.4, < 1.6)
-    sass (3.1.15)
+    sass (3.1.16)
     sass-rails (3.2.5)
       railties (~> 3.2.0)
       sass (>= 3.1.10)
@@ -167,7 +165,7 @@ DEPENDENCIES
   jquery-rails
   libxml-ruby (>= 2.0.5)
   memcached (>= 1.4.1)
-  oauth-plugin (>= 0.4.0.pre7)
+  oauth-plugin (>= 0.4.0.1)
   open_id_authentication (>= 1.1.0)
   paperclip (~> 2.0)
   pg