Remove no longer needed support for old Ubuntu versions
[chef.git] / cookbooks / tools / recipes / default.rb
1 #
2 # Cookbook Name:: tools
3 # Recipe:: default
4 #
5 # Copyright 2011, OpenStreetMap Foundation
6 #
7 # Licensed under the Apache License, Version 2.0 (the "License");
8 # you may not use this file except in compliance with the License.
9 # You may obtain a copy of the License at
10 #
11 #     http://www.apache.org/licenses/LICENSE-2.0
12 #
13 # Unless required by applicable law or agreed to in writing, software
14 # distributed under the License is distributed on an "AS IS" BASIS,
15 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
16 # See the License for the specific language governing permissions and
17 # limitations under the License.
18 #
19
20 package "bash-completion"
21 package "dmidecode"
22 package "ethtool"
23 package "lsof"
24 package "lsscsi"
25 package "pciutils"
26 package "screen"
27 package "smartmontools"
28 package "strace"
29 package "sysstat"
30 package "tcpdump"
31 package "usbutils"
32 package "numactl"
33 package "xfsprogs"
34 package "sysv-rc-conf"
35 package "iotop"
36 package "lvm2"
37 package "rsyslog"
38
39 service "rsyslog" do
40   action [:enable, :start]
41   supports :status => true, :restart => true, :reload => true
42 end
43
44 # Remove unused base package
45 package "mlocate" do
46   action :purge
47 end
48
49 # Remove ubuntu "desktop" vestigal package
50 package "whoopsie" do
51   action :purge
52 end