Limit required attributes to the actions that need them
[chef.git] / cookbooks / postgresql / resources / execute.rb
1 #
2 # Cookbook:: postgresql
3 # Resource:: postgresql_execute
4 #
5 # Copyright:: 2012, OpenStreetMap Foundation
6 #
7 # Licensed under the Apache License, Version 2.0 (the "License");
8 # you may not use this file except in compliance with the License.
9 # You may obtain a copy of the License at
10 #
11 # https://www.apache.org/licenses/LICENSE-2.0
12 #
13 # Unless required by applicable law or agreed to in writing, software
14 # distributed under the License is distributed on an "AS IS" BASIS,
15 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
16 # See the License for the specific language governing permissions and
17 # limitations under the License.
18 #
19
20 default_action :run
21
22 property :command, :kind_of => String, :name_property => true
23 property :cluster, :kind_of => String, :required => true
24 property :database, :kind_of => String, :required => true
25 property :user, :default => "postgres"
26 property :group, :default => "postgres"
27
28 action :run do
29   options = { :database => new_resource.database, :user => new_resource.user, :group => new_resource.group }
30
31   converge_by "execute #{new_resource.command}" do
32     if ::File.exist?(new_resource.command)
33       cluster.execute(options.merge(:file => new_resource.command))
34     else
35       cluster.execute(options.merge(:command => new_resource.command))
36     end
37   end
38 end
39
40 action_class do
41   def cluster
42     @cluster ||= OpenStreetMap::PostgreSQL.new(new_resource.cluster)
43   end
44 end