Use passenger 4 on production servers
[chef.git] / cookbooks / passenger / attributes / default.rb
1 default[:passenger][:version] = 5
2 default[:passenger][:ruby_version] = "1.9.1"
3 default[:passenger][:max_pool_size] = 6
4 default[:passenger][:pool_idle_time] = 300
5
6 if node[:passenger][:version] == 4
7   default[:apt][:sources] = node[:apt][:sources] |  ["brightbox-ruby-ng", "passenger4"]
8 else
9   default[:apt][:sources] = node[:apt][:sources] |  ["brightbox-ruby-ng", "passenger"]
10 end